dovecot -n silently reports wrong configuration when using dovecot-postfix

Bug #511295 reported by Timo Sirainen on 2010-01-22
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
dovecot (Ubuntu)
Low
Unassigned

Bug Description

dovecot-postfix package uses dovecot-postfix.conf by giving it with -c parameter to all dovecot binaries. So when people ask for help about Dovecot, they paste dovecot -n output as requested, but this outputs wrong configuration and gets everyone confused. They'd need to give dovecot -n -c /etc/dovecot/dovecot-postfix.conf, but this isn't obvious.

It would have been nice if Ubuntu hadn't used a different config file, but since I can't do anything about it, I hope you'll add this patch (applies without errors also to v1.1 hg tip): http://hg.dovecot.org/dovecot-1.2/rev/142c935e44d6

With it dovecot -n gives a nice warning that hopefully points users towards the solution:

Warning: Dovecot was last started using /etc/dovecot/dovecot-postfix.conf, but this config is /etc/dovecot.conf

Related branches

On Fri, Jan 22, 2010 at 06:13:07PM -0000, Timo Sirainen wrote:
> Public bug reported:
>
> dovecot-postfix package uses dovecot-postfix.conf by giving it with -c
> parameter to all dovecot binaries. So when people ask for help about
> Dovecot, they paste dovecot -n output as requested, but this outputs
> wrong configuration and gets everyone confused. They'd need to give
> dovecot -n -c /etc/dovecot/dovecot-postfix.conf, but this isn't obvious.
>
> It would have been nice if Ubuntu hadn't used a different config file,
> but since I can't do anything about it, I hope you'll add this patch
> (applies without errors also to v1.1 hg tip):
> http://hg.dovecot.org/dovecot-1.2/rev/142c935e44d6
>
> With it dovecot -n gives a nice warning that hopefully points users
> towards the solution:
>
> Warning: Dovecot was last started using /etc/dovecot/dovecot-
> postfix.conf, but this config is /etc/dovecot.conf
>

Right. We should revisit this dovecot-postfix.conf configuration file as this
poses a lot of user support questions.

 importance low
 status triaged

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

Changed in dovecot (Ubuntu):
importance: Undecided → Low
status: New → Triaged

This leads to another effect: the dovecot deliver command may complain like this "Fatal: postmaster_address setting not given". The problem is, that dovecot's deliver command defined in master.cf needs the -c parameter too:

dovecot unix - n n - - pipe
  flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -c /etc/dovecot/dovecot-postfix.conf -f ${sender} -d ${recipient}

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dovecot - 1:1.2.9-1ubuntu6

---------------
dovecot (1:1.2.9-1ubuntu6) lucid; urgency=low

  [Ante Karamatic]
  * dovecot-example.conf, debian/dovecot-common.dirs, debian/01-dovecot-postfix.auth,
       debian/01-dovecot-postfix.conf, debian/control, debian/dovecot-postfix.dirs,
       debian/dovecot-postfix.postinst, debian/dovecot-postfix.postrm, debian/dovecot-postfix.preinst,
       debian/rules:
       * Fix dovecot -n not to report wrong configuration. (LP: #511295)
 -- Chuck Short <email address hidden> Mon, 19 Apr 2010 13:13:20 -0400

Changed in dovecot (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers