[ffe] update dovecot to 1.1.4

Bug #281423 reported by Mathias Gug on 2008-10-10
4
Affects Status Importance Assigned to Milestone
dovecot (Ubuntu)
Undecided
Unassigned

Bug Description

I'd like to request a FFexception for dovecot 1.1.4. The new release mainly focuses on fixing indexing issues as well as mbox crashes.

Upstream changelog:

v1.1.4 2008-10-05 Timo Sirainen <email address hidden>

        - SORT: Yet another assert-crashfix when renumbering index sort IDs.
        - ACL plugin fixes: Negative rights were actually treated as positive
          rights. 'k' right didn't prevent creating parent/child/child mailbox.
          ACL groups weren't working.
        - Maildir++ quota: Fixes to rebuilding when quota limit wasn't
          specified in Dovecot (0 limit or limit read from maildirsize).
        - mbox: Several bugfixes causing errors and crashes.
        - Several fixes to expire plugin / expire-tool.
        - lock_method=dotlock could have deadlocked with itself.
        - Many error handling fixes and log message improvements.

v1.1.3 2008-09-02 Timo Sirainen <email address hidden>

        * mail_max_userip_connections limit no longer applies to master user
          logins.

        + login_log_format_elements: Added %k to show SSL protocol/cipher
          information. Not included by default.
        + imap/pop3-proxy: If auth_verbose=yes, log proxy login failures.
        + deliver: Added -s parameter to autosubscribe to autocreated mailboxes.
        - message parser fixes - hopefully fixes an infinite looping problem
        - SORT: One more assert-crashfix when renumbering index sort IDs.
        - mbox: Saving may have truncated the mail being saved
        - mbox: Several other bugfixes
        - mail_full_filesystem_access=yes was broken when listing mailboxes
          (it still is with maildir++ layout).
        - maildirlock utility was somewhat broken
        - zlib plugin: bzip2 support was somewhat broken
        - NFS: Make sure writing to files via output streams don't
          assert-crash when write() returns only partial success.

The merge from Debian experimental also enabled to following feature:

  * debian/control: added libbz2-dev to the Build-Depends to enable the bzip2
    support. (Closes: #495129)

The package builds on i386 and amd64. It also installs and upgrades correctly. All of the dovecot tests from the qa-regression-testing suite are also successful.

Related branches

Mathias Gug (mathiaz) wrote :
Steve Langasek (vorlon) wrote :

FFe approved, please upload ASAP since this changeset is on the large side.

Changed in dovecot:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dovecot - 1:1.1.4-0ubuntu1

---------------
dovecot (1:1.1.4-0ubuntu1) intrepid; urgency=low

  * New upstream release (LP: #281423):
    - Fix message parser.
    - Fix maildirlock utility.
    - Fix bzip2 support in zlib plugin.
    - mbox: Several bugfixes causing errors and crashes.
    - Many error handling fixes and log message improvements.
    - SORT: Fix assert-crashes.
  * Update dovecot-managesieve patch for 1.1.4.
  * debian/control:
    - Update Vcs-* headers.
  * Merge from debian experimental, remaining changes:
    - Use Snakeoil SSL certificates by default.
      + debian/control: Depend on ssl-cert
      + debian/paptches/ssl-cert-snakeoil.dpatch: Change default SSL cert
        paths to snakeoil.
      + debian/dovecot-common.postinst: Relax grep for SSL_* a bit.
    - Add autopkgtest in debian/tests/*.
    - Don't fail in postinst if dovecot-{sql,ldap} is missing. (LP: #153161)
    - debian/dovecot-common.init: Check to see if there is an /etc/inetd.conf.
      (LP: #208411)
    - debian/patches/login-max-process-count-warning.dpatch: Tell the user
      that they have reached the maximum number of processes count.
      (LP: #189616)
    - Fast TearDown: Update lsb init header to not stop in level 6.
    - Add status action to the init script:
      + debian/control: Depend on lsb >= 3.2.12ubuntu3.
      + debian/dovecot-common-init: Add the 'status' action (LP: #247096).
    - debian/rules:
      - Copy config.{guess,sub} after running libtoolize.
      - Clean dovecot-managesieve directory.
    - debian/patches/fix-dovecot-sieve.dpatch: Fixes assertion error
      when a header string ends with a LF (LP: #264306)
    - Add ufw integration:
      - Created debian/dovecot-common.ufw.profile
      - debian/rules:
        + install profile
      - debian/control
        + Suggest ufw
    - debian/{control,rules}: enable PIE hardening
    - Updated dovecot.common.README.Debian with information on what has changed
      between 1.0 and 1.1.1. Fixes (LP: #257625)
    - dovecot-imapd, dovecot-pop3: Replaces dovecot-common (<< 1:1.1). LP: #254721.
  * Dropped:
    - debian/dovecot-common.postinst: Remove stop script symlinks fom rc0
      and rc6 on upgrades. Need to be kept until next LTS release.
    - Fast TearDown:
      + debian/rules: Call dh_installinit in 'multiuser' mode.
      + debian/control: Depend on new sysv-rc for this.
    - Include dovecot-sieve-1.1.5: available in Debian.

 -- Mathias Gug <email address hidden> Fri, 10 Oct 2008 16:05:33 -0400

Changed in dovecot:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers