DosEMU compiled without X support

Bug #53996 reported by David Marín on 2006-07-25
16
Affects Status Importance Assigned to Milestone
Dapper Backports
Undecided
Unassigned
Baltix
Low
Mantas Kriaučiūnas
Debian
Fix Released
Unknown
Ubuntu
Dapper
Undecided
Unassigned
dosemu (Ubuntu)
Undecided
StefanPotyra

Bug Description

Binary package hint: dosemu

Whenever I try to start dosemu under X with "xdosemu" I get the following message:

"ERROR: X support not compiled in"

and dosemu runs in the terminal, not generating its own window. This is fatal for me, as I need to run a graphical DOS application.

Bart Martens (bartm) wrote :

Which version are you using? This was fixed in Debian some time ago. See this Debian bug report:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=370021

David Marín (davefx) wrote :

Yes: using the current version in Debian unstable fixes the problem. It's just an problem in the Ubuntu Dapper version.

Mantas Kriaučiūnas (mantas) wrote :

Dosemu from Ubuntu Breezy doesn't have this problem - only dosemu from Ubuntu dapper is compiled without X support.
I'm suggesting to fix this bug ASAP and replace buggy dosemu in Ubuntu Dapper with version with X support.

Changed in dosemu:
status: Unconfirmed → Confirmed
Adrian R Goalby (argoalby) wrote :

Had same problem with Ubuntu Dapper.

Installed dosemu_1.2.2-5_i386.deb (from Debian testing) and it seems to work properly in X window, terminal window or after text mode login.

Had to force the install because of slight version difference in libc6 between Debian testing and Ubuntu Dapper, but still seems to work.

Download your own Debian/testing dosemu from

http://packages.debian.org/testing/otherosfs/dosemu

StefanPotyra (sistpoty) wrote :

Hi,

this is fixed with the edgy version of dosemu (1.2.2-5ubuntu1). I'll try to see if I can get that version backported to dapper, but that might take some time.

Cheers,
      Stefan.

Changed in dosemu:
assignee: nobody → sistpoty
status: Confirmed → Fix Released
Adrian R Goalby (argoalby) wrote :

Dapper is Ubuntu 6.06 LTS (Long Term Support)

I think this implies that a backport is required. Edgy is not released yet, and even then support for Dapper will still be required.

This Bug #53996 together with Bug #53384 and Bug #52857 against dosemu-freedos all need to be fixed to get dosemu working properly on Ubuntu. None require upstream patches, they just require using the correct versions from upstream.

Dosemu has been around for a few years and I think most Linux users would expect all releases of Ubuntu to have a working version.

Please remove the status of "Fix Released" until Dapper has actually been fixed (no bug report was raised against Edgy), importance of "Medium" would also seem appropriate.

John Dong (jdong) wrote :

Looking into it.

Changed in dapper-backports:
status: Unconfirmed → Confirmed
John Dong (jdong) wrote :

 -> Considering debhelper (>= 5.0.35)
      Tried versions: 5.0.7ubuntu13
   -> Does not satisfy version, not trying
===

Does not cleanly build in Dapper. Not easily backportable.... dapper-updates is the other possibility then.

Changed in dapper-backports:
status: Confirmed → Rejected
StefanPotyra (sistpoty) wrote :

sorry for the long time this bug is present...
@John: I meant to bring this into dapper-updates anyway

The problem is, that we still don't have a StableReleaseUpdate-Policy for universe, but I hope that will be discussed in the next few weeks now.

Cheers,
   Stefan.

StefanPotyra (sistpoty) wrote :

Hi,

sorry for the extreme delay. Finally there is a fixed package in the dapper-proposed archive, which needs to be tested. It would be great, if you could help testing and leave a comment on bug #72951 if the package solves the problems (or also if it doesn't work for you).

Thanks,
   Stefan.

StefanPotyra (sistpoty) wrote :

Package in dapper-updates now.

Przemek K. (azrael) on 2009-11-20
Changed in baltix:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.