Doesn't have a .desktop file

Bug #48292 reported by Wouter Stomp on 2006-06-03
16
Affects Status Importance Assigned to Milestone
dosbox (Debian)
Fix Released
Unknown
dosbox (Ubuntu)
Wishlist
Emmet Hikory

Bug Description

Binary package hint: dosbox

Dosbox doesn't have a .desktop file and therefore doesn't appear in the menus.

Revision history for this message
William Grant (wgrant) wrote :

Yep, no .desktop in the package.

Changed in dosbox:
status: Unconfirmed → Confirmed
Changed in dosbox:
assignee: nobody → pandisv
Revision history for this message
Vassilis Pandis (pandisv) wrote : .desktop

It shows in the Gnome menu under Others and validates. I found no icon for this package (looked in the upstream website and in the source package).

Changed in dosbox:
assignee: pandisv → nobody
Changed in dosbox:
status: Unknown → Unconfirmed
Revision history for this message
delvalle26 (bassaf) wrote :

In dosbox 0.65, the icon is in the src directory of the source tarball...

dosbox.ico

:)

Changed in dosbox:
assignee: nobody → motu
Revision history for this message
Emmet Hikory (persia) wrote :

Imagemagick 6.2.4.5.dsfg1-0.13 cannot convert the src/dosbox.ico provided with dosbox 0.65-1, and I have had no success with other editors. If someone could extract the icon, I would be happy to produce a debdiff.

Emmet Hikory (persia) on 2007-01-08
Changed in dosbox:
status: Confirmed → Needs Info
Changed in dosbox:
assignee: motu → nobody
Revision history for this message
Siegfried Gevatter (rainct) wrote :

I did a "screen print" and cut the icon from there with The Gimp, then resized and saved it as .png and .xpm.

Revision history for this message
Siegfried Gevatter (rainct) wrote :

The .xpm icon is acceptable, so I don't thing we need to include the .png into the package. It could be send to upstream, although.

Revision history for this message
Siegfried Gevatter (rainct) wrote :

I asked upstream to upload the PNG: http://vogons.zetafleet.com/viewtopic.php?p=108867

Will do a debdiff now.

Changed in dosbox:
assignee: nobody → rainct
status: Needs Info → In Progress
Revision history for this message
Siegfried Gevatter (rainct) wrote :
Changed in dosbox:
assignee: rainct → nobody
status: In Progress → Confirmed
Revision history for this message
Emmet Hikory (persia) wrote :

Thanks for the icon and debdiff. A few notes:

1) It's considered polite to credit the author of a file in the changelog, as:

  * Added a .desktop from Vassilis Pandis (LP: #48292)
  * Added an icon for the .desktop and menu

2) You menu file doesn't parse. If everything isn't on a single line, it needs a \ at the end of the previous line.

3) The .desktop standards have changed since the original file submission. Check the .desktop file with desktop-file-validate to see if any additional changes are required prior to upload.

4) When uploading a debdiff, if you need sponsorship, be sure to follow the guidelines listed at https://wiki.ubuntu.com/SponsorshipProcess. If you don't want to use the script, just attach the debdiff to the bug and subscribe the appropriate team.

Revision history for this message
Siegfried Gevatter (rainct) wrote :

This should fix points 1, 2 and 3. Don't know if it will work since I did it with Notepad and on a Windows machine, will check it this evening at home.

Changed in dosbox:
assignee: nobody → rainct
status: Confirmed → In Progress
Revision history for this message
Emmet Hikory (persia) wrote :

Good try :) It doesn't quite install cleanly (specifically, if you edit a diff file by hand, you need to make sure you have the correct context and that the index codes are correct). Please attach the revised debdiff when you have a chance to test.

Revision history for this message
Siegfried Gevatter (rainct) wrote :

Here is the new .desktop file (this one validates). Put the category as "Utility", don't know if it should be "Game" instead.

Also I included some translations:
 - Catalan, German and Spanish (by myself)
 - Dutch (by mathijs and JanC)
 - Italian (by hocompratov)
 - Russian (by Castor_Troy, skyrider and arzt)

Revision history for this message
Siegfried Gevatter (rainct) wrote :

Okay, here you have the new debdiff.

Also added a Ukrainian translation, too, by skyrider.

Revision history for this message
Siegfried Gevatter (rainct) wrote :

I tried to generate a deb (dpkg-buildpackage -rfackeroot) but it complained about "SDL_sound.h" not existing (build dependencies are installed). Is this a local problem?

Changed in dosbox:
assignee: rainct → nobody
status: In Progress → Confirmed
Revision history for this message
Emmet Hikory (persia) wrote :

Thanks for the debdiff, and apologies for the delay. Could you please regenerate against dosbox 0.70-0ubuntu1?

Changed in dosbox:
assignee: nobody → persia
status: Confirmed → In Progress
assignee: persia → rainct
status: In Progress → Needs Info
Revision history for this message
Siegfried Gevatter (rainct) wrote :
Changed in dosbox:
assignee: rainct → nobody
status: Needs Info → Confirmed
Emmet Hikory (persia) on 2007-06-08
Changed in dosbox:
assignee: nobody → persia
status: Confirmed → In Progress
Revision history for this message
Emmet Hikory (persia) wrote :

Please also consider sending the .xpm and .desktop files to the Debian bug, to make it easy for Debian to absorb these changes.

Changed in dosbox:
status: In Progress → Fix Committed
Revision history for this message
Siegfried Gevatter (rainct) wrote :

Done ;)

Revision history for this message
Siegfried Gevatter (rainct) wrote :

dosbox (0.70-0ubuntu2) gutsy; urgency=low

  * Added a .desktop based upon one from Vassilis Pandis (LP: #48292)
  * Added an icon for the .desktop and the menu

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Fri, 8 Jun 2007 15:21:54 +0200

Changed in dosbox:
status: Fix Committed → Fix Released
Changed in dosbox:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.