Imperfect text information in .desktop file

Bug #177203 reported by Kirill Chunaev on 2007-12-18
6
Affects Status Importance Assigned to Milestone
dosbox (Debian)
Fix Released
Unknown
dosbox (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: dosbox

I want to make two suggestions about .desktop file of this package:
1) Name section of .desktop file sounds for now as "Dosbox Emulator". I think it is quite reasonable to rename this section to "DOSBox". The official way of writing is "DOSBox", not "Dosbox", and I think there isn't any reason to use word "Emulator" additionally, because this word appeared in comment section.
2) Comment section of .desktop file sounds for now as "An emulator to run old DOS games". It's fine, but we can use DOSBox not only for games, but for any other DOS applications. Maybe it's better to correct this comment to something like "A DOS emulator" or "An emulator to run old DOS applications"?
What do you think about my suggestions? It's important for me.

Related branches

Changed in dosbox:
importance: Undecided → Low
Siegfried Gevatter (rainct) wrote :

Thanks for taking the time to report this and helping make Ubuntu better. I'll have look at this soon.

Notes:

1) The word "Emulator" should be conserved in the name according to the latest FreeDesktop.org specs (menu entries should be descriptives by themselves, without the need to look at the comment; look at other entries and you'll see that most of them -except the games- follow this).

2) Also because of the latests specifications, comments should start with a verb. So an appropriate description, considering your comments, would be something like: «Run old DOS applications».

Changed in dosbox:
status: New → In Progress
Changed in dosbox:
assignee: nobody → rainct
Siegfried Gevatter (rainct) wrote :

dosbox (0.72-0.1ubuntu1) hardy; urgency=low

  * debian/dosbox.desktop: (LP: #177203)
     - Fix name capitalization.
     - Remove extension from icon name.
     - Change ca/de/en/es descriptions so that they refer to
       "applications" in general instead of "games".
     - Change "Game" category to "Utility".
  * Bump standards version to 3.7.3:
     - Move Homepage field to source stanza.
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Fri, 28 Dec 2007 15:47:17 +0100

Changed in dosbox:
assignee: rainct → nobody
status: In Progress → Confirmed
Changed in dosbox:
status: Unknown → New
Emmet Hikory (persia) on 2008-01-02
Changed in dosbox:
assignee: nobody → persia
status: Confirmed → In Progress
Emmet Hikory (persia) wrote :

Uploaded. Thanks.

Changed in dosbox:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dosbox - 0.72-0.1ubuntu1

---------------
dosbox (0.72-0.1ubuntu1) hardy; urgency=low

  * debian/dosbox.desktop: (LP: #177203)
     - Fix name capitalization.
     - Remove extension from icon name.
     - Change ca/de/en/es descriptions so that they refer to
       "applications" in general instead of "games".
     - Change "Game" category to "Utility".
  * Bump standards version to 3.7.3:
     - Move Homepage field to source stanza.
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Fri, 28 Dec 2007 15:47:17 +0100

Changed in dosbox:
status: Fix Committed → Fix Released

Hello!
I don't want to open a new bug in launchpad, but I have new suggestions
about dosbox package:
1) Can you correct two errors in description of this deb-package? It is
necessary to improve "Dosbox" into "DOSBox" and remove hyphen from
"DOS-games" in text of this description.
2) I've improved "Name" and "Comment" sections in Russian and Ukrainian.
Please, improve these sections in other languages (all, expect English,
Russian and Ukrainian). I've attached my .desktop file to this message.
Is it late to add this improvements to new dosbox-0.72-0.1ubuntu1 package?
Thanks for all.

Siegfried Gevatter (rainct) wrote :

1) That's the same you reported before, and is now fixed in version 0.72-0.1ubuntu1 ;).

2) Yes, the new version is already published in Hardy. I would prefer not to upload (and re-compile for all platforms) dosbox for a minor change again so, can you please send a message to <email address hidden> telling what the new comments in Russian and Ukrainian should be, so that this can be fixed in Debian instead and come into the next Ubuntu version after Hardy? (Note that they should start with a verb; for reference, the new English description is «Run old DOS applications»).

Thanks!

Kirill Chunaev (kirchun) wrote :

You didn't understand my first paragraph. I've told about description in
file named "control" of .deb package, not about .desktop file. Everybody
can see description of .deb package in Synaptic...

Siegfried Gevatter (rainct) wrote :

Ah, right.

Hm... Can you report this to <email address hidden>, too?

Thanks,

--
Siegfried-Angel Gevatter Pujals (RainCT)
GNU/Linux User #438657. Ubuntu User #11680.

Kirill Chunaev (kirchun) wrote :

I've installed new dosbox package. I have one question to you: why did you
change "Game" category to "Utility" category? Maybe it is reasonable to
change "Game" category to "System" category? Similar application DOSEMU
has "System" category, because it is PC-emulator. What do you think about
it? Can anybody else give good advice to us? It's important for newbie
users of Ububntu, I think.
Maybe you will remake package nevertheless? Hardy's packaging will be
finishing at least at February...
Sorry for my energy. I'm perfectionist and wanna to make Ubuntu much
better.

Changed in dosbox:
assignee: persia → nobody
Changed in dosbox:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.