Ubuntu

servicemenu for amarok has an invalid menu entry "addAsPodcast"

Reported by Christian Schürer-Waldheim on 2008-03-07
90
Affects Status Importance Assigned to Milestone
dolphin (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: dolphin

As soon as I select a file to preview or open its context menu, I get the following error message twice:

The desktop entry file
/usr/share/apps/d3lphin/servicemenus/amarok_addaspodcast.desktop
has an invalid menu entry
addAsPodcast.

There is a similar service menu file in the amarok package, maybe that one can be used or copied.

dolphin:
  Installed: 0.9.2-0ubuntu5

TESTCASE:
Open Dolphin, open a directory with XML files (example: /usr/share/mime/multipart/);
move mouse over XML file.
- If dolphin doesn't throw up a popup complaining about an invalid menu entry, it's fixed.

To fix this problem temporary, just copy the service menu:

sudo cp /usr/share/apps/konqueror/servicemenus/amarok_addaspodcast.desktop /usr/share/apps/d3lphin/servicemenus/amarok_addaspodcast.desktop

clickwir (clickwir) wrote :

I can confirm that I got this same error when just mousing over a .html file in Dolphin. So far, mousing over or selecting any other file type seems ok.

Kubuntu Hardy.

$uname -a
Linux mach 2.6.24-12-generic #1 SMP Wed Mar 12 22:31:43 UTC 2008 x86_64 GNU/Linux

clickwir (clickwir) wrote :

Confirmed bug.

Changed in dolphin:
status: New → Confirmed
vista killer (vistakiller) wrote :

Same problem here in kubuntu hardy heron kde 3.5.9

Gulok (gulok) wrote :

Same problem, when I move mouse over .htm file in Dolphin.

Kubuntu Hardy Heron Beta kde 3.5.9

Linux ja-desktop 2.6.24-12-generic #1 SMP Wed Mar 12 23:01:54 UTC 2008 i686 GNU/Linux

Bipolar (bipolar) wrote :

Exact same problem here on up to date Hardy. Every time I hover over an html file in Dolphin. Works fine in Konq.

It would be very good idea if we had one folder for servicemenu files (example /usr/share/servicemenus) but also programs had their own folder, because they can have servicemenu files what others doesn't need. This would ease to edit and translate servicemenu files, because we don't have to copy all the time our changes from one to another.

ernest (ernest-bywater) wrote :

When I right click on a html, htm, or xhtml file to open the menu so as to select the editing program to edit the file, I get an error message which reads:

quote

The desktop Entry File

/usr/share/apps/d3lphin/servicemenus/amarok_adaspodcast.desktop

has an invalid menu entry

addAsPodcast

end quote

The file mentioned reads:

quote

[Desktop Entry]
ServiceTypes=text/html,text/xml,application/xml,text/rss
Actions=addAsPodcast
[Desktop Action addAsPodcast]
Name=Add as podcast to amaroK
Name[de]=Als Podcast zu amaroK hinzufügen
Icon=amarok
X-Ubuntu-Gettext-Domain=desktop_dolphin

end quote

I did try using the System Settings to adjust the File Associations, but that has no effect.

I have no podcast equipment, have not activated any podcast software, and am unable to access and edit the file to remove this line as I'm using Kubuntu 8.04 and not being a Linux guru I don't know how to get the system to let me into root to change this via the command line.

I didn't have this problem with the Kubuntu 8.04 RC I upgraded to during the week, and now I have this problem - it didn't happen before the upgrade.

This problem doesn't crash the system but it is extremely annoying as it happens every time I right click a html or hml file, after giving the error sound, I can then go on with what I wish to do; but I'm about to start development of a major web site and could do without this bloody noise all the time.

Thank you

Christian Iversen (chrivers) wrote :

I can confirm this bug on Hardy. I can also confirm that the temp fix proposed by Christian Schuerer works. I don't know if it's the right fix or not, but it did make dolphin stop spewing errors.

Timbuck.3 (timbuck-3) wrote :

Same problem here in kubuntu hardy heron kde 3.5.9

Linux XXXXxx 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux

I just erased the content of this file ----> amarok_addaspodcast.desktop It fixes the bug

Must be a better way to solve this bug, I'll try the fix proposed by Christian Schuerer...

Mordac85 (ib17037) wrote :

I just finished upgrading to Hardy, from Gutsy, and rcvd this same error. Previously in Gutsy, I had removed Amarok and the upgrade reinstalled it. Removing it again caused the error, so I had to reinstall it yet again and run the file copy above. After uninstalling Amarok again, it's still in /usr/share/apps/d3lphin/servicemenus/ and all seems to be working fine.

Does anyone know where what reference is looking for this file and can we resolve the issue somehow other than having an unnecessary file lying around?

Doug Jones (djsdl) wrote :

I looked at the amarok_addaspodcast.desktop file and compared it with a number of other amarok*.desktop files in the same folder. This one differed in that it had no Exec line in it. I added one after the Icon line:

Exec=amarok -a %u

I have no idea if this is actually the correct line to use, as the amarok docs I found were not very instructive on this issue. (I'm sure it helps that I know little about amarok.)

But, adding this line to the file eliminated the bad behavior.

In any case, it would be a mistake to consider this merely a bug in a .desktop file. The biggest bug is in dolphin itself. An app shouldn't start behaving like a popup-mad web browser from the bad old days just because a config file is wrong. If it finds a bad .desktop file, it should skip it (and maybe log the error somewhere).

I tried dragging a selection box around a list of files in a dolphin window and it went crazy with endless identical dialog boxes that I just couldn't close fast enough. And the pane to the right with context-sensitive options started replicating itself down the window. I couldn't close dolphin, and eventually had to restart the xserver.

So this appears to be two bugs: One in dolphin itself, and one in the file amarok_addaspodcast.desktop .

James Dunmore (james-dunmore) wrote :

"Doug Jones wrote on 2008-04-29"

Agree 100% (for what it's worth!)

Your temporary fix "Exec=amarok -a %u" works for now though - thanks

pschoond (paul-pollux-it) wrote :

Compared the file with /usr/share/apps/konqueror/servicemenus/amarok_addaspodcast.desktop and the line that is missing is indeed:

Exec=dcop amarok playlistbrowser addPodcast %u

After adding this line to /usr/share/apps/d3lphin/servicemenus/amarok_addaspodcast.desktop you now get an option (Actions) to add the url as a podcast to Amarok (sounds obvious doesn't it :-) when rightclicking on any html file.

I verfied this indeed adds the url as a podcast

Problem solved

Regards,

Paul

gloygum (gloy) wrote :

Can confirm that adding

Exec=dcop amarok playlistbrowser addPodcast %u

fixes problem. Thanks for sorting this one!

karl (karl-sebastian-liebich) wrote :

same here. but I experience that behaviour with a certain bunch of pdf-files. Only that folder is concerned. The files are from the same source, maybe there is a content in them causing the error while loading the preview. No other pdf is concerned.

Linux goatfish 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux
Kubuntu 8.04 64bit

karl (karl-sebastian-liebich) wrote :

dolphin seems to recognize that particular pdf-files as html-files. That will be the reason.

Darrell Hare (dbh-eastlink) wrote :

I'm having the same problem. I'm running Kubuntu (Hardy) KDE3. When I get anywhere near a particular html file in Dolphin I get the same error as you guys. I tried the fix but I think I got it wrong. I'm kinda new so can some one give me a step by step procedure to get rid of this?
harecanada

Darrell Hare (dbh-eastlink) wrote :

I tried Christian Schuerer's suggestion and it solved the bug for me. I was wondering though , Christian, why did you say "temporary" ? Will it come back?
harecanada

Kevin Christmas (kachristmas) wrote :

If the fix is so simple, why hasn't it been fixed? I hope the Kubuntu devs aren't wondering where the opinion that "Kubuntu lacks polish," comes from.

simion314 (simion314) wrote :

i confirm that the that fix above works.
for beginers a step by step guide:
1 edit and fix the file /usr/share/apps/d3lphin/servicemenus/amarok_addaspodcast.desktop, i use kate to edit

sudo kate /usr/share/apps/d3lphin/servicemenus/amarok_addaspodcast.desktop

2 the editor opens and you must add the line

Exec=dcop amarok playlistbrowser addPodcast %u

3save the file and maybe restart delpin.

Thx to pschoond for the fix.

The Ubuntu bug team should fix this and make an update to fix this.

Adam Spain (adamspain) wrote :

Attached is a debdiff that should fix this in Intrepid. I've also uploaded packages with this fix for Hardy to my PPA, which people can test/use to fix this bug:

https://launchpad.net/~adamspain/+archive

I think it would be good if this could be fixed in a Stable Release Update for Hardy as it is pretty annoying. My understanding of the process is that it would need to be fixed in Intrepid first though, so that's what this debdiff does. I'm pretty new to fixing packages, so please point out any mistakes.

Adam Spain's fix (the packages in your PPA) works well for me. Step to
test: Open Dolphin, open a directory with XML files (example:
/usr/share/mime/multipart/); move mouse over XML file. If dolphin
doesn't bark, it's fixed.

FWIW, an SRU is most definitely warranted. Thanks, Adam.

Jonathan: can you please take a look at it?

GG (pcdoctor01) wrote :

Thx pschoond for the fix!

GG (pcdoctor01) wrote :
Adam Spain (adamspain) wrote :

Debdiff for hardy-proposed.

Jonathan Riddell (jr) wrote :

Uploaded to hardy-proposed

Please add a test case and test once pitti has approved it.

Adam Spain (adamspain) wrote :

TEST CASE: Open Dolphin and navigate to a folder with .html or .xml files in. Hover the mouse cursor over a .html or .xml file in Dolphin, and if the bug is present you get an error message box popup telling you the desktop entry file has an invalid menu entry.

Steve Langasek (vorlon) wrote :

Has this bug been fixed in intrepid?

Targeting to hardy and subscribing ubuntu-sru, per https://wiki.ubuntu.com/StableReleaseUpdates; not yet copying to -proposed, which is currently frozen to facilitate building of candidate ISO images for 8.04.1 point release.

Changed in dolphin:
status: New → Confirmed
Adam Spain (adamspain) wrote :

It's not been fixed in Intrepid because according to Riddell we don't need it for Intrepid since it'll switch to KDE4. I assume since Kubuntu Intrepid will be KDE4 by default, there's no point keeping KDE3 and KDE4 versions of Dolphin around, so the KDE3 version (this package) will be dropped.

Risto H. Kurppa (risto.kurppa) wrote :

Still broken on Hardy, waiting for the fix to arrive in -proposed.

Kevin Krumwiede (kjkrum) wrote :

*google* *google*

What the heck? Why hasn't this been patched in Hardy yet?

flaccid (chris-xhost) wrote :

Not sure if it helps, but podcasts are XML and not text/html.

Removing this mimetype from the desktop entry has removed the error dialog.

simion314 (simion314) wrote :

I test the patch proposed by Adam Spain and it is working. At this moment before appling the patch the bug was not fix (i made all the updates). I hope that this patch will be aprved soon, the bug is in a core applcation (not on a application from multiverse or universe)
Thx Adam Spain for your work.

Martin Pitt (pitti) wrote :

Marking as WONTFIX for intrepid then.

Changed in dolphin:
status: Confirmed → Won't Fix
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Adam Spain (adamspain) wrote :

The binary from -proposed works fine for me and fixes the bug.

Paulus (donmatteo) wrote :

I confirm that installing the deb from -proposed (sudo apt-get install dolphin=0.9.2-0ubuntu6.1) fixes the bug.

MikeCalder (michaelcalder) wrote :

30th July. I just installed Kubuntu on my wife's machine, and lost time searching for and fixing this. It's still there guys. I worked from the standard Kubuntu download disk, then applied all fixes.

It takes how many months to fix something so trivial?

I hadn't noticed on my machine because Dolphin does not, shall we say, meet my needs - but if it is to be the default file manager intended for non-technical users on a flagship distro, it should work without such silly errors.

Adam Spain (adamspain) wrote :

MikeCalder I agree it's taking a long time to get the fix published. I guess the current holdup is waiting for the SRU verification team to test the update (which is very simple and shouldn't need that much testing). I don't know if the SRU verification team have a backlog or this is just the normal amount of time it takes, but this process doesn't seem very good at getting annoying bugs that affect a lot of people fixed quickly.

Steve Beattie (sbeattie) wrote :

I have reproduced the original behavior in the version of dolphin shipped in Kubuntu 8.04, 0.9.2-0ubuntu6, and verified that the version in -proposed, 0.9.2-0ubuntu6.1, does indeed fix the issue. I also poked around a little bit with the updated version of dolphin and saw no obvious regressions.

description: updated
Kevin Krumwiede (kjkrum) wrote :

Yeah, we know the fix was suggested and implemented in 'proposed'. But it took forever to get to 'proposed', and now it's taking forever to get into 'main'. These are the kinds of issues that make Linux unacceptable for the average user. I've been using Ubuntu since the 4.10 betas, and I was thrilled about being able to promote a distro that "just works" (one of Ubuntu's stated goals). But the quality has only declined since then. Fixing stuff like this in 'main' needs to be priority one if Canonical is true to its vision. (And don't even get me started about the utter brokenness of sound mixing in GNOME, which has persisted through, what, three releases now?)

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in dolphin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers