Ctrl+Scroll zoom with touchpad in Dolphin is erratic

Bug #1805024 reported by Brandon Bell
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dolphin (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 18.10 Cosmic (with kubuntu-desktop), Dolphin (4:18.04.3-0ubuntu2) on a Dell Latiude 7490 using the xserver-xorg-input-synaptics driver.

Using a Ctrl+Scroll with a mouse to zoom works normally, but doing the same with a touchpad (configured for edge scrolling or two-finger scrolling) appears to follow different rules which causes it to not work properly. More specifically, the zoom doesn't seem to activate unless the scroll speed is excessively fast.

Scrolling, itself, works fine everywhere else in both edge- and two-finger- mode. Ctrl+Scroll zooming works fine in all other programs (except Chrome where they've stupidly decided to disable it and require keyboard Ctrl-/+).

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: dolphin 4:18.04.3-0ubuntu2
ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
Uname: Linux 4.18.0-11-generic x86_64
ApportVersion: 2.20.10-0ubuntu13.1
Architecture: amd64
CurrentDesktop: KDE
Date: Sat Nov 24 21:26:56 2018
InstallationDate: Installed on 2016-01-31 (1028 days ago)
InstallationMedia: Kubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: dolphin
UpgradeStatus: Upgraded to cosmic on 2018-11-20 (4 days ago)

Revision history for this message
Brandon Bell (brandonbell) wrote :
Revision history for this message
Brandon Bell (brandonbell) wrote :

Attaching log from xev showing, toward the bottom, scrolling up (button 4) and down (button 5).

Revision history for this message
Brandon Bell (brandonbell) wrote :

This seems to have been fixed quite a while back.

Changed in dolphin (Ubuntu):
status: New → Invalid
Revision history for this message
Brandon Bell (brandonbell) wrote :

Well, the issue is back again in Disco and Dolphin 4:19.04.3-0ubuntu1~ubuntu19.04~ppa1.

Exact same symptoms.

Changed in dolphin (Ubuntu):
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers