Dolphin crashes on changing view size (Gutsy)

Bug #145744 reported by Matthias Kellermann on 2007-09-27
14
Affects Status Importance Assigned to Milestone
dolphin (Ubuntu)
Undecided
Unassigned

Bug Description

When I try to change the view in Dolphin via View -> Smaller (Ctrl+-) Dolphin crashes.

Tested on Gutsy Beta, 32Bit system.

Backtrace:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1234684224 (LWP 12700)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6 0xb7112e50 in QIconView::calcGridNum () from /usr/lib/libqt-mt.so.3
#7 0xb7115c68 in QIconView::makeRowLayout () from /usr/lib/libqt-mt.so.3
#8 0xb71193f8 in QIconView::arrangeItemsInGrid () from /usr/lib/libqt-mt.so.3
#9 0xb7c95f67 in KFileIconView::arrangeItemsInGrid ()
   from /usr/lib/libkio.so.4
#10 0x080808cc in ?? ()
#11 0x082d71c0 in ?? ()
#12 0x00000001 in ?? ()
#13 0x00000075 in ?? ()
#14 0xb6f56530 in QTimer::stop () from /usr/lib/libqt-mt.so.3
#15 0xb7113121 in QIconView::adjustItems () from /usr/lib/libqt-mt.so.3
#16 0xb7118e5e in QIconView::resizeEvent () from /usr/lib/libqt-mt.so.3
#17 0xb6f65ab9 in QWidget::event () from /usr/lib/libqt-mt.so.3
#18 0xb6ec5af0 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#19 0xb6ec84ba in QApplication::notify () from /usr/lib/libqt-mt.so.3
#20 0xb768c242 in KApplication::notify () from /usr/lib/libkdecore.so.4
#21 0xb6e58209 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#22 0xb6ec6b28 in QApplication::sendPostedEvents ()
   from /usr/lib/libqt-mt.so.3
#23 0xb6f67e5f in QWidget::show () from /usr/lib/libqt-mt.so.3
#24 0xb70684a2 in QScrollView::show () from /usr/lib/libqt-mt.so.3
#25 0xb6f64cbf in QWidget::showChildren () from /usr/lib/libqt-mt.so.3
#26 0xb6f680f0 in QWidget::show () from /usr/lib/libqt-mt.so.3
#27 0x0806eb5e in ?? ()
#28 0x083064b8 in ?? ()
#29 0x083069b8 in ?? ()
#30 0x00000000 in ?? ()

sneakypete (peteburgers) wrote :

Same with me - I've just upgraded from Kubuntu Feisty to Gutsy Beta.

To reproduce:
* Open dolphin (System Menu -> Home Folder)
* Change the view mode to "Previews"
* View Menu -> Zoom Out.

Expected Behaviour: Icons get smaller
Actual Behaviour: Crash

Possibly Related: (split into a separate bug?)
Zoom in/out works when in icon or details view mode. However when the zoom is changed in these modes, the view mode changes unexpectedly to Preview mode. If I then change back to icon/details view mode, I can see the results of the zoom change (the icons are larger/smaller than before).

palbarra (pedro-albarran) wrote :

I can reproduce this buggy behaviour, just as explain in the two previous comments.

Changed in dolphin:
status: New → Confirmed
Toufik (toufik2) wrote :

Same here after fresh install of gutsy beta

Adric Riedel (adric-riedel) wrote :

Same here, Kubuntu 7.10 AMD64.

See also bugs #132238 and #148795

. (asfg-deactivatedaccount) wrote :

Still? This seems to have been fixed here now.

It works now as expected with latest Kubuntu Gutsy - 32 and 64 Bit versions tested.

Martin Böhm (martin.bohm) wrote :

Thank you for your bug report. I cannot reproduce it and some people already reported that it is working well now, therefore I will close this bug. Please reopen this bug if you can reproduce this bug on Kubuntu Gutsy with latest updates.

Changed in dolphin:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers