Problem with dokuwiki installation

Bug #216980 reported by Magnus Ihse Bursie
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dokuwiki (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

Binary package hint: dokuwiki

I found this problem in hardy beta (as of today, 13 april 2008). I was installing dokuwiki (by apt-get install ... dokuwiki ..., where ... was a bunch of other packets).

The package version of dokuwiki is 0.0.20070626b-1.

During the installation, I first get to answer a few questions, the last one being about "Purging pages on removal".

Then I got this output:

Setting up dokuwiki (0.0.20070626b-1) ...
X_LOADTEMPLATEFILE /var/lib/dpkg/info/ucf.templates ucf

At this point, the installation just stopped. When I pressed return, the installation process continued for a while, and then a new
X_LOADTEMPLATEFILE /var/lib/dpkg/info/ucf.templates ucf
appeared. Yet another press on returned made me continue, and yet another appeared, and so on. Somewhere between 5 and 10 times this happend, and then the installation finished.

My quess is that I should really have answered some installation questions at that point, and that by pressing return I just accepted the defaults.

REPRODUCABILITY:
I can reproduce this behaviour by running
dpkg-reconfigure dokuwiki

Let me know if you need any more information regarding this.

Revision history for this message
Diego Torres Milano (diego-pxes) wrote :

Same behavior in Hardy Release.

Revision history for this message
Diego Torres Milano (diego-pxes) wrote :

Apache should be restarted upon successful installation/reconfiguration to read the new dokuwiki configuration.

Revision history for this message
mardon (mar-don) wrote :

I have same problem installation stop on X_LOADTEMPLATEFILE /var/lib/dpkg/info/ucf.templates ucf . I resatrt Apache and installation still waiting

Revision history for this message
Wimru (rudolfwimmer) wrote :

I also had installation problem (stop on X_LOADTEMPLATEFILE..) than I killed synaptic after this synaptic didn't work anymore.

Revision history for this message
Paul McGarry (paul-paulmcgarry) wrote :

Same problem on upgrade to Intrepid Alpha 4 from Hardy.
Hitting enter a few times in the console window gets past it.

Revision history for this message
troutmask (mjgatford) wrote : Re: [Bug 216980] Re: Problem with dokuwiki installation

Paul,

Thanks, I'll give it a go.

Mike

On Sat, 16 Aug 2008 03:50:23 +0100, Paul McGarry <email address hidden>
wrote:

> Same problem on upgrade to Intrepid Alpha 4 from Hardy.
> Hitting enter a few times in the console window gets past it.
>

--
Using Opera's revolutionary e-mail client: http://www.opera.com/mail/

Revision history for this message
Andrew (andrewkvalheim) wrote :

I ran into the same problem during installation. I pressed Enter several times to get through it, and haven't noticed anything else unusual with the wiki yet.

Revision history for this message
Julien88 (julien-leduc-serviware) wrote :

I had the same problem, but still managed to install it: stop apache before install, launch install process, hit return a few times till the end.
After that start apache and go to: http://localhost/dokuwiki

and you should see your new wiki.

Revision history for this message
Luca Falavigna (dktrkranz) wrote :

Will be fixed when bug #278014 will be processed.

Changed in dokuwiki:
importance: Undecided → Medium
status: New → Fix Released
Revision history for this message
Kevin (kevin-matson) wrote :

I had the same problem and stopping Apache before rerunning the install allowed the install to go forward.

Revision history for this message
Wursthupe (wursthupe) wrote :

I had the same problem today with Ubuntu 8.04 x64. Pressing RETURN a few times and restarting apache2 let my dokuwiki work.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers