Ubuntu

docky crashes everytime

Reported by Narayanan N on 2011-04-11
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Docky
Medium
Rico Tzschichholz
docky (Ubuntu)
Undecided
Rico Tzschichholz

Bug Description

Binary package hint: docky

[Info 13:48:48.001] Docky version: 2.1.2 Release
[Info 13:48:48.007] Kernel version: 2.6.38.8
[Info 13:48:48.008] CLR version: 2.0.50727.1433
[Debug 13:48:48.188] [UserArgs] BufferTime = 0
[Debug 13:48:48.188] [UserArgs] MaxSize = 2147483647
[Debug 13:48:48.188] [UserArgs] NetbookMode = False
[Debug 13:48:48.188] [UserArgs] NoPollCursor = False
[Debug 13:48:48.201] [SystemService] Using org.freedesktop.UPower for battery information
[Info 13:48:48.218] [ThemeService] Setting theme: Transparent
[Debug 13:48:48.240] [DesktopItemService] Loading remap file '/usr/share/docky/remaps.ini'.
[Debug 13:48:48.246] [DesktopItemService] Remapping 'Picasa3.exe' to 'picasa'.
[Debug 13:48:48.246] [DesktopItemService] Remapping 'nbexec' to 'netbeans'.
[Debug 13:48:48.246] [DesktopItemService] Remapping 'deja-dup-preferences' to 'deja-dup'.
[Debug 13:48:48.246] [DesktopItemService] Remapping 'VirtualBox' to 'virtualbox'.
[Debug 13:48:48.246] [DesktopItemService] Loading remap file '/home/.../.local/share/docky/remaps.ini'.
[Debug 13:48:48.249] [DesktopItemService] Loading desktop item cache '/home/.../.cache/docky/docky.desktop.en_US.UTF-8.cache'.

Unhandled Exception: System.ArgumentException: Value does not fall within the expected range.
  at Docky.Services.Applications.DesktopItem.GetBool (System.String key) [0x00000] in <filename unknown>:0
  at Docky.Services.Applications.DesktopItem.get_Ignored () [0x00000] in <filename unknown>:0
  at Docky.Services.DesktopItemService.BuildExecStrings () [0x00000] in <filename unknown>:0
  at Docky.Services.DesktopItemService.DesktopItemsChanged () [0x00000] in <filename unknown>:0
  at Docky.Services.DesktopItemService.Initialize () [0x00000] in <filename unknown>:0
  at Docky.Services.DockServices.Init () [0x00000] in <filename unknown>:0
  at Docky.Docky.Main (System.String[] args) [0x00000] in <filename unknown>:0

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: docky 2.1.2-1
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Mon Apr 11 13:50:23 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: docky
UpgradeStatus: Upgraded to natty on 2011-03-14 (27 days ago)

Narayanan N (narayana) wrote :
Rico Tzschichholz (ricotz) wrote :

docky (2.1.2-1ubuntu1) natty; urgency=low

  * debian/patches:
    + 10_prevent crash_if_a_desktop-file_contains_invalid_values.patch
      (LP: #757140)

 -- Rico Tzschichholz <email address hidden> Wed, 13 Apr 2011 09:23:01 +0200

Changed in docky (Ubuntu):
status: New → Confirmed
assignee: nobody → Rico Tzschichholz (ricotz)
tags: added: patch
Martin Pitt (pitti) wrote :

Sponsored

Changed in docky (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docky - 2.1.2-1ubuntu1

---------------
docky (2.1.2-1ubuntu1) natty; urgency=low

  * debian/patches:
    + 10_prevent crash_if_a_desktop-file_contains_invalid_values.patch
      (LP: #757140)
 -- Rico Tzschichholz <email address hidden> Wed, 13 Apr 2011 09:23:01 +0200

Changed in docky (Ubuntu):
status: Fix Committed → Fix Released
Changed in docky:
assignee: nobody → Rico Tzschichholz (ricotz)
status: New → Fix Committed
importance: Undecided → Medium
milestone: none → 2.1.3
Changed in docky:
status: Fix Committed → Fix Released
Felix Moreno (felix-justdust) wrote :

This bug is not fixed, it's again in ubuntu 12.04 , 12.10, and the las 13.04... docky is not working properly in ubuntu since 2 years ago.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers