Application Docky Crashes Frequently

Bug #1074804 reported by Subin Hutton on 2012-11-04
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
docky (Ubuntu)
Undecided
Unassigned

Bug Description

Docky crashes, whenever I install any application through apt and ubuntu software center. Then I have to restart the application in-order to work again. Your suggestions are highly appreciated.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: docky 2.1.4-1
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
Date: Sun Nov 4 11:35:47 2012
InstallationDate: Installed on 2012-10-19 (15 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: docky
UpgradeStatus: No upgrade log present (probably fresh install)

Subin Hutton (djlynux) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in docky (Ubuntu):
status: New → Confirmed
Felix Moreno (felix-justdust) wrote :

It happens to me too in Ubuntu 12.10 and 13.04, I have a direct access to docky beacuase usually is closed because of some fails.
Im'm using docky + gnome-panel

pip (verymadpip) wrote :

Docky also crashes in Xubuntu 13.04 x64 when installing applications from software centre

Fred Roller (fredroller66) wrote :

I am running Docky on Xubuntu across several machines and several generations 12.04 -14.04 and it is easily reproduced by updating or installing with either GUI (software center or update manager) or CLI apt-get or dpkg -i. The installation process is what is killing it. I have attached the following log from an Acer Aspire 7520 AMD 64 (corex2), 4Gb ram, 1 Tb hdd, with Nvidia graphics.
First killall docky.
Then docky --debug > docky.log &
then sudo apt-get install warzone2100 -y
then wait for crash.
Do not restart docky
then killall docky.
End of steps.

It's an annoyance but not a show stopper. I have tried on a 14.04 beta2 build with the same results. The following from the log seems to be the relevent part:

[snip]
[Debug 12:44:19.621] [DesktopItemService] 2 new application(s) found.
[Debug 12:44:19.622] [DesktopItemService] Adding '/usr/share/applications/warzone2100.desktop'.
[Debug 12:44:19.622] [DesktopItemService] Adding '/usr/share/applications/warzone2100.desktop'.
[Debug 12:44:20.427] [DesktopItemService] Saving desktop item cache '/home/froller/.cache/docky/docky.desktop.en_US.UTF-8.cache'.
[Info 12:44:20.795] [DrawingService] Could not find 'application-default-icon', using fallback of 'application-x-executable'.
[Debug 12:44:21.985] [DesktopItemService] Saving desktop item cache '/home/froller/.cache/docky/docky.desktop.en_US.UTF-8.cache'.
[Debug 12:44:23.141] [DesktopItemService] Saving desktop item cache '/home/froller/.cache/docky/docky.desktop.en_US.UTF-8.cache'.
[Fatal 12:44:23.192] [GLib-GObject] g_object_ref: assertion 'G_IS_OBJECT (object)' failed
[Debug 12:44:24.426] [DesktopItemService] Saving desktop item cache '/home/froller/.cache/docky/docky.desktop.en_US.UTF-8.cache'.
[Fatal 12:44:44.124] [GLib-GObject] g_object_ref: assertion 'G_IS_OBJECT (object)' failed
[EOF]

relevent because it is the first mention of the new programs and seems to be trying update cache. Could [Info 12:44:20.795] the trigger of the crash? Just guessing, I don't know enough about programing to say. Given the age of the post, if the solution has been resolved else where please point me in that direction.

Fred

supashang (supashang) wrote :

I can confirm that Docky is also crashing frequently on Ubuntu 14.04 LTS 64Bit on both mine and my girlfriends PC. I've tried to get repro info, but since it crashes randomly, this is becoming a wild bug hunt.

monkeybrain2012 (kammon101) wrote :

Yeah, still isn't fixed in 14.04 and I can confirm that installation (using synpatic) kills it. There is some improvement in the ppa version https://launchpad.net/~docky-core/+archive/ubuntu/ppa but it still crashes, but a lot less.

Docky has crashed only when installation/update is running. IAW when
software is installed. Always has from 12.04 by my experience. No
matter the set up or situation the culprit in my case could always be
traced to when an install occurred. HIH FWIW.

On 08/16/2014 05:29 PM, monkeybrain2012 wrote:
> Yeah, still isn't fixed in 14.04 and I can confirm that installation
> (using synpatic) kills it. There is some improvement in the ppa version
> https://launchpad.net/~docky-core/+archive/ubuntu/ppa but it still
> crashes, but a lot less.
>

--
- Fred

"Only those who can see the invisible
can accomplish the impossible." - Anonymous

^rooker (rooker) wrote :

I've recently set up a new notebook with 14.04.3 a few days ago.
I know that Docky was known to crash (=disappear) every now and then in 12.04 already, but in 14.04 it's simply "gone" most of the time.

Anyone know what can be done to improve this?

Thanks in advance.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers