Libreoffice highlighters cause desktop panels and docky to disapear

Bug #1502852 reported by Rossco on 2015-10-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dockmanager (Ubuntu)
Undecided
Unassigned

Bug Description

Hi I have dell inspiron laptop and I'm using gnome ubuntu 14.04 LTS fall-back with matacity 64bit, composting is on for docky.
While using the standard LibreOffice which came with the disto, Every time I use the Font colour highlighting feature in Impress, or any of the three highlighting features in Writer and Calc and then change the colour, it makes the panels on my desktop and Docky disappear. I do as much of the highlighting as possible before restoring panels and dock, as panels and dock just keep on disappearing the same way after restoring them. The document itself is not affect in any way. While the panel is invisible, all the icons are still functional. Some of the icons are also usable, I just have to guess where the icons are and click onto them and they become visible, such as Applications and Places. Workspace Switcher and Show Desktop also work. Others such as the Indicator Applet Complete - calendar, internet , mail, sound and so on all remain invisible, if I click on one of these, I wont know its opened until I restore the panels, see my workaround below.

My workaround to restore the dock and panel is to Alt+Ctrl+Del twice and then everything re-appears, I then cancel the logout pop-up window.

I have a friend I helped install a similar fallback with matacity system using the normal ubuntu 14.04 LTS distro (not gnome) 64bit, again composting is on for Docky, different type of laptop with the same issues.

Both my friend and I do a lot of highlighting in our docs and its so annoying for us we are thinking of replacing LibreOffice with OpenOffice, at the same time we would rather stay with LibreOffice if someone could help us somehow, thanks in advance.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1502852/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Rossco (wudgulah) on 2015-10-06
affects: ubuntu → libreoffice (Ubuntu)

Rossco, thank you for reporting this and helping make Ubuntu better. Are there any crash files in the folder /var/crash after this event?

Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete

On 06/10/15 20:02, Christopher M. Penalver wrote:
> Rossco, thank you for reporting this and helping make Ubuntu better. Are
> there any crash files in the folder /var/crash after this event?
>
> ** Changed in: libreoffice (Ubuntu)
> Importance: Undecided => Medium
>
> ** Changed in: libreoffice (Ubuntu)
> Status: New => Incomplete
>
Hi Christopher, thanks for your reply.
Their are no crash reports from Libreoffice in the above folder, and I
duplicated the bug again just now and nothing changed in any of the
other crash reports.

Rossco:
"...and I duplicated the bug again just now and nothing changed in any of the other crash reports."

As I wouldn't expect a LibreOffice crash file to be there, as no evidence exists of it crashing, my interest is if there are any crash files in there at all (not if there are LibreOffice ones only).

Hence, to clarify, are there crash files in /var/crash from other programs?

Rossco (wudgulah) wrote :

On 07/10/15 19:49, Christopher M. Penalver wrote:
> Rossco:
> "...and I duplicated the bug again just now and nothing changed in any of the other crash reports."
>
> As I wouldn't expect a LibreOffice crash file to be there, as no
> evidence exists of it crashing, my interest is if there are any crash
> files in there at all (not if there are LibreOffice ones only).
>
> Hence, to clarify, are there crash files in /var/crash from other
> programs?
>
Hi Christopher,

Yes, their are three from Firefox:

_usr_lib_firefox_plugin-container.1000.crash
_usr_lib_firefox_plugin-container.1000.upload
_usr_lib_firefox_plugin-container.1000.uploaded

The top one is 22.8Mb and was unable to send it as an attachment, the
other two were 0bites
Thanks.

Changed in libreoffice (Ubuntu):
importance: Medium → Undecided
status: Incomplete → Invalid
Rossco (wudgulah) wrote :

On 18/10/15 02:58, Christopher M. Penalver wrote:
> Rossco, thank you for reporting this and helping make Ubuntu better.
> However, your crash report is missing.
>
> Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer. First, execute at a terminal:
> cd /var/crash && sudo rm * ; sudo apt-get update && sudo apt-get -y upgrade && sudo service apport start force_start=1
>
> If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart. Now reproduce the crash, then open a terminal, navigate to your /var/crash directory and file your report with:
> sudo ubuntu-bug /var/crash/_my_crash_report.crash
>
> where _my_crash_report.crash is the crash you would like to report. By
> default, this sends the crash to the Ubuntu Error Tracker
> infrastructure, which is different than Launchpad. For more on this,
> please see https://wiki.ubuntu.com/ErrorTracker .
>
> However, if after doing this you would still like to have a crash report posted to Launchpad, for example to ease triage and add others to your report, one would need to open the following file via a terminal:
> sudo nano /etc/apport/crashdb.conf
>
> and comment out the line:
> 'problem_types': ['Bug', 'Package'],
>
> by changing it to:
> # 'problem_types': ['Bug', 'Package'],
>
> Save, close, and file the crash report via:
> sudo ubuntu-bug /var/crash/_my_crash_report.crash
>
> If you do open this report, please feel free to subscribe me to it.
>
> However, I'm closing this report since the process outlined above will
> deal with this issue more efficiently. Also, please do not attach your
> crash report manually to this report and reopen it. Thank you for your
> understanding.
>
> Helpful bug reporting tips:
> https://wiki.ubuntu.com/ReportingBugs
>
> ** Changed in: libreoffice (Ubuntu)
> Importance: Medium => Undecided
>
> ** Changed in: libreoffice (Ubuntu)
> Status: Incomplete => Invalid
>
Hi Christopher,

I followed your instructions as below:

Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer. First, execute at a terminal:
cd /var/crash && sudo rm * ; sudo apt-get update && sudo apt-get -y upgrade && sudo service apport start force_start=1

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart. Now reproduce the crash, then open a terminal, navigate to your /var/crash directory and file your report with:
sudo ubuntu-bug /var/crash/_my_crash_report.crash

I reproduced the bug, navigated to /var/crash directory, but now their are no files in that directory at all.
So how do I send a crash report now?

Rossco, could you please advise how you installed Docky precisely, and from where?

Rossco (wudgulah) wrote :

On 18/10/15 12:31, Christopher M. Penalver wrote:
> Rossco, could you please advise how you installed Docky precisely, and
> from where?
>
Installation:
I installed Docky from the software centre, dockmanager is checked;

Because I use the 3D Background in Docky, I also install dconf from the
software centre and go to Applications/System Tools/dconf
Editor/org/gnome/metacity and check the "compositing_manager" box.

Thanks
Rossco

affects: libreoffice (Ubuntu) → dockmanager (Ubuntu)
Changed in dockmanager (Ubuntu):
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers