update to docker 18.09.2

Bug #1815683 reported by Michael Hudson-Doyle on 2019-02-12
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
docker.io (Ubuntu)
Undecided
Michael Hudson-Doyle
Xenial
Undecided
Michael Hudson-Doyle
Bionic
Undecided
Michael Hudson-Doyle
Cosmic
Undecided
Michael Hudson-Doyle

Bug Description

We should update to docker.io 18.09.2 in disco, cosmic, bionic, xenial.

[test case]
The autopkgtests per https://wiki.ubuntu.com/DockerUpdates.

[regression potential]
https://wiki.ubuntu.com/DockerUpdates again.

Changed in docker.io (Ubuntu):
status: New → Fix Released
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Changed in docker.io (Ubuntu Xenial):
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Changed in docker.io (Ubuntu Bionic):
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Changed in docker.io (Ubuntu Cosmic):
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in docker.io (Ubuntu Bionic):
status: New → Confirmed
Changed in docker.io (Ubuntu Cosmic):
status: New → Confirmed
Changed in docker.io (Ubuntu Xenial):
status: New → Confirmed

Hello Michael, or anyone else affected,

Accepted docker.io into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/docker.io/18.09.2-0ubuntu1~18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in docker.io (Ubuntu Cosmic):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Brian Murray (brian-murray) wrote :

Hello Michael, or anyone else affected,

Accepted docker.io into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/docker.io/18.09.2-0ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in docker.io (Ubuntu Bionic):
status: Confirmed → Fix Committed
tags: added: verification-needed-bionic
Changed in docker.io (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Michael, or anyone else affected,

Accepted docker.io into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/docker.io/18.09.2-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Canonical Kubernetes team has verified docker.io 18.09.2 with the Charmed Distribution of Kubernetes on Xenial (using the package from xenial-proposed) and Bionic (using the package from bionic proposed).

tags: added: id-5c5d9cc72b39e25ced022896
Michael Hudson-Doyle (mwhudson) wrote :

Per https://wiki.ubuntu.com/DockerUpdates the verification is the autopkgtests and these have all passed, with the exception of the ubuntu-fan tests which fail for xenial and bionic due to systemd messages on stderr that are there but ignored on cosmic and up: good enough.

tags: added: verification-done verification-done-bionic verification-done-cosmic verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-cosmic verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docker.io - 18.09.2-0ubuntu1~18.10.1

---------------
docker.io (18.09.2-0ubuntu1~18.10.1) cosmic; urgency=medium

  * Backport to 18.10 (LP: #1815683).

 -- Michael Hudson-Doyle <email address hidden> Wed, 13 Feb 2019 13:25:20 +1300

Changed in docker.io (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for docker.io has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docker.io - 18.09.2-0ubuntu1~18.04.1

---------------
docker.io (18.09.2-0ubuntu1~18.04.1) bionic; urgency=medium

  * Backport to 18.04 (LP: #1815683).

 -- Michael Hudson-Doyle <email address hidden> Wed, 13 Feb 2019 13:24:14 +1300

Changed in docker.io (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docker.io - 18.09.2-0ubuntu1~16.04.1

---------------
docker.io (18.09.2-0ubuntu1~16.04.1) xenial; urgency=medium

  * Backport to 16.04 (LP: #1815683).
  * Revert "Let dh_systemd install .service file: replace .install file entry
    with symlink"
  * Build with the freshly backported golang-1.10-go package.
  * Relax the build dependency on debhelper.
  * Build depend on btrfs-tools, not libbtrfs-dev or btrfs-progs.
  * Re-add build-depends on dh-systemd

 -- Michael Hudson-Doyle <email address hidden> Wed, 13 Feb 2019 11:47:29 +1300

Changed in docker.io (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers