upgrade to docker 18.06

Bug #1794396 reported by Michael Hudson-Doyle on 2018-09-25
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
docker.io (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[impact]
we should update docker to the 18.06 release

[test case]
The autopkgtests per https://wiki.ubuntu.com/DockerUpdates.

[regression potential]
https://wiki.ubuntu.com/DockerUpdates again.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docker.io - 18.06.1-0ubuntu1

---------------
docker.io (18.06.1-0ubuntu1) cosmic; urgency=medium

  * Update to 18.06.1 upstream release (LP: #1794396)
    - drop "fix-btrfs-constants.patch" (applied upstream)
  * Update debconf to prompt more aggressively (LP: #1784602)
    1. does not prompt on initial install (but does start the daemon)
    2. does prompt on every reinstall / upgrade (if the daemon is running)
    3. does prompt during "dpkg-reconfigure docker.io" (but does _not_
       [re]start the daemon)
    4. works properly with DEBIAN_FRONTEND=noninteractive -- user's
       previous/stored answer to the question automatically applies with no
       prompt
  * Check if "docker" group exists before creating it (LP: #1769911)

 -- Tianon Gravi <email address hidden> Mon, 24 Sep 2018 15:42:19 -0700

Changed in docker.io (Ubuntu):
status: New → Fix Released
description: updated

Hello Michael, or anyone else affected,

Accepted docker.io into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/docker.io/18.06.1-0ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in docker.io (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Michael Hudson-Doyle (mwhudson) wrote :

I've completed verification for this bug (i.e. checked the autopkgtests ran ok) and also verified the fixes for bug 1784602 and bug 1769911 which I really ought to have mentioned in the changelog entry. I'm going to give the k8s team a few days to raise objections though.

k8s team needs a bit more time to test on bionic. Will do that asap and report back here.

k8s team has finished testing and we're +1 on moving this to bionic-updates.

tags: added: verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docker.io - 18.06.1-0ubuntu1~18.04.1

---------------
docker.io (18.06.1-0ubuntu1~18.04.1) bionic; urgency=medium

  * Backport to 18.04 (LP: #1794396)

 -- Michael Hudson-Doyle <email address hidden> Thu, 27 Sep 2018 14:39:50 +1200

Changed in docker.io (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for docker.io has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Michael, or anyone else affected,

Accepted docker.io into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/docker.io/18.06.1-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in docker.io (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial

The k8s team have finished testing the package in xenial-proposed and are +1 on moving it to xenial-updates. Not removing verification tags since mwh has not yet commented.

Hi, thanks for testing so quickly! Some autopkgtest failed but I suspect they're just being flaky. Will retry before I mark verification-done.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers