package docker.io (not installed) failed to install/upgrade: subprocess installed post-removal script returned error exit status 127

Bug #1744599 reported by Robert Lambert on 2018-01-21
136
This bug affects 28 people
Affects Status Importance Assigned to Milestone
docker.io (Ubuntu)
Medium
Unassigned
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned

Bug Description

Just adding a bug hopefully to help out, I am new to this.

rob@node:~$ lsb_release -rd
Description: Ubuntu 16.04.3 LTS
Release: 16.04

rob@node:~$ apt-cache policy docker
docker:
  Installed: (none)
  Candidate: 1.5-1
  Version table:
     1.5-1 500
        500 http://ca.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        100 /var/lib/dpkg/status

3) What you expected to happen: Uninstall
4) What happened instead: this on reboot

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: docker.io (not installed)
ProcVersionSignature: Ubuntu 4.13.0-26.29~16.04.2-generic 4.13.13
Uname: Linux 4.13.0-26-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.15
AptOrdering:
 docker.io: Purge
 NULL: ConfigurePending
Architecture: amd64
Date: Sun Jan 21 13:34:09 2018
ErrorMessage: subprocess installed post-removal script returned error exit status 127
InstallationDate: Installed on 2018-01-21 (0 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.3
 apt 1.2.24
SourcePackage: docker.io
Title: package docker.io (not installed) failed to install/upgrade: subprocess installed post-removal script returned error exit status 127
UpgradeStatus: No upgrade log present (probably fresh install)

Robert Lambert (lambertr) wrote :
tags: removed: need-duplicate-check
Joshua Powers (powersj) wrote :

Thanks for taking the time to file a bug!

It looks like the nuke-graph-directory.sh script is a shell (/bin/sh) and at the end runs shopt, which is a bash built-in.

To reproduce:

$ mkdir /tmp/test
$ pull-lp-source docker.io
$ cd docker.io-*
$ sudo ./contrib/nuke-graph-directory.sh /tmp/test

Nuking /tmp/test ...
  (if this is wrong, press Ctrl+C NOW!)

+ sleep 10

./nuke-graph-directory.sh: 64: ./nuke-graph-directory.sh: shopt: not found

Changed in docker.io (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Tianon Gravi (tianon) wrote :

This was fixed upstream in 17.04+ (https://github.com/docker/docker/pull/30519) -- I could've sworn we backported the patch, but apparently not! (I'll go work on getting that applied now)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docker.io - 17.03.2-0ubuntu3

---------------
docker.io (17.03.2-0ubuntu3) bionic; urgency=medium

  * d/tests/docker-in-lxd: set DEBIAN_FRONTEND=noninteractive when installing
    docker in the lxd container

 -- Michael Hudson-Doyle <email address hidden> Wed, 21 Feb 2018 10:49:58 +1300

Changed in docker.io (Ubuntu):
status: Confirmed → Fix Released
Robie Basak (racb) on 2018-06-21
Changed in docker.io (Ubuntu Xenial):
status: New → Triaged
Changed in docker.io (Ubuntu Artful):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docker.io - 17.03.2-0ubuntu2~16.04.1

---------------
docker.io (17.03.2-0ubuntu2~16.04.1) xenial; urgency=medium

  [ Michael Hudson-Doyle ]
  * Backport to Xenial. (LP: #1732368)
  * Install the service file with .install again, fixing service activation
    on install.
  * Use golang.org/x/net/context instead of stdlib context to enable building
    with Go 1.6.
  * Adjust debconf template to match change in behavior.

  [ Tianon Gravi ]
  * Adjust debconf prompt:
    - ask during _every_ upgrade
    - default to not restarting

 -- Michael Hudson-Doyle <email address hidden> Fri, 23 Mar 2018 15:34:08 +1300

Changed in docker.io (Ubuntu Xenial):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers