upgrade to 1.13

Bug #1712954 reported by Michael Hudson-Doyle on 2017-08-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
docker.io (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Michael Hudson-Doyle
Zesty
Undecided
Michael Hudson-Doyle
runc (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Michael Hudson-Doyle
Zesty
Undecided
Michael Hudson-Doyle

Bug Description

[Impact]
It's time to update docker again.

[Test Case]
See https://wiki.ubuntu.com/DockerUpdates

[Regression potential]
See above. I will test by hand that s390x actually works this time though.

Changed in docker.io (Ubuntu):
status: New → Fix Released
Changed in docker.io (Ubuntu Xenial):
status: New → In Progress
Changed in runc (Ubuntu Xenial):
status: New → In Progress
Changed in runc (Ubuntu):
status: New → Fix Released
Changed in runc (Ubuntu Zesty):
status: New → In Progress
Changed in docker.io (Ubuntu Zesty):
status: New → In Progress
Changed in docker.io (Ubuntu Xenial):
status: In Progress → Confirmed
Changed in docker.io (Ubuntu Zesty):
status: In Progress → Confirmed
Changed in runc (Ubuntu Xenial):
status: In Progress → Confirmed
Changed in runc (Ubuntu Zesty):
status: In Progress → Confirmed
Changed in docker.io (Ubuntu Xenial):
status: Confirmed → In Progress
Changed in docker.io (Ubuntu Zesty):
status: Confirmed → In Progress
Changed in docker.io (Ubuntu Xenial):
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Changed in docker.io (Ubuntu Zesty):
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Changed in runc (Ubuntu Xenial):
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Changed in runc (Ubuntu Zesty):
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Changed in runc (Ubuntu Xenial):
status: Confirmed → In Progress
Changed in runc (Ubuntu Zesty):
status: Confirmed → In Progress

Hello Michael, or anyone else affected,

Accepted docker.io into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/docker.io/1.13.1-0ubuntu1~17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in docker.io (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-zesty
Brian Murray (brian-murray) wrote :

Hello Michael, or anyone else affected,

Accepted runc into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/runc/1.0.0~rc2+docker1.13.1-0ubuntu1~17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in runc (Ubuntu Zesty):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Michael, or anyone else affected,

Accepted docker.io into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/docker.io/1.13.1-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in docker.io (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Michael, or anyone else affected,

Accepted runc into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/runc/1.0.0~rc2+docker1.13.1-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in runc (Ubuntu Xenial):
status: In Progress → Fix Committed

We did some testing of docker 1.13.1 with CDK this week and it doesn't work out-of-the-box, at least not with Flannel on AWS (and Flannel is our default overlay at the moment). TL;DR is there's a new default iptables rule that breaks us. We can probably work around this in the charms, but for now we should keep 1.13.1 in xenial-proposed.

tags: added: verification-failed-xenial
removed: verification-needed-xenial

So what's the next step here? is there a change you would like me to make
to the docker packaging or are you going to fix this on your end?

On 30 September 2017 at 09:01, Tim Van Steenburgh <email address hidden>
wrote:

> We did some testing of docker 1.13.1 with CDK this week and it doesn't
> work out-of-the-box, at least not with Flannel on AWS (and Flannel is
> our default overlay at the moment). TL;DR is there's a new default
> iptables rule that breaks us. We can probably work around this in the
> charms, but for now we should keep 1.13.1 in xenial-proposed.
>
> ** Tags removed: verification-needed-xenial
> ** Tags added: verification-failed-xenial
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1712954
>
> Title:
> upgrade to 1.13
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/docker.io/+bug/
> 1712954/+subscriptions
>

Hello Michael, or anyone else affected,

Accepted docker.io into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/docker.io/1.13.1-0ubuntu1~16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed-xenial
removed: verification-failed-xenial
Michael Hudson-Doyle (mwhudson) wrote :

The autopkgtests passed on amd64, ppc64el and i386. I've run them by hand on arm64.

We still need to run basic tests on s390x and get word from the k8s team that they are happy to see this migrate.

Michael Hudson-Doyle (mwhudson) wrote :

I've run the tests (successfully) on s390x now.

CDK has been updated to work with docker 1.13.1 - no need to block on k8s any longer.

Xenial is ready to go, still need to finish testing on zesty.

tags: added: verification-done-xenial
removed: verification-needed-xenial

testing on zesty all done

tags: added: verification-done verification-done-zesty
removed: verification-needed verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docker.io - 1.13.1-0ubuntu1~17.04.1

---------------
docker.io (1.13.1-0ubuntu1~17.04.1) zesty; urgency=medium

  * Backport to Zesty. (LP: #1712954)

 -- Michael Hudson-Doyle <email address hidden> Fri, 01 Sep 2017 10:44:02 +1200

Changed in docker.io (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for docker.io has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package docker.io - 1.13.1-0ubuntu1~16.04.2

---------------
docker.io (1.13.1-0ubuntu1~16.04.2) xenial; urgency=medium

  * Rebuild with golang-1.6 1.6.2-0ubuntu5~16.04.4 which uses the correct page
    size on arm64 for use with Ubuntu kernels. (LP: #1702979)

docker.io (1.13.1-0ubuntu1~16.04.1) xenial; urgency=medium

  * Backport to Xenial. (LP: #1712954)
  * Install the service file with .install again, fixing service activation
    on install.
  * Use golang.org/x/net/context instead of stdlib context to enable building
    with Go 1.6.

 -- Michael Hudson-Doyle <email address hidden> Thu, 02 Nov 2017 11:43:13 +1300

Changed in docker.io (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package runc - 1.0.0~rc2+docker1.13.1-0ubuntu1~17.04.1

---------------
runc (1.0.0~rc2+docker1.13.1-0ubuntu1~17.04.1) zesty; urgency=medium

  * Backport to Zesty. (LP: #1712954)

 -- Michael Hudson-Doyle <email address hidden> Fri, 01 Sep 2017 10:45:35 +1200

Changed in runc (Ubuntu Zesty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package runc - 1.0.0~rc2+docker1.13.1-0ubuntu1~16.04.1

---------------
runc (1.0.0~rc2+docker1.13.1-0ubuntu1~16.04.1) xenial; urgency=medium

  * Backport to Xenial. (LP: #1712954)

 -- Michael Hudson-Doyle <email address hidden> Mon, 28 Aug 2017 09:40:33 +1200

Changed in runc (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers