Docker does not support nftables

Bug #1503674 reported by Hadmut Danisch on 2015-10-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
docker.io (Ubuntu)
Wishlist
Unassigned

Bug Description

Hi,

I had a fresh 15.10 beta install and have thrown out iptables in favour of nftables.

Unfortunately, apt removed the docker.io package as well, since it depends on iptables.

Shouldn't docker.io be able to deal solely with nftables without the need for iptables?

regards

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: docker.io (not installed)
ProcVersionSignature: Ubuntu 4.2.0-14.16-generic 4.2.2
Uname: Linux 4.2.0-14-generic x86_64
ApportVersion: 2.19-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Wed Oct 7 14:11:26 2015
InstallationDate: Installed on 2015-09-03 (33 days ago)
InstallationMedia: Xubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150825)
SourcePackage: docker.io
UpgradeStatus: No upgrade log present (probably fresh install)

Hadmut Danisch (hadmut) wrote :

I think this is an upstream bug because last I checked Docker shells out to
iptables directly.

Robie Basak (racb) on 2015-10-08
tags: added: needs-upstream-bug
Changed in docker.io (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
summary: - depends on iptables instead of nftables
+ Docker does not support nftables
tags: added: needs-upstream-report
removed: needs-upstream-bug
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers