Docbook2man fails on directories with spaces

Bug #76933 reported by Matthew Flaschen
4
Affects Status Importance Assigned to Milestone
docbook-utils (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Binary package hint: docbook-utils

When I ran docbook2man in a directory path with spaces, it failed with the log:

matthew@matthew-e1505:/data/C Projects/apt-get/apt-0.6.45ubuntu14_new/doc$ docbook2man apt-get.8.xml
[: 233: Projects/apt-get/apt-0.6.45ubuntu14_new/doc/apt-get.8.xml: unexpected operator
Using catalogs: /etc/sgml/catalog
Using stylesheet: /usr/share/docbook-utils/docbook-utils.dsl#print
Working on: /data/C Projects/apt-get/apt-0.6.45ubuntu14_new/doc/apt-get.8.xml
nsgmls:E: cannot open "/data/C" (No such file or directory)
nsgmls:E: cannot find "Projects/apt-get/apt-0.6.45ubuntu14_new/doc/apt-get.8.xml"; tried "Projects/apt-get/apt-0.6.45ubuntu14_new/doc/apt-get.8.xml", "/usr/local/share/sgml/Projects/apt-get/apt-0.6.45ubuntu14_new/doc/apt-get.8.xml", "/usr/share/sgml/Projects/apt-get/apt-0.6.45ubuntu14_new/doc/apt-get.8.xml"
cd: 392: can't cd to /data/C
Done.

It seems it isn't quoting the path.

Revision history for this message
Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 alpha?

Changed in docbook-utils:
status: New → Incomplete
Revision history for this message
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in docbook-utils:
status: Incomplete → Invalid
Revision history for this message
Matthew Flaschen (matthew-flaschen) wrote :

Why does it matter if it can be reproduced in 8.10? 8.04 is still supported, and the bug is still present in that release:

matthew@matthew-e1505: ~/Code/c/Directory With Spaces/apt-get/apt-0.7.9ubuntu17.1/doc% docbook2man apt-get.8.xml
[: 233: With: unexpected operator
basename: extra operand `Spaces/apt-get/apt-0.7.9ubuntu17.1/doc/apt-get.8.xml'
Try `basename --help' for more information.
Using catalogs: /etc/sgml/catalog
Using stylesheet: /usr/share/docbook-utils/docbook-utils.dsl#print
Working on: /home/matthew/Code/c/Directory With Spaces/apt-get/apt-0.7.9ubuntu17.1/doc/apt-get.8.xml
nsgmls:E: cannot open "/home/matthew/Code/c/Directory" (No such file or directory)
nsgmls:E: cannot find "With"; tried "With", "/usr/local/share/sgml/With", "/usr/share/sgml/With"
nsgmls:E: cannot find "Spaces/apt-get/apt-0.7.9ubuntu17.1/doc/apt-get.8.xml"; tried "Spaces/apt-get/apt-0.7.9ubuntu17.1/doc/apt-get.8.xml", "/usr/local/share/sgml/Spaces/apt-get/apt-0.7.9ubuntu17.1/doc/apt-get.8.xml", "/usr/share/sgml/Spaces/apt-get/apt-0.7.9ubuntu17.1/doc/apt-get.8.xml"
cd: 392: can't cd to /home/matthew/Code/c/Directory
Done.

Changed in docbook-utils:
status: Invalid → Confirmed
Revision history for this message
Matthew Flaschen (matthew-flaschen) wrote :

I wrote the attached patch, which seems to fix the quoting problem (though I still can't build the apt docs).

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers