8.04->9.04-beta upgrade: Could not install 'base-passwd'

Bug #349725 reported by Jan Köhler on 2009-03-27
58
This bug affects 2 people
Affects Status Importance Assigned to Milestone
doc-base (Ubuntu)
High
Michael Vogt
Hardy
Undecided
Michael Vogt
Intrepid
Undecided
Michael Vogt
Jaunty
High
Michael Vogt
update-manager (Ubuntu)
Undecided
Michael Vogt
Hardy
Undecided
Michael Vogt
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Michael Vogt

Bug Description

Binary package hint: update-manager

TEST CASE: (for the SRU verification)
1. install the new doc-base
2. perform a release upgrade and ensure there are no regressions

The reason why this is not a positive test-case is that the bug is hard to trigger, it
depends on the unpack ordering of the upgrade. The diff is very small (just one line change)
so this test should be sufficient.

kubuntu-8.04-to-9.04-beta-upgrade

Error
Could not install 'base-passwd'
The upgrade will continue but the 'base-passwd' package may be in a not working state. Please conside submitting a bug report about it.

subprocess post-installation script returned error exit status 9

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Please attach the files in /var/log/dist-upgrade/* to this report.

Changed in update-manager (Ubuntu):
assignee: nobody → mvo
status: New → Incomplete
Jan Köhler (jan.k) wrote :

here it is

Michael Vogt (mvo) wrote :

Here is the error:

Preparing to replace base-passwd 3.5.16 (using .../base-passwd_3.5.21_i386.deb)
...
Can't locate Pod/Usage.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/
5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/
5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/sbin/install-docs li
ne 18.
Global symbol "$opt_rootdir" requires explicit package name at /usr/sbin/install
-docs line 136.
Execution of /usr/sbin/install-docs aborted due to compilation errors.
dpkg: warning - old pre-removal script returned error exit status 9
dpkg - trying script from the new package instead ...
dpkg: ... it looks like that went OK.
Unpacking replacement base-passwd ...
Setting up base-passwd (3.5.21) ...
Can't locate Pod/Usage.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/
5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/
5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/sbin/install-docs li
ne 18.
Global symbol "$opt_rootdir" requires explicit package name at /usr/sbin/install
-docs line 136.
Execution of /usr/sbin/install-docs aborted due to compilation errors.
dpkg: error processing base-passwd (--configure):
 subprocess post-installation script returned error exit status 9
Errors were encountered while processing:
 base-passwd

Changed in update-manager (Ubuntu Jaunty):
importance: Undecided → High
status: Incomplete → Triaged
Michael Vogt (mvo) wrote :

It looks like this is fixed in jaunty, but intrepid has 0.8.16:

doc-base (0.8.18) unstable; urgency=medium

  * install-docs.in: include $opt_rootdir in used vars not to fail when
    Perl is in unusable state (closes: #501874). In such a case install-docs
    should try to recover on next invokation (see entry for version 0.8.4)

 -- Robert Luberda <email address hidden> Sun, 16 Nov 2008 22:34:09 +0100

Steve Langasek (vorlon) wrote :

Michael,

The diff you point to is already included in jaunty, right? So what else needs changed here for jaunty? Or should this bug be re-targeted to intrepid?

agradeceria inmensamente las respuestas en español pues no entiendo nada de
ingles . gracias.

2009/3/30 Steve Langasek <email address hidden>

> Michael,
>
> The diff you point to is already included in jaunty, right? So what
> else needs changed here for jaunty? Or should this bug be re-targeted
> to intrepid?
>
> --
> 8.04->9.04-beta updgrade: Could not install 'base-passwd'
> https://bugs.launchpad.net/bugs/349725
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “doc-base” source package in Ubuntu: Triaged
> Status in doc-base in Ubuntu Jaunty: Triaged
>
> Bug description:
> Binary package hint: update-manager
>
> kubuntu-8.04-to-9.04-beta-upgrade
>
> Error
> Could not install 'base-passwd'
> The upgrade will continue but the 'base-passwd' package may be in a not
> working state. Please conside submitting a bug report about it.
>
> subprocess post-installation script returned error exit status 9
>

--
RECIBE UN ABRAZO DE PAZ ¡ SHALOM !

Michael Vogt (mvo) on 2009-04-02
description: updated
Michael Vogt (mvo) on 2009-04-03
Changed in doc-base (Ubuntu Intrepid):
assignee: nobody → mvo
status: New → In Progress
Changed in doc-base (Ubuntu Hardy):
assignee: nobody → mvo
status: New → In Progress

The fix was backported from 0.8.18, thus this is fixed in Jaunty.

Changed in doc-base (Ubuntu Jaunty):
status: Triaged → Fix Released
Changed in doc-base (Ubuntu Intrepid):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in doc-base (Ubuntu Hardy):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

I was able to reproduce some of the package installation failures while performing the kubuntu-8.04-to-9.04 upgrade (via jriddell's script) with doc-base 0.8.7 from the 8.04 release. With doc-base 0.8.7ubuntu1 from hardy-proposed, I was able to perform the same upgrade without hitting the package installation errors. Cursory explorations with dhelp and doc-central with doc-base 0.8.7ubuntu1 (pre-upgrade) didn't show any obvious regressions.

I consider the hardy component of this bug verification-done. Thanks!

Matt Zimmerman (mdz) on 2009-04-05
summary: - 8.04->9.04-beta updgrade: Could not install 'base-passwd'
+ 8.04->9.04-beta upgrade: Could not install 'base-passwd'
Steve Beattie (sbeattie) wrote :

I was not able to reproduce the upgrade failure while upgrading from intrepid kubuntu 8.10 to 9.04 with doc-base 0.8.16 from intrepid, but I was able to successfully upgrade from 8.10->9.04 with the version of doc-base from intrepid-proposed, 0.8.16ubuntu1. Also, basic exploration of documentation in 8.10 after the installation of doc-base from intrepid-proposed did not show any obvious regressions.

tags: added: verification-done
removed: verification-needed
Colin Watson (cjwatson) wrote :

Since this is having a severe effect on Kubuntu upgrade testing, and since the patch is very simple, I'm going to waive the aging period for this update and copy it to hardy-updates and intrepid-updates now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package doc-base - 0.8.7ubuntu1

---------------
doc-base (0.8.7ubuntu1) hardy-proposed; urgency=low

  * backport fix from 0.8.18 to fix potential upgrade
    failures (LP: #349725)

 -- Michael Vogt <email address hidden> Thu, 02 Apr 2009 13:31:57 +0200

Changed in doc-base (Ubuntu Hardy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package doc-base - 0.8.16ubuntu1

---------------
doc-base (0.8.16ubuntu1) intrepid-proposed; urgency=low

  * backport fix from 0.8.18 to fix potential upgrade
    failures (LP: #349725)

 -- Michael Vogt <email address hidden> Thu, 02 Apr 2009 13:44:06 +0200

Changed in doc-base (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Michael Vogt (mvo) wrote :

update-manager will patch (the diff is very small) install-docs before the first dpkg run is done so that people upgrading from CD without the chance to update installd-docs from -updates have a working version.

Changed in update-manager (Ubuntu Jaunty):
assignee: nobody → mvo
status: New → Fix Released
Changed in update-manager (Ubuntu Intrepid):
status: New → Fix Released
Changed in update-manager (Ubuntu Hardy):
assignee: nobody → mvo
status: New → Fix Released
Changed in doc-base (Ubuntu Jaunty):
status: Fix Released → New
Steve Langasek (vorlon) on 2009-04-11
Changed in doc-base (Ubuntu Jaunty):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers