FFe: Please provide dnsmasq-utils from dnsmasq package

Bug #853255 reported by Dave Walker
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dnsmasq (Ubuntu)
Wishlist
Unassigned
Oneiric
Wishlist
Unassigned

Bug Description

Please provide dnsmasq-utils from dnsmasq package

Explanation of FeatureFreeze exception:

Add a new binary package (dnsmasq-utils) which ships dhcp_lease_time which allows fixing of bug 852771 (allow IP addresses to be put back into the pool faster, for re-use - avoiding exhaustion.

This change is part of Debian package, dnsmasq (2.58-1) and should be cherry picked and reconciled early next cycle.

Thanks.

dnsmasq (2.58-1) unstable; urgency=low

...
   * New binary package, dnsmasq-utils, containing dhcp_release and
     dhcp_lease_time from contrib/wrt. Note that these are Linux-specific
     so this package is Architecture: linux-any (closes: #638136)
...

 -- Simon Kelley <email address hidden> Mon, 22 Aug 2011 14:57:03 +0000

Related branches

Dave Walker (davewalker)
Changed in dnsmasq (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Dave Walker (davewalker) wrote :

Oneiric amd64 pbuilder log.

Revision history for this message
Dave Walker (davewalker) wrote :

Adds new libnetfilter-conntrack-dev build dep and install dep of libnetfilter-conntrack3, which is in universe.

Due to this in upstream changelog:
            Add support for Linux conntrack connection marking. If
     enabled with --conntrack, the connection mark for incoming
     DNS queries will be copied to the outgoing connections
     used to answer those queries. This allows clever firewall
     and accounting stuff. Only available if dnsmasq is
     compiled with HAVE_CONNTRACK and adds a dependency on
     libnetfilter-conntrack. Thanks to Ed Wildgoose for the
     initial idea, testing and sponsorship of this function.

Do not believe it is worth the MIR this cycle to add that feature. Therefore suggesting that this package is merged, with the introduction of a delta dropping the conntrack support, and removing the build-dep.

Thanks.

summary: - FFe: Sync dnsmasq 2.58-3 (main) from Debian unstable (main)
+ FFe: Merge dnsmasq 2.58-3 (main) from Debian unstable (main)
description: updated
Revision history for this message
Steve Langasek (vorlon) wrote : Re: FFe: Merge dnsmasq 2.58-3 (main) from Debian unstable (main)

Given that there's going to be a delta for this package anyway, does it still make sense to update instead of cherry-picking the one fix you need? "Mostly bugfixes" isn't "entirely bugfixes", and it doesn't seem there's been much analysis of the risk from the non-bugfix bits.

Revision history for this message
Dave Walker (davewalker) wrote :

@Steve, Yes - agreed - I have updated the bug as outlined.

Thanks.

description: updated
summary: - FFe: Merge dnsmasq 2.58-3 (main) from Debian unstable (main)
+ FFe: Please provide dnsmasq-utils from dnsmasq package
Dave Walker (davewalker)
tags: added: server-o-rs
Revision history for this message
Steve Langasek (vorlon) wrote :

Makes sense to me. FFe acked.

Changed in dnsmasq (Ubuntu Oneiric):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dnsmasq - 2.57-1ubuntu1

---------------
dnsmasq (2.57-1ubuntu1) oneiric; urgency=low

   * New binary package, dnsmasq-utils - cherry picked from Debian's
     2.58-1 package. Contains dhcp_release and dhcp_lease_time from
     contrib/wrt. (LP: #853255)
     - contrib/wrt/(dhcp_release.1,dhcp_lease_time.1): Included manpages
       from 2.58-1 package.
 -- Dave Walker (Daviey) <email address hidden> Mon, 19 Sep 2011 09:41:12 +0000

Changed in dnsmasq (Ubuntu Oneiric):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers