dnsmasq 2.41-2ubuntu1 init script typo: log_msg_end

Bug #235868 reported by Eric Shattow on 2008-05-29
8
Affects Status Importance Assigned to Milestone
dnsmasq (Debian)
Fix Released
Unknown
dnsmasq (Ubuntu)
Low
Thierry Carrez
Hardy
Low
Thierry Carrez

Bug Description

Binary package hint: dnsmasq

Correction:

  case "$?" in
- 0) log_warning_msg "running" ; log_msg_end 0; exit 0 ;;
+ 0) log_warning_msg "running" ; log_end_msg 0; exit 0 ;;
- 1) log_warning_msg "dead, pid file exists" ; log_msg_end 1; exit 1 ;;
+ 1) log_warning_msg "dead, pid file exists" ; log_end_msg 1; exit 1 ;;
- 3) log_warning_msg "not running" ; log_msg_end 3; exit 3 ;;
+ 3) log_warning_msg "not running" ; log_end_msg 3; exit 3 ;;
- *) log_warning_msg "unknown" ; log_msg_end 4; exit 4 ;;
+ *) log_warning_msg "unknown" ; log_end_msg 4; exit 4 ;;
  esac

Eric Shattow (eshattow) wrote :

Assigning to Soren (their patch introduced the typo in 2.40-1ubuntu4).

Changed in dnsmasq:
assignee: nobody → soren
Thierry Carrez (ttx) wrote :

I confirm.
Note that the patch was forwarded to Debian and 2.42-1 shipped with it.

Changed in dnsmasq:
status: New → Confirmed
Thierry Carrez (ttx) wrote :

Debdiff for the fix, including Eric's patch.

Thierry Carrez (ttx) wrote :

Fixed debdiff targeting hardy-proposed.

Thierry Carrez (ttx) wrote :

Last try (sorry for the noise) with proper patch attribution to Eric in the changelog.

Thierry Carrez (ttx) on 2008-06-16
Changed in dnsmasq:
assignee: soren → tcarrez
Mathias Gug (mathiaz) wrote :

The patch looks good.

In order to get it uploaded to hardy, it needs to get through the SRU process: https://wiki.ubuntu.com/StableReleaseUpdates.

Could you provide a test case that demonstrates what is failing in hardy ?

Before uploading for hardy-proposed, the version in intrepid needs to be fixed (the patch has been accepted by Debian in 2.42-3).

Thierry Carrez (ttx) wrote :

SRU report :

Impact : The init status command displays an error message in addition to the status.
Affects : >=2.40-1ubuntu4 (hardy, intrepid)
Development branch fix : patch was accepted yesterday in Debian 2.42-3, will be merged as soon as MoM catches up, see bug 239404 for details.
Minimal patch : see comment 5 above.

TEST CASE :
$ sudo apt-get install dnsmasq
$ sudo /etc/init.d/dnsmasq status
 * Checking DNS forwarder and DHCP server dnsmasq
 * running
/etc/init.d/dnsmasq: 212: log_msg_end: not found

This last line should just read " [ OK ]".

Regression potential : given the simplicity of the patch, there is no regression potential.

Changed in dnsmasq:
status: Unknown → Fix Released
Steve Langasek (vorlon) wrote :

Well, I consider this a borderline case for an SRU in light of the discussion prior to release about this likely not being a standard interface in the long term. I'll say "yes" here because the risk is very low, but this package should not enter -proposed until after the 8.04.1 CD builds are done.

Changed in dnsmasq:
assignee: nobody → tcarrez
importance: Undecided → Low
status: New → Triaged
Thierry Carrez (ttx) on 2008-06-18
Changed in dnsmasq:
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dnsmasq - 2.42-4ubuntu1

---------------
dnsmasq (2.42-4ubuntu1) intrepid; urgency=low

   * Merge from debian unstable (LP: #239404), remaining changes:
     - TearDown spec recommendations in debian/postinst and debian/init
     - debian/control: Updated maintainer to match DebianMaintainerField
   * Dropped changes:
     - LSBified init script (fix included in Debian)
   * This version fixes the log_msg_end typos in init script (LP: #235868)
   * Apply latest TearDown spec recommendation
     - Replaced "multiuser" in debian/postinst
     - Set "Default-Stop: 1" in debian/init LSB header

 -- Thierry Carrez <email address hidden> Wed, 18 Jun 2008 20:47:40 +0200

Changed in dnsmasq:
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in dnsmasq:
status: Triaged → Fix Committed
Daniel T Chen (crimsun) wrote :

PASS: Upgrades from 8.04 fine.
PASS: Upgrades from 8.04.1 fine.
PASS: Installs on 8.04.1 fine.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in dnsmasq:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.