Build-Depends on nettle-dev >=3.1

Bug #1785376 reported by Steve Dodd on 2018-08-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dnsmasq (Ubuntu)
Low
Unassigned

Bug Description

While trying to backport 2.79 to trusty, I discovered it now needs eddsa.h from nettle-dev, which only seems to have been added in version 3.1:

https://git.lysator.liu.se/nettle/nettle/commit/6907bbacd6da270aea6cd9d51eb9c0e25c17d520

Upstream version 2.79 has this in the changelog:

+ Tidy up Crypto code, removing workarounds for ancient
+ versions of libnettle. We now require libnettle 3.

Not sure this is backportable to Trusty's nettle on 2.7.1-1ubuntu0.2 without taking back the upstream changes.

To get you correctly, you report that the build dependency currently being
 nettle-dev (>=2.4-3)
should be like
 nettle-dev (>=3.1-1)
right?

I agree, when 2.79 was merged which implies these dependencies that should have been bumped.

Changed in dnsmasq (Ubuntu):
status: New → Confirmed

Since it "only" affects backports to very old releases as we have
  Xenial: 3.2-1ubuntu0.16.04.1
  Debian-Stable: 3.3-1
I'll mark importance low for now.

Changed in dnsmasq (Ubuntu):
importance: Undecided → Low

Thank you for taking the time to report this bug and helping to make Ubuntu better.

This bug is present in Debian too, and Ubuntu currently doesn't make any changes over the Debian package. So this bug would be best fixed directly in Debian, and then Ubuntu will pick up the fix automatically.

Would you mind filing a bug with Debian please?
I think given the low severity it is fine to fix it just there and we pick it up automatically.
If you do so I'd be glad if you could report back the generated bug number to track the handling there.

tags: added: bitesize needs-upstream-report
Changed in dnsmasq (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers