(fakeraid) root device not activated during boot

Bug #941874 reported by Mårten Thornberg on 2012-02-27
122
This bug affects 23 people
Affects Status Importance Assigned to Milestone
dmraid (Ubuntu)
Critical
Phillip Susi
multipath-tools (Ubuntu)
Critical
Phillip Susi

Bug Description

I have installed Precise Pangolin Alpha 2 to a fakeraid stripe, but ubuntu fails to boot after install. When choosing recovery option, the boot process times out waiting for root device and drops to busybox shell. Running "dmraid -ay" and exiting busybox resumes boot and it continues normally.

---
The problems are:

* There are no initramfs hooks for kpartx, so kpartx is not available during boot.
the following files are needed:
/sbin/kpartx
/lib/udev/kpartx_id
/lib/udev/dmsetup_env
/lib/udev/rules.d/95-kpartx.rules

* The hook for dmraid udev rules is wrong:
The script /usr/share/initramfs-tools/hooks/dmraid
tries to add:
/lib/udev/rules.d/85-dmraid.rules
but the existing file is called:
/lib/udev/rules.d/97-dmraid.rules

After fixing the above two issues, system boots normally.

* dmraid-activate is sometimes called with full device name
dmraid-activate expecte device name withouth "/dev/", e.g. "sda" not "/dev/sda". However the script
/usr/share/initramfs-tools/scripts/local-top/dmraid
calls dmraid-activate using the full device name and path.

* There might also be antoher bug on line 100 in dmraid-activate (in the awk script):
    # Heximal to decimal conversion array
    for (i = 0; i <= 9; i++) hex2dec[i] = i
    hex2dec["a"] = 10; hex2dec["b"] = 11; hex2dec["c"] = 12
    hex2dec["e"] = 13; hex2dec["d"] = 14; hex2dec["f"] = 15;
Element "e" and "d" appears to have been switched. I'm not entirely sure what the script is trying to do though, and that part of the script does not affect my system.

---
ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: dmraid 1.0.0.rc16-4.1ubuntu6 [modified: sbin/dmraid-activate usr/share/initramfs-tools/scripts/local-top/dmraid]
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
Date: Mon Feb 27 12:59:55 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120201.2)
ProcEnviron:
 PATH=(custom, user)
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
SourcePackage: dmraid
UpgradeStatus: Upgraded to precise on 2012-02-21 (5 days ago)

Related branches

Mårten Thornberg (marrowm) wrote :
description: updated
Mårten Thornberg (marrowm) wrote :

The activate_array function works, it's just that it runs "dmraid -ay -i -p -Z" and the -p option prevents partitions to be activated. Changing that doesn't work either though, since it looks like dmraid-activate is never called. I'm not sure how dmraid is supposed to activate the root device during boot in that case?

description: updated
summary: - dmraid-activate fails to activate (fakeraid) root device during boot
+ (fakeraid) root device not activated during boot
Phillip Susi (psusi) wrote :

The -p was added in precise because udev will now run kpartx to activate partitions. Does blkid identify the drives as raid members?

Mårten Thornberg (marrowm) wrote :

Stripe is on sda + sdb. When I run "blkid", sdb show up but not sda, "blkid -p sda" identifies it as part of raid though.

root@pongo:/dev# blkid -p sda
sda: TYPE="promise_fasttrack_raid_member" USAGE="raid"
root@pongo:/dev# blkid -p sdb
sdb: TYPE="promise_fasttrack_raid_member" USAGE="raid"
root@pongo:/dev# blkid
/dev/sdb: TYPE="promise_fasttrack_raid_member"
/dev/mapper/pdc_chjidjcfg1: LABEL="SSD" UUID="D6825DE9825DCF1D" TYPE="ntfs"
/dev/mapper/pdc_chjidjcfg5: LABEL="ubuntu" UUID="520af4ca-51ba-4238-a594-2d1b673f4a9e" UUID_SUB="f4cdc806-21be-4943-9e6d-d6a7645f311d" TYPE="btrfs"
/dev/mapper/pdc_chjidjcfg6: UUID="300c5e59-35ac-4654-809e-8d5d8391ce99" TYPE="swap"

Mårten Thornberg (marrowm) wrote :

If it helps:
root@pongo:~# kpartx -l /dev/mapper/pdc_chjidjcfg
pdc_chjidjcfg1 : 0 335544320 /dev/mapper/pdc_chjidjcfg 2048
pdc_chjidjcfg2 : 0 129296898 /dev/mapper/pdc_chjidjcfg 335546622
pdc_chjidjcfg5 : 0 112540672 /dev/dm-1 2
pdc_chjidjcfg6 : 0 16755968 /dev/dm-1 112540930

Mårten Thornberg (marrowm) wrote :

I've got dmraid-activate to load the device now (/dev/mapper/pdc_chjidjcfg) but the partitions still does not get loaded. kpartx is not available in busybox, is that correct?

Mårten Thornberg (marrowm) wrote :

There are no initramfs hooks for kpartx

also, in:
/usr/share/initramfs-tools/hooks/dmraid
it tries to add
/lib/udev/rules.d/85-dmraid.rules
but the existing file is called
/lib/udev/rules.d/97-dmraid.rules

When I fix the above and add hooks for kpartx everything works and ubuntu boots normally.

description: updated
Mårten Thornberg (marrowm) wrote :

dmraid-activate also use sed and awk when activating certain fakeraid types:

isw : Intel Software RAID (0,1,5,01)
ddf1 : SNIA DDF1 (0,1,4,5,linear)

I don't think awk and sed is available in the initramfs either so there
should probably be hooks for that too if there is a device of that type installed.

Phillip Susi (psusi) wrote :

Oops, this is my fault. I changed the priority of the udev rules file from 85 to 97 and must have forgot to update the initramfs hook to use the new path. I am in the hospital at the moment since my wife had our baby two weeks early the other day, so I'm going to ask cjwatson to make this quick fix for me.

Changed in dmraid (Ubuntu):
importance: Undecided → High
status: New → Triaged
tags: added: regression-potential
Phillip Susi (psusi) wrote :

Good work figuring that out by the way Marten. Many thanks.

JR (juergen-richtsfeld) wrote :

I've just upgraded to precise beta and had the same problem with my intel dmraid.

http://ubuntuforums.org/archive/index.php/t-1719850.html
helped (calling /sbin/dmraid -i -ay and commenting the rest).

Mårten Thornberg (marrowm) wrote :

Congratulations for the new baby :-)

I believe I have the same problem, but I'm not sure. Please enlighten me.

I have a Sony Vaio VPCZ13 with two SSD's striped out of the box. In the past I succesfully ran Natty and Oneiric. Now with Precise Beta 1 I can't boot anymore. I get dropped in a Busybox shell with the error that the device at /dev/by-uuid/... can't be found.

Luckily I did a dist-upgrade from Oneiric, so I can still boot without problems using the Oneiric kernel 3.0.0-16 option in grub. So is this related to the 3.2 kernel in Precise?

See also the following threads... Are these also related to this bug?

https://lists.launchpad.net/sony-vaio-z-series/msg02641.html

http://ubuntuforums.org/showthread.php?p=11760955

Thanks awesome devs!

W

Additional info...

When I choose kernel 3.2 in grub I'm dropped in Busybox shell. If I enter 'dmraid -ay' and 'exit', then normal boot procedure continues.

W

Phillip Susi (psusi) on 2012-03-13
Changed in dmraid (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Phillip Susi (psusi)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dmraid - 1.0.0.rc16-4.1ubuntu7

---------------
dmraid (1.0.0.rc16-4.1ubuntu7) precise; urgency=low

  * Fix Update initramfs hook to copy correct udev rules file with
    new priority of 97 instead of 85 (LP: #941874)
 -- Phillip Susi <email address hidden> Tue, 13 Mar 2012 14:12:07 -0400

Changed in dmraid (Ubuntu):
status: In Progress → Fix Released
Ryan Beasley (ryan-beasley) wrote :

I just updated to 1.0.0.rc16-4.1ubuntu7, but I still end up staring at an initramfs prompt before needing to manually issue "dmraid -ay" followed by Ctrl-D to resume boot.

We still need the kpartx hook, as pointed out by the bug submitter, in order to fix this. :)

Phillip Susi (psusi) on 2012-03-16
Changed in multipath-tools (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Phillip Susi (psusi)
Phillip Susi (psusi) wrote :

Wait a second, the kpartx udev rule shouldn't have anything to do with dmraid. The dmraid udev rule takes care of running kpartx.

Changed in multipath-tools (Ubuntu):
status: Triaged → Incomplete
DrTwox (drtwox) wrote :

I have this same problem with Kubuntu Precise Beta1.
I installed Kubuntu Precise Beta1 successfully (using default partition setup with a single SATA drive) and rebooted. The desktop loads without error. I run apt-get update && apt-get upgrade and then reboot. Now the boot process stops:

Gave up waiting for root device. Common problems:
 - Boot args (cat /proc/cmdline)
    - Check root delay= (did the system wait long enough?)
    - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/disk/by-uuid/8e6f9262-9fbb-48fb-b1f1-a5ba22f25554 does not exist.
Dropping to a shell!

BusyBox v1.18.5 (Ubuntu 1:1.18.5-1ubuntu2) build in shell (ash)
Enter 'help' for a list of built-in commands

(initramfs) cat /proc/partitions
major minor #blocks name

 11 0 1048575 sr0
  8 0 117220824 sda
252 0 117220823 dm-0

Ken Persing (specialk) wrote :

OK, no idea if this will help, but when I get thrown into initramfs, when running 'dmraid -ay', it says the raid volume is already activated, but in /dev I only have the raided drive (dm-0) and not any of the partitions (dm-1 and dm-2). Booting from a rescue disk, I have the same problem and after running kpartx (iirc, kpartx -a /dev/dm-0, I'm not in front of my pc), the devices appear and can be mounted.

So, if the dmraid udev tool is supposed to take care of running kpartx... it's not working.

btw, drives are running under "isw : Intel Software RAID" (4x120gb agility 3s, sda-sdd), so I'm not sure if I'm affected by the lack of awk and sed hooks as martin pointed out earlier...

Cheers,

Ken

Here's what fixed it for me:

change the following line in sbin/dmraid-activate back to the same as it was in initrd.img.3.0.0.12-generic from Oneric:

Change (around line 75):
 # array brought up in degraded mode, except in the case of striped arrays.

 dmraid -p -i -ay -Z "$1"

To:
 # array brought up in degraded mode, except in the case of striped arrays.

 dmraid -i -ay -Z "$1"

I'm curious to know the reason they decided to add the -p in this version. Does anyone know?

Let me know if you need me to post the step-by-step fix.. most people probably have no idea about how to pkg/re-pkg the initrd file.

Cheers!
Shannon

Download full text (4.2 KiB)

Ken,

for me, everything was in /dev/mapper and before running dmraid -ay
ls /dev/mapper/ only had the device, not the partitions:
isw_dgjgchief_Volume0

Then after dmraid -ay, ls /dev/mapper shows (p1,p2,p3 being my /, home,
swap partitions):
isw_dgjgchief_Volume0p1 isw_dgjgchief_Volume0p3
isw_dgjgchief_Volume0 isw_dgjgchief_Volume0p2

I think my machine is running with the sd drives setup as striped.

Never the less, the fix in my previous comment works for my situation.

Regards,
Shannon

On Sun, Mar 18, 2012 at 7:47 PM, Ken Persing <email address hidden> wrote:

> OK, no idea if this will help, but when I get thrown into initramfs,
> when running 'dmraid -ay', it says the raid volume is already activated,
> but in /dev I only have the raided drive (dm-0) and not any of the
> partitions (dm-1 and dm-2). Booting from a rescue disk, I have the same
> problem and after running kpartx (iirc, kpartx -a /dev/dm-0, I'm not in
> front of my pc), the devices appear and can be mounted.
>
> So, if the dmraid udev tool is supposed to take care of running
> kpartx... it's not working.
>
> btw, drives are running under "isw : Intel Software RAID" (4x120gb
> agility 3s, sda-sdd), so I'm not sure if I'm affected by the lack of awk
> and sed hooks as martin pointed out earlier...
>
> Cheers,
>
> Ken
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/941874
>
> Title:
> (fakeraid) root device not activated during boot
>
> Status in “dmraid” package in Ubuntu:
> Fix Released
> Status in “multipath-tools” package in Ubuntu:
> Incomplete
>
> Bug description:
> I have installed Precise Pangolin Alpha 2 to a fakeraid stripe, but
> ubuntu fails to boot after install. When choosing recovery option, the
> boot process times out waiting for root device and drops to busybox
> shell. Running "dmraid -ay" and exiting busybox resumes boot and it
> continues normally.
>
> ---
> The problems are:
>
> * There are no initramfs hooks for kpartx, so kpartx is not available
> during boot.
> the following files are needed:
> /sbin/kpartx
> /lib/udev/kpartx_id
> /lib/udev/dmsetup_env
> /lib/udev/rules.d/95-kpartx.rules
>
> * The hook for dmraid udev rules is wrong:
> The script /usr/share/initramfs-tools/hooks/dmraid
> tries to add:
> /lib/udev/rules.d/85-dmraid.rules
> but the existing file is called:
> /lib/udev/rules.d/97-dmraid.rules
>
> After fixing the above two issues, system boots normally.
>
> * dmraid-activate is sometimes called with full device name
> dmraid-activate expecte device name withouth "/dev/", e.g. "sda" not
> "/dev/sda". However the script
> /usr/share/initramfs-tools/scripts/local-top/dmraid
> calls dmraid-activate using the full device name and path.
>
> * There might also be antoher bug on line 100 in dmraid-activate (in the
> awk script):
> # Heximal to decimal conversion array
> for (i = 0; i <= 9; i++) hex2dec[i] = i
> hex2dec["a"] = 10; hex2dec["b"] = 11; hex2dec["c"] = 12
> hex2dec["e"] = 13; hex2dec["d"] = 14; hex2dec["f"] = 15;
> Element "e" and "d" appears to have been switched. I'm not entirely sure
> what the script is try...

Read more...

Ah.. disregard my previous comment.. they're just links to dm-0 thru dm-3

ls -l /dev/mapper
lrwxrwxrwx 1 root root 7 Mar 18 21:05 isw_dgjgchief_Volume0 -> ../dm-0
lrwxrwxrwx 1 root root 7 Mar 18 21:05 isw_dgjgchief_Volume0p1 ->
../dm-1
lrwxrwxrwx 1 root root 7 Mar 18 21:05 isw_dgjgchief_Volume0p2 ->
../dm-2
lrwxrwxrwx 1 root root 7 Mar 18 21:05 isw_dgjgchief_Volume0p3 ->
../dm-3

I have a RAID stripe of 3 64GB sd drives on this machine. So I wonder if
that's different than your configuration?

hwinfo shows..
  dm_log 18564 3 dm_raid45,dm_mirror,dm_region_hash, Live 0x0000000000000000
25: PCI 1f.2: 0104 RAID bus controller
  Model: "Intel Mobile 82801 SATA RAID Controller"
  Device: pci 0x282a "Mobile 82801 SATA RAID Controller"
  Attached to: #25 (RAID bus controller)

Phillip Susi (psusi) wrote :

The -p is to disable dmraid's internal handling of partitions in favor of letting kpartx take care of it. This was done because kpartx also supports GPT, but dmraid does not.

Can you try updating your initramfs and see if that helps?

sudo update-initramfs -u

Also please make sure you are running the -ubuntu7 version of dmraid.

Mårten Thornberg (marrowm) wrote :

I think kpartx, sed and awk is also missing in the ramfs, at least for me. kpartx can not mount a root partitions if kpartx is not available during boot... sed and awk is used by the dmraid-activate script in some cases as well... not for my controller though so I can not test it. I added kpartx hooks on my machine as well, which fixed the issue for me.

Phillip Susi (psusi) wrote :

What do you mean by "added kpartx hooks"?

Mårten Thornberg (marrowm) wrote :

Sorry if I'm using the wrong terminology, I just called it hooks because that is what the folder is named.

I mean I have added a script very similar to:

    /usr/share/initramfs-tools/hooks/dmraid

which copies the necessary kpartx files to the initramfs as well, when doing update-initramfs -u (at least that is what I assume happens ;)).

I include these for kpartx:
    /sbin/kpartx
    /lib/udev/kpartx_id
    /lib/udev/dmsetup_env
    /lib/udev/rules.d/95-kpartx.rules

Mårten Thornberg (marrowm) wrote :

Attaching file:
-rwxr-xr-x 1 root root 490 feb 29 18:53 /usr/share/initramfs-tools/hooks/kpartx

Phillip Susi (psusi) wrote :

Ok, kpartx has a hook rule that is supposed to do that already, but for some reason, it is not being installed. It looks like a packaging error of some sort.

Changed in multipath-tools (Ubuntu):
status: Incomplete → Triaged

>Can you try updating your initramfs and see if that helps?
>
>sudo update-initramfs -u
I did this and I still get dropped to the busybox, just after "begin running scripts/local-top...done" shows during boot.

From busybox, ls /dev shows these (disk but not the partitions):
/dev/dm-0
/dev/isw_dgjgchief_Volume0

cat /proc/kmsg shows at the end:
device-mapper:dm-raid45:initialized v0.2594b

>Also please make sure you are running the -ubuntu7 version of dmraid.
I'm not sure how to check this. As for the dmraid command, from busybox:
dmraid -V shows:
dmraid version: 1.0.0.rc16 (2009.09.16) shared
dmraid library version: 1.0.0.rc16 (2009.09.16) shared
device-mapper version: 4.22.0 (or perhaps 4.2.2.0)

Let me know if you need anything else.
Cheers!

Phillip Susi (psusi) wrote :

I've fixed both packages to get this working and set up an isw dmraid with my old disks and installed precise and the updated packages to verify it works. Just waiting for a sponsor to merge the changes.

Changed in dmraid (Ubuntu):
status: Fix Released → In Progress
Changed in multipath-tools (Ubuntu):
status: Triaged → In Progress
Phillip Susi (psusi) on 2012-03-31
Changed in dmraid (Ubuntu):
importance: High → Critical
Changed in multipath-tools (Ubuntu):
importance: High → Critical
Adam Conrad (adconrad) on 2012-03-31
Changed in dmraid (Ubuntu):
milestone: none → ubuntu-12.04
Changed in multipath-tools (Ubuntu):
milestone: none → ubuntu-12.04
Adam Conrad (adconrad) wrote :

Giving my release team nod for the FFe required to do the simple package split in the multipath-tools branch, and sponsoring the upload (after tidying it a bit). Thanks for looking at this.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dmraid - 1.0.0.rc16-4.1ubuntu8

---------------
dmraid (1.0.0.rc16-4.1ubuntu8) precise; urgency=low

  * Depend on kpartx-boot to pull kpartx into the initramfs (LP: #941874)
 -- Phillip Susi <email address hidden> Tue, 20 Mar 2012 15:37:44 -0400

Changed in dmraid (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package multipath-tools - 0.4.9-3ubuntu5

---------------
multipath-tools (0.4.9-3ubuntu5) precise; urgency=low

  * Split kpartx initramfs bits into kpartx-boot for dmraid (LP: #941874)
 -- Phillip Susi <email address hidden> Tue, 20 Mar 2012 15:26:22 -0400

Changed in multipath-tools (Ubuntu):
status: In Progress → Fix Released

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Shannon

Shannon VanWagner
Network Administrator / IT Support at Airbiquity
Greater Seattle Area

Confirm that you know Shannon VanWagner:
https://www.linkedin.com/e/alfvy9-h0hg05c2-9/isd/6509490604/6f-LEnoQ/?hs=false&tok=3SJK737u_n3Rc1

--
You are receiving Invitation to Connect emails. Click to unsubscribe:
http://www.linkedin.com/e/alfvy9-h0hg05c2-9/h0kdSFiu9-8jrf7-iGTqW4yu8QLJwPAsKnQLHRa/goo/941874%40bugs%2Elaunchpad%2Enet/20061/I2257831682_1/?hs=false&tok=3QVqCwUqPn3Rc1

(c) 2012 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.

Sorry about the linkedin spam.. I think I bombed my address book with it. Please feel free to delete comment #35.

With this release, the problem is fixed for me :-)

Mårten Thornberg (marrowm) wrote :

Works for me as well now, thanks!

Works for me as well now, thanks!

Adi Pircalabu (apircalabu) wrote :

Apparently I have a related problem after an upgrade from 11.10 done using "do-release-upgrade". The troubled server has all the partitions on a software RAID 1. With the new kernel (3.2.0-24.37) it failed to mount the root partition, dropping to a busybox shell. After booting the ol kernel I found there's no dmraid package installed on the server. Installing it also pulled kpartx-boot as dependency and now I have /usr/share/initramfs-tools/hooks/kpartx in place. update-initramfs appears to have generated a bootable initrd this time, but I haven't had the chance to test it yet.
Also, looking at the initrd images for 3.0.0-16-server and 3.2.0-24-generic I found there are no dmraid & kpartx related entries in 3.0.0.16 image.
Is it perhaps worth to have dmraid & kpartx-boot as dependencies for a basic installation? For some reason they were not installed previously. Should I file a new bug for this? I haven't found anything similar yet.

Basic information:
# cat /etc/issue
Ubuntu 12.04 LTS \n \l
# uname -a
Linux ddns02.ddns.local 3.0.0-16-server #29-Ubuntu SMP Tue Feb 14 13:08:12 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
(now running the old kernel)
# dpkg -l | grep linux-image
ii linux-image-3.0.0-16-server 3.0.0-16.29 Linux kernel image for version 3.0.0 on x86_64
rc linux-image-3.0.0-17-server 3.0.0-17.30 Linux kernel image for version 3.0.0 on x86_64
ii linux-image-3.2.0-24-generic 3.2.0-24.37 Linux kernel image for version 3.2.0 on 64 bit x86 SMP
ii linux-image-server 3.2.0.24.26 Linux kernel image on Server Equipment.
# cat /proc/mdstat
Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
md2 : active raid1 sda3[0] sdb3[1]
      955277176 blocks super 1.2 [2/2] [UU]

md1 : active raid1 sda2[0] sdb2[1]
      19529656 blocks super 1.2 [2/2] [UU]

md0 : active raid1 sdb1[1] sda1[0]
      1950708 blocks super 1.2 [2/2] [UU]

md127 : active raid1 sdd1[1] sdc1[0]
      976760400 blocks super 1.2 [2/2] [UU]

unused devices: <none>

# mount| grep md
/dev/md1 on / type ext4 (rw,errors=remount-ro)

Adi Pircalabu (apircalabu) wrote :

Quick update to my previous update: after rebuilding initrd image with dmraid & kpartx it's all good, now 3.2.0-24-generic finds the root partition and loads the OS.

Phillip Susi (psusi) wrote :

Adi, dmraid is for fake hardware raid support, not the software raid you are using. Your issue seems to be unrelated to dmraid or this bug report.

path (patrick-harzheim) wrote :

Just worked around the same problem that Adi Piracalabu described. Installed Ubuntu 12.04 release Amd64 image on fakeraid raid5. With my boot loader, root directory and swap all on a separate disc. Then my home directory on my raid 5. Installation completed successfully.

Rebooting fails to mount my raid5 drive, I skip mounting the home directory and I can't access my main account that has the home directory on those discs. Logging in with a guest account and creating a separate admin account with my main accounts passwords, permitted me to install dmraid. With a reboot from that software state. The home directory on the raid5 is mounted and my account that has the home directory in the raid5 is accessible. That's where it works for me right now.

With some analysis, after a few re installations. I noticed that the installation of 12.04 does not install dmraid at all? Basically if I performed the installation and continued to try ubuntu before restarting into it. Then mounted the disk I installed to. Dmraid does not appear to be installed in the libs, binaries, initramfs...

While trying ubuntu 12.04 the raids are accessible, but when you install 12.04, it skips or fails the dmraid package and the rest of those dependencies.

If this could be fixed; if the installer can successfully place the dmraid package, if it installs on a system that has fakeraids; then I think I'll finally be able to boot off of a fakeraid without a workaround.

Danny Wood (danwood76) wrote :

@Path

Off topic for a bug report but I will set you straight on a few things.

Dmraid support is good but for later hardware is crappy at best but don't blame the Ubuntu devs. The original developer (a red hat guy) stopped developing the project a while ago and we have been trying to get him to merge fixes for years.

There is a far better implementation for software raid which is mdadm, but this is not compatible with windows dual boot. Do you rant on Microsofts bug reports that they don't support 100% of features of mdadm? (they actual support no features of mdadm and dont have public bug reports)

This bug has been fixed by Phillip Susi who is a dedicated maintainer and usually fixes bugs very quickly. The only issues are when bugs pop up after the development cycle which makes it harder to get them merged due to the merging requirements after release.

Final thoughts. Ubuntu is an 'Unstable' operating system (built from debian unstable) and it uses the latest software packages that can be unstable but usually in this LTS until the 12.04.1 release.

Laurie Kell (lauriekell) wrote :

Hi

I am encountering the same problems, in that I am trying to install UBUNTU 12.04 on a Sony vaio VPCZ13C5E. But can't get past busybox.

I used boot/repair to try and fix the problem, the diagnostics and a dscription of my system are at http://paste.ubuntu.com/1126678/

Any help would be appreciated.

Laurie

Don mylastname (pir8don) wrote :

Hi all

this is a real doozy.

I need to run 10.04 because it has userful mutiseat and can boot the same partition on a single disk but can't on my fake raid. gpt partitioning on the raid because it is 4tb.

I can boot 12.04 (kde) on the fake raid fine but get the same error as above when trying to boot to the raid partition. Have tried dmraid -ay as suggested above and have tried introducing 120s delay in boot params but still no successful boot. Have also copied the early grub commands from the 12.04 boot and have tried using the device name rather than uuid but nothing does the trick.

It seems that the disks in the raid are both recognised as being raid members but the partitions are not available to the boot.

Can anyone offer a work around?

Don

Phillip Susi (psusi) wrote :

Unless you must dual boot this system with Windows, the best thing to do is not to use fake raid. Switch to regular Linux software raid instead.

Ebbex (eb4x) wrote :

I've just installed a HP Microserver (N40L) with the latest installer from precise-updates/main/installer-amd64/20101020ubuntu136.9/images/quantal-netboot. The installer fails to activate the raid, so I had to drop into a shell, write dmraid -ay, to continue the installation.

After the install, I have the exact same problem, I'm always dropped into the busybox initramfs shell, write "dmraid -ay" to activate the raid, and "exit", and boot continues as normal.

I've solved my problem by adding the line "[ -x /sbin/dmraid ] && /sbin/dmraid -ay" to the end of the /usr/share/initramfs-tools/scripts/local-top/dmraid as suggested in https://bugs.launchpad.net/ubuntu/+source/dmraid/+bug/247027/comments/21

But I'm guessing there's a more sophisticated procedure that's not kicking in on my system. What information can I start providing to help get this fixed? (If there's a ubuntu developer interested, I can provide access directly to the box via the ilo device.)

linux-image-3.5.0-36-generic #57 precise1 (amd64)
dmraid 1.0.0.rc16-4.1ubuntu8

Phillip Susi (psusi) wrote :

Before running dmraid -ay, what does blkid show?

Ebbex (eb4x) wrote :

(initramfs) blkid
(initramfs) blkid -p /dev/sd[a-d]
/dev/sda: TYPE="promise_fasttrack_raid_member" USAGE="raid"
/dev/sdb: TYPE="promise_fasttrack_raid_member" USAGE="raid"
/dev/sdc: TYPE="promise_fasttrack_raid_member" USAGE="raid"
/dev/sdd: TYPE="promise_fasttrack_raid_member" USAGE="raid"

Without any parameters blkid doesn't return anything.

Ebbex (eb4x) wrote :

(initramfs) dmraid -ay
RAID set "pdc_ebdeeaiceb-0" was activated
RAID set "pdc_ebdeeaiceb-1" was activated
RAID set "pdc_ebdeeaiceb" was activated
RAID set "pdc_ebdeeaiceb1" was activated
RAID set "pdc_ebdeeaiceb2" was activated
RAID set "pdc_ebdeeaiceb3" was activated

Phillip Susi (psusi) wrote :

If /dev/mapper/pdc_ebdeeaiceb does not exist without you having to run dmraid, then it is unrelated to this bug. Please file a new one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers