dmraid-activate failed due to lack of 'awk'

Bug #879752 reported by Gary Oliver on 2011-10-22
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
dmraid (Debian)
New
Unknown
dmraid (Ubuntu)
High
Ubuntu Installer Team

Bug Description

Using the "server" and "alternate" install images for 11.10 amd64, activating a raid array results in:

disk-detect: /sbin/dmraid-activate: line 263: awk: not found
disk-detect: /sbin/dmraid-activate: line 263: awk: not found
(i.e. twice)

From appearances, dmraid-active is attempting to use awk in its script, but awk is not
available in the root fs of the installer.

Hardware and environment:
Supermicro 1u box with X7DCA-L motherboard 2.4GHz XEON
8G ECC ram
dual 500G hard drives configured as "raid 1" with Adaptec controller emulation

affects: debian-installer (Ubuntu) → dmraid (Ubuntu)
Changed in dmraid (Ubuntu):
importance: Undecided → High
status: New → Triaged
Steve Langasek (vorlon) on 2012-01-06
Changed in dmraid (Ubuntu):
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
Molly Fletcher (molly-fletcher) wrote :

Also seeing this in both 12.04 and 12.10 server (amd64) on a HP Proliant DL320G5 with the on the board Intel sataraid

Molly Fletcher (molly-fletcher) wrote :

switching to another console and doing "dmraid -ay" then switching back to the installer and selecting "go back" -> "detect disks" allows the install to proceed if anyone needs a work around until this is fixed.

Changed in dmraid (Debian):
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.