Ubuntu

tmp cleaned during upgrades and breaking installations?

Reported by Akoley Marc on 2009-10-06
166
This bug affects 24 people
Affects Status Importance Assigned to Milestone
dmraid (Ubuntu)
Critical
Loïc Minier
Karmic
Critical
Loïc Minier
mountall (Ubuntu)
High
Scott James Remnant (Canonical)
Karmic
High
Scott James Remnant (Canonical)

Bug Description

Binary package hint: evolution

1-Description: Ubuntu karmic (development branch)
Release: 9.10

2-evolution-plugins-experimental:
  Installé : 2.28.0-0ubuntu4
  Candidat : 2.28.0-0ubuntu4
 Table de version :
 *** 2.28.0-0ubuntu4 0
        500 http://fr.archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status
3-A update expected to happen

4-this don't happen i have a crash notification instead

ProblemType: Package
Architecture: i386
Date: Tue Oct 6 06:14:11 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: problèmes de dépendances - laissé non configuré
NonfreeKernelModules: nvidia
Package: evolution-plugins-experimental 2.28.0-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: evolution
Title: package evolution-plugins-experimental 2.28.0-0ubuntu4 failed to install/upgrade: problèmes de dépendances - laissé non configuré
Uname: Linux 2.6.31-11-generic i686

Akoley Marc (ekomak) wrote :
Sebastien Bacher (seb128) wrote :

The issue is a gconf one

"Traceback (most recent call last):
  File "/usr/sbin/gconf-schemas", line 73, in <module>
    shutil.rmtree(tmp_home)
  File "/usr/lib/python2.6/shutil.py", line 208, in rmtree
    onerror(os.listdir, path, sys.exc_info())
  File "/usr/lib/python2.6/shutil.py", line 206, in rmtree
    names = os.listdir(path)
OSError: [Errno 2] No such file or directory: '/tmp/gconf-BBrcKQ'"

affects: evolution (Ubuntu) → gconf (Ubuntu)
affects: gconf (Ubuntu) → evolution (Ubuntu)
Sebastien Bacher (seb128) wrote :

Do you get the issue if you retry the installation?

affects: evolution (Ubuntu) → gconf (Ubuntu)
summary: - package evolution-plugins-experimental 2.28.0-0ubuntu4 failed to
- install/upgrade: problèmes de dépendances - laissé non configuré
+ gconf-schemas:OSError: [Errno 2] No such file or directory
summary: - gconf-schemas:OSError: [Errno 2] No such file or directory
+ gconf-schemas: OSError: [Errno 2] No such file or directory

The issue goes away after a dpkg --configure -a or a apt-get upgrade

Changed in gconf (Ubuntu):
status: New → Confirmed
affects: gconf (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Undecided → High
summary: - gconf-schemas: OSError: [Errno 2] No such file or directory
+ tmp cleaned during upgrades and breaking installations
summary: - tmp cleaned during upgrades and breaking installations
+ tmp cleaned during upgrades and breaking installations?
Loïc Minier (lool) on 2009-10-06
Changed in ubuntu:
importance: High → Critical
Michael Vogt (mvo) wrote :

Just for the record, I tried to reproduce this on a stock ubuntu install and my /tmp was not cleared.

Michael Vogt (mvo) wrote :

From the apt log:

Paramétrage de brasero (2.28.1-0ubuntu1) ...^M
^M
Paramétrage de libdevkit-power-gobject1 (010+git20090913-0ubuntu2) ...^M
^M
Paramétrage de devicekit-power (010+git20090913-0ubuntu2) ...^M
^M
Paramétrage de libdmraid1.0.0.rc15 (1.0.0.rc15-11ubuntu1) ...^M
^M
Paramétrage de dmraid (1.0.0.rc15-11ubuntu1) ...^M
update-initramfs: deferring update (trigger activated)^M
^M
Paramétrage de evolution-common (2.28.0-0ubuntu4) ...^M
Paramétrage de evolution (2.28.0-0ubuntu4) ...^M
Traceback (most recent call last):^M
  File "/usr/sbin/gconf-schemas", line 73, in <module>^M
    shutil.rmtree(tmp_home)^M
  File "/usr/lib/python2.6/shutil.py", line 208, in rmtree^M
    onerror(os.listdir, path, sys.exc_info())^M
  File "/usr/lib/python2.6/shutil.py", line 206, in rmtree^M
    names = os.listdir(path)^M
OSError: [Errno 2] No such file or directory: '/tmp/gconf-BBrcKQ'^M
dpkg : erreur de traitement de evolution (--configure) :^M
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1^M

Brasero uses gconf-schema too, so if it is/was a postinst script, it must be in one of the packages
between brasero and the failure

Michael Vogt (mvo) wrote :

Something similar in the other report:

Paramétrage de brasero (2.28.1-0ubuntu1) ...^M
^M
Paramétrage de libdevkit-power-gobject1 (010+git20090913-0ubuntu2) ...^M
^M
Paramétrage de devicekit-power (010+git20090913-0ubuntu2) ...^M
^M
Paramétrage de libdmraid1.0.0.rc15 (1.0.0.rc15-11ubuntu1) ...^M
^M
Paramétrage de dmraid (1.0.0.rc15-11ubuntu1) ...^M
update-initramfs: deferring update (trigger activated)^M
^M
Paramétrage de evolution-common (2.28.0-0ubuntu4) ...^M
Paramétrage de evolution (2.28.0-0ubuntu4) ...^M
Traceback (most recent call last):^M
  File "/usr/sbin/gconf-schemas", line 73, in <module>^M
    shutil.rmtree(tmp_home)^M
  File "/usr/lib/python2.6/shutil.py", line 208, in rmtree^M
    onerror(os.listdir, path, sys.exc_info())^M
  File "/usr/lib/python2.6/shutil.py", line 206, in rmtree^M
    names = os.listdir(path)^M
OSError: [Errno 2] No such file or directory: '/tmp/gconf-DXgm31'^M
dpkg : erreur de traitement de evolution (--configure) :^M
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1^M

Loïc Minier (lool) on 2009-10-06
affects: ubuntu → dmraid (Ubuntu)
Loïc Minier (lool) wrote :

It seems this happens when installing dmraid; the faulty command causing /tmp to be cleared is:
udevadm trigger --subsystem-match=block --action=change
(as root)

Loïc Minier (lool) wrote :

This was worked around in dmraid 1.0.0.rc15-11ubuntu2; I closed the wrong bug in the changelog, so closing manually now.

dmraid (1.0.0.rc15-11ubuntu2) karmic; urgency=low

  * Comment out "udevadm trigger" call in postinst for now as it has severe
    consequences when mountall is installed (clears /tmp). If dmraid is
    installed, then presumably the important system devices are up and one can
    be bothered with a reboot to take the change into account. Let
    update-initramfs flag the system as needing a reboot. LP: #444545.

 -- Loïc Minier <email address hidden> Tue, 06 Oct 2009 17:54:44 +0200

Changed in dmraid (Ubuntu):
assignee: nobody → Loïc Minier (lool)
status: Confirmed → Fix Released
Loïc Minier (lool) on 2009-10-06
Changed in mountall (Ubuntu Karmic):
status: New → Triaged
assignee: nobody → Scott James Remnant (scott)
importance: Undecided → High
Changed in mountall (Ubuntu Karmic):
status: Triaged → In Progress
milestone: none → ubuntu-9.10
Changed in mountall (Ubuntu Karmic):
status: In Progress → Fix Committed

I've uploaded a new mountall package to the ubuntu-boot PPA:

https://launchpad.net/~ubuntu-boot/+archive/ppa

I would appreciate it if you could install this and try it out. *BEFORE* you reboot though, could you run "sudo mountall --debug > mountall.log 2>&1" and attach that to this bug - then after you reboot, let me know whether it worked or not.

Thanks

Sorry about the issues with the previous PPA versions, as usual things worked just fine when I tested it in the various rigs I have here - of course it flatly failed when installed on normal systems because I hadn't actually tested that ;)

I've uploaded a new ~boot4 version, this one feels much better (and I'm running it on my laptop now :p)

As before, after installing the package but *before* you reboot, please run with --debug and attach the log to the bug - then after rebooting, let me know how it works out.

Thanks for all your help with testing, this is a big change and it's good to know that it's now working for 95% of people and your help getting it work for the final 5% is greatly appreciated!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mountall - 0.2.0

---------------
mountall (0.2.0) karmic; urgency=low

  [ Colin Watson ]
  * Always check the root filesystem if --force-fsck is used, regardless of
    passno. LP: #435707.

  [ Johan Kiviniemi ]
  * Have each fsck instance create a lock for each underlying physical device.
    If you have a single disk or RAID, all filesystem checks will happen
    sequentially in order to avoid thrashing. On more complex configurations,
    you’ll benefit from the parallel checks mountall has been doing all along.
    LP: #434974.

  [ Scott James Remnant ]
  * Flush standard output and error before spawning processes to make
    capturing logs easier (otherwise we end up repeating things still in
    the buffer), and before calling exec().
  * Turn the code upside down so that each mount knows what it's waiting
    for, and allow multiple dependencies. This makes the code much more
    readable putting the "policy" in a single function, and will make it
    much easier in future when this is done by Upstart.
  * For kernel filesystems listed in fstab, honour the order that they
    are listed in fstab. LP: #432571, #433537, #436796
  * Always create new swap partition mounts for each fstab entry, don't
    treat them as updating the same. LP: #435027.
  * Virtual filesystems under local or remote filesystems (and local under
    remote) don't delay the virtual or local events. LP: #431040.
  * Simplify event emission, this has the advantage that we can now output
    what mount points we're waiting for and what they are waiting for as
    well.
  * Fixed issue with trailing slashes. LP: #443035.
  * Only run hooks if the filesystem was not already mounted. LP: #444252.
  * Don't clean up /tmp when run without --tmptime argument.
  * Ignore loop and ram devices until ready. LP: #441454.
  * Add options to binfmt_misc filesystem, which will probably cause it to
    be mounted on boot as well.
  * Synchronously mount local and virtual filesystems, I suspect this is
    the real cause behind the XFS races as one will modprobe and the other
    will not (and fail). LP: #432620.
  * Synchronously activate swap to avoid out of memory issues when checking
    the root filesystem.
  * Enumerate existing udev devices on startup, so we don't always have to
    see udev be coldplugged.
  * Don't break on general errors for non-essential filesystems.
    LP: #441144.
  * Don't repeat attempts to mount a filesystem without having first
    succeded to mount another.
  * Still restart mountall even if the recovery shell fails.
  * Don't queue filesystem check when device is "none", or missing, or the
    filesystem is marked nodev.
  * Generate a "mount" event before mounting a filesystem, and wait for its
    effects to complete.

 -- Scott James Remnant <email address hidden> Fri, 09 Oct 2009 16:50:46 +0100

Changed in mountall (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers