Ubuntu

isw: Error finding disk table slot

Reported by William on 2008-09-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dmraid (Ubuntu)
Undecided
Luke Yelavich

Bug Description

Binary package hint: dmraid

This is a spin off from Bug 112402. (May be related also to Bug 162484 as I have the Intel 82801 Controller)

ubuntu@ubuntu:~$ sudo dmraid -n /dev/sda
ERROR: isw: Error finding disk table slot for /dev/sda
No RAID disks and with names: "/dev/sda"

ubuntu@ubuntu:~$ sudo hdparm -i /dev/sda

/dev/sda:

 Model=Hitachi HTS722016K9A300 , FwRev=DCDOC54P, SerialNo=071219DP1D10DFG7D1NP
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
 BuffType=DualPortCache, BuffSize=15203kB, MaxMultSect=16, MultSect=?0?
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=312581808
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes: pio0 pio1 pio2 pio3 pio4
 DMA modes: mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6
 AdvancedPM=yes: mode=0x80 (128) WriteCache=enabled
 Drive conforms to: unknown: ATA/ATAPI-2,3,4,5,6,7

 * signifies the current active mode

ubuntu@ubuntu:~$ lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04

ubuntu@ubuntu:~$ apt-cache policy dmraid
dmraid:
  Installé : 1.0.0.rc14-0ubuntu3
  Candidat : 1.0.0.rc14-0ubuntu3
 Table de version :
 *** 1.0.0.rc14-0ubuntu3 0
        500 http://archive.ubuntu.com hardy/universe Packages
        100 /var/lib/dpkg/status

Related branches

Phillip Susi (psusi) wrote :

Can you dump the last two sectors of the disk and attach them to this report? Do the following:

sudo dd if=/dev/sda skip=312581805 | bzip2 -c > metadata.bz2

Changed in dmraid:
status: New → Incomplete
Sam Bingner (sam-bingner) wrote :

I had the same problem -- the attached patch should fix it...

William (william-dupre) wrote :

Philip, Sam,

sorry for the delay. In order to test this I need to revert my config to support the RAID and will therefore have to wipe the disks.

I can do it but I will need a few more time.
How could I test the patch attached ? Will I need to recompile myself the dmraid package ? Is there any way to get an already compile package that I could test right away ?

Thanks a lot
William

Sam Bingner (sam-bingner) wrote :

I went ahead and posted a compiled version for x86_64 at: http://www.bingner.com/dmraid

or you can wait for the maintainers to either accept my patch or come up with another version and post it in the main package... the problem was pretty simple once I realized the serial number of my drive was >16 characters and the raid metadata only had the last 16 characters.

Phillip Susi (psusi) wrote :

Hrm... interesting. I had thought the issue was with whitespace being removed from serial numbers that shouldn't. I wonder if this is a separate issue or if this was the problem all along.

Changed in dmraid:
status: Incomplete → In Progress
Sam Bingner (sam-bingner) wrote :

Any plans to incorporate this or a similar fix? Should I be reporting this somewhere else? I'd like to be able to not constantly avoid updating dmraid...

Phillip Susi (psusi) wrote :

Luke, can you apply this patch to the svn repo?

Changed in dmraid:
assignee: nobody → themuso
status: In Progress → Fix Committed
William (william-dupre) wrote :

Sam, Philip,

Took me some time but I finally manage to reset the Raid 0 on my machine and restart an install from scratch.

I am using Ibex latest live cd
Linux ubuntu 2.6.27-7-generic #1 SMP Fri Oct 24 06:40:41 UTC 2008 x86_64 GNU/Linux
and the current dmraid package does not work (1.0.0.rc14-2ubuntu12) I still get NO raid

ubuntu@ubuntu:~$ sudo dmraid -ay
ERROR: isw: Error finding disk table slot for /dev/sdb
ERROR: isw: Error finding disk table slot for /dev/sda
No RAID disks
ubuntu@ubuntu:~$ dmraid --version
dmraid version: 1.0.0.rc14 (2006.11.08) shared
dmraid library version: 1.0.0.rc14 (2006.11.08)
device-mapper version: unknown

After installing the one from Sam (same version info so that does not help to differentiate)
ubuntu@ubuntu:~$ sudo dmraid -ay
ubuntu@ubuntu:~$

and then
ubuntu@ubuntu:~$ cd /dev/mapper/
ubuntu@ubuntu:/dev/mapper$ ls -altr
total 0
crw-rw---- 1 root root 10, 60 2009-01-12 15:17 control

Which puzzles me a little. Should I not find a raid volume name ?

Thanks for your input

Changed in dmraid:
status: Fix Committed → Confirmed
William (william-dupre) wrote :

Managed to solve it. The disk was used and the liveCD had mounted sdb so the raid device volume could not be recognized.

After unmount sdb, I had the correct info from dmraid -ay.

So I am now running Ibex on Raid 0 with my Intel array.

Thanks a lot Sam.

Just one small thing: The version number being the same as the one from the standard repo, it proposes to update the dmraid module on each connexion.
When and How will I be warned that this patch has been included in the standard tree ?

Thanks again and Happy new year !!!

Applied Sam's patch in the git repository:

commit 748a00110906b0b7fedf2e7cab5d11699fd576aa
Author: Giuseppe Iuculano <email address hidden>
Date: Fri Mar 6 08:56:28 2009 +0100

    debian/patches/14_isw-serial-fix.patch: Change the serial number scan to only look at the LAST 16 bytes rather than the first. Thanks Sam Bingner (LP: #267953)

Changed in dmraid:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dmraid - 1.0.0.rc15-1ubuntu3

---------------
dmraid (1.0.0.rc15-1ubuntu3) jaunty; urgency=low

  * debian/patches/09_promise-add-offsets.patch: Added 591 disk offset
    locations for Promise RAID metadata. (ASUS M3A equipped with the
    SB600 south bridge), change taken from Debian's dmraid git repo.
  * debian/patches/14_isw-serial-fix.patch: Change the serial number scan to
    only look at the LAST 16 bytes rather than the first. Thanks Sam Bingner
    (LP: #267953, taken from Debian's dmraid git repo.

 -- Luke Yelavich <email address hidden> Tue, 17 Mar 2009 16:19:16 +1100

Changed in dmraid:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers