dmraid missing from live cd

Bug #212309 reported by Andrea Bocci on 2008-04-05
6
Affects Status Importance Assigned to Milestone
dmraid (Ubuntu)
Wishlist
Unassigned
Nominated for Intrepid by Erik Engberg
Nominated for Jaunty by Erik Engberg

Bug Description

Kubuntu 8.04 beta - live CD

At least as of 8.04 beta, the desktop live CD does not include "dmraid".
Since "fake" raid is becoming quite common, and dual booting is unfortunately still too common, it would be useful to be able to install Ubuntu on a shared "fake" raid volume.

This is currently quite straightforward provided one knows the necessary steps:
 - "apt-get install dmraid" to the live environment
 - "fdisk /dev/mapper/..." to one's desired partition structure
 - "mke2fs -j /dev/mapper/..." and mkswap "/dev/mapper/..." to build the filesystems
 - correctly configure Ubiquity (currently there's a bug: /dev/mapper/... partitions with a filesystem are listed twice)
 - "chroot /target" and "apt-get install dmraid" to the target installation

Since most of the support is already in place (grub installs nicely, for example), it would be helpful if dmraid was included in the live cd: this would remove the first and last steps from the list - which incidentally are the only ones to require an internet connection :-p

Changed in ubuntu-meta:
importance: Undecided → Wishlist
status: New → Confirmed
Kyle Jones (mutiny32) wrote :

Seconded. This should be included.

Kyle Jones (mutiny32) wrote :

Give notice.

Changed in dmraid:
assignee: nobody → ubuntu-installer
Colin Watson (cjwatson) wrote :

Kyle, don't assign bugs to the ubuntu-installer team; it spams us all by mail. We're aware of this bug and it's being worked on.

Changed in dmraid:
assignee: ubuntu-installer → nobody

My apologies, In Launchpad it looked as if the dmraid package maintainer had just seen the bug and said "yeah, this should be done" and wishlisted it. It has been open for quite some time and the only technical "bug" that seems present is a layer-8 issue.

Again, apologies for spamming everyone. But just to be the smartass I am, it DID gain some needed attention.

-Kyle

-----Original Message-----
From: Colin Watson <email address hidden>
Sent: Friday, February 13, 2009 3:52 AM
To: <email address hidden>
Subject: [Bug 212309] Re: dmraid missing from live cd

Kyle, don't assign bugs to the ubuntu-installer team; it spams us all by
mail. We're aware of this bug and it's being worked on.

** Changed in: dmraid (Ubuntu)
     Assignee: Ubuntu Installer Team (ubuntu-installer) => (unassigned)

--
dmraid missing from live cd
https://bugs.launchpad.net/bugs/212309
You received this bug notification because you are a member of ubuntu-
dmraid, which is subscribed to dmraid in ubuntu.

Phillip Susi (psusi) wrote :

Marking this as fixed since it is included at least as of 10.04.

Changed in dmraid (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers