dm-writeboost 2.2.6-1~16.04.1 ADT test failure with linux-hwe-edge 4.13.0-16.19~16.04.3

Bug #1727334 reported by Seth Forshee on 2017-10-25
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dm-writeboost (Ubuntu)
Marcelo Cerri
Nominated for Xenial by Marcelo Cerri

Bug Description


Currently the DKMS package fails to install in supported custom kernels that are based on 4.11 or 4.13. That includes the current 4.11 hwe-edge and the upcoming 4.13 hwe-edge kernels and some of the custom and cloud kernels as well.

[Test Case]

Install the DKMS package with the 4.13 hwe-edge kernel from -proposed. The package installation should proceed without any errors.

[Regression Potential]

Although new patches were added, the regression risk is very low since the new changes are conditionally compiled based on the kernel version.

Besides that the new package was tested with the following kernels in an amd64 environment:

- linux-generic 4.4
- linux-hwe 4.10
- linux-hwe-edge 4.11
- linux-hwe-edge 4.13 (from xenial-proposed)
- linux-azure 4.11
- linux-azure-edge 4.13 (which is in process of getting promoted to

[Original description]

Testing failed on:

Seth Forshee (sforshee) wrote :
tags: added: kernel-adt-failure
tags: added: kernel-adt-failure-hwe-edge-4.13
removed: kernel-adt-failure
Marcelo Cerri (mhcerri) on 2017-10-27
description: updated
Marcelo Cerri (mhcerri) on 2017-11-01
Changed in dm-writeboost (Ubuntu):
status: New → In Progress
assignee: nobody → Marcelo Cerri (mhcerri)

Hello Seth, or anyone else affected,

Accepted dm-writeboost into xenial-proposed. The package will build now and be available at in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at . Thank you in advance!

Changed in dm-writeboost (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
Changed in dm-writeboost (Ubuntu):
status: In Progress → Fix Released
Marcelo Cerri (mhcerri) on 2017-11-30
tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Brian Murray (brian-murray) wrote :

Please add some verification details.

Changed in dm-writeboost (Ubuntu Xenial):
status: Fix Committed → Incomplete
Robie Basak (racb) on 2017-12-06
tags: added: verification-done-needed verification-needed
removed: verification-done verification-done-xenial
tags: added: verification-needed-xenial
removed: verification-done-needed
Marcelo Cerri (mhcerri) wrote :

ADT tests are passing version for 2.2.6-1~16.04.2 with kernel 4.13.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Marcelo Cerri (mhcerri) wrote :

Adding more details. I also have run the ADT tests for the following kernels to ensure there's no regressions:

- linux-generic 4.4
- linux-hwe 4.10
- linux-hwe-edge 4.11
- linux-hwe-edge 4.13
- linux-azure 4.11
- linux-azure-edge 4.13

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dm-writeboost - 2.2.6-1~16.04.2

dm-writeboost (2.2.6-1~16.04.2) xenial; urgency=medium

  * Backport to xenial to support 4.11 and 4.13 kernels. (LP: #1727334)
    - 0001-ubuntu-compat-4.13.patch

 -- Marcelo Henrique Cerri <email address hidden> Fri, 27 Oct 2017 15:16:55 -0200

Changed in dm-writeboost (Ubuntu Xenial):
status: Incomplete → Fix Released

The verification of the Stable Release Update for dm-writeboost has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments