-L does not work anymore (for multiarch packages?)

Bug #1030074 reported by Norbert Kiesel on 2012-07-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dlocate (Debian)
New
Unknown
dlocate (Ubuntu)
Undecided
Unassigned

Bug Description

dlocate -L does not work for me anymore. I think it broke during the mutliarch transition. Here is what I get:
% dpkg -l liblua5.1-svn1 | grep ii
ii liblua5.1-svn1 0.4.0-4 Subversion library for the Lua language version 5.1
% strace -etrace=file dlocate -L liblua5.1-svn1 |& grep liblua
execve("/usr/bin/dlocate", ["dlocate", "-L", "liblua5.1-svn1"], [/* 41 vars */]) = 0
stat("/var/lib/dpkg/info/liblua5.1-svn1.list", 0x7fff8f49f1f0) = -1 ENOENT (No such file or directory)
Package liblua5.1-svn1 not installed or liblua5.1-svn1.list is empty.
% ls /var/lib/dpkg/info/liblua5.1-svn1*list
/var/lib/dpkg/info/liblua5.1-svn1:amd64.list
%

So the list file now contains the architecture, but dlocate does not use that. Perhaps as simple as putting a `dpkg --print-architecture` output somewhere.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: dlocate 1.02
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
Uname: Linux 3.2.0-26-generic x86_64
ApportVersion: 2.0.1-0ubuntu10
Architecture: amd64
Date: Fri Jul 27 11:08:27 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
ProcEnviron:
 TERM=gnome-256color
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: dlocate
UpgradeStatus: Upgraded to precise on 2012-03-31 (117 days ago)

Norbert Kiesel (nk-iname) wrote :
Norbert Kiesel (nk-iname) wrote :

The attachment "dlocate.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
David Henningsson (diwic) wrote :

Hi Norbert and thanks for your patch!

I have tried your patch and found a problem with it:
If I run "dlocate -L alsa-utils" before patching dlocate, I get a correct list of files.
If I run "dlocate -L alsa-utils" after patching dlocate, I get an error message:
"Package alsa-utils:amd64 not installed or alsa-utils:amd64.list is empty."

However, if I do the same for the "libasound2" package instead, I get a correct list a files *after* the patch.

So it seems your patch fixes some (multiarch?) cases, but breaks other (non-multiarch?) cases.

summary: - -L does not work anymore
+ -L does not work anymore (for multiarch packages?)
Changed in dlocate (Ubuntu):
status: New → Triaged
David Henningsson (diwic) wrote :

Also, I suspect this is the same as debian bug http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=658222 - if you like, you can post to that bug, and interact with the people there, and suggest your patch (or a modified one). It will be easier to correct the problem closer to the source, so to speak.

Changed in dlocate (Debian):
status: Unknown → New

Hey there,

I'm a Debian Developer who has done a previous NMU for dlocate and I'd be happy to do some more to fix open bugs.

If your patch is ready, I'd be happy to apply it to fix Debian #658222 and do another NMU.

Cheers,

Adrian

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.