Package does not ship dlm_stonith

Bug #1491745 reported by Rocco on 2015-09-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dlm (Ubuntu)
Medium
Unassigned

Bug Description

The dlm_stonith binary needed to get fencing working in a pacemaker/gfs2 scenario is not in the dlm package, or somewhere else in ubuntu.

Robie Basak (racb) on 2015-09-04
summary: - dlm_stonith where?
+ Package does not ship dlm_stonith
Changed in dlm (Ubuntu):
importance: Undecided → Medium
Billy Olsen (billy-olsen) wrote :

The stonith piece of dlm comes in the fence subfolder but was not included in the upstream Makefile (relying on packaging to include?). This was very recently changed in this upstream commit - https://git.fedorahosted.org/cgit/dlm.git/commit/?h=dlm-4.0.4&id=c4d060213081fcf9bd47bfc90374a2ffcefd7020. This would cause the binary piece for fencing to be compiled as part of a package build.

James Page (james-page) on 2016-03-07
Changed in dlm (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dlm - 4.0.4-3ubuntu1

---------------
dlm (4.0.4-3ubuntu1) xenial; urgency=medium

  * Resync with Debian unstable (LP: #1248054, #1491745); remaining changes:
    - d/control,dlm.install,rules: Rename dlm-controld -> dlm inline
      with packaging history in Ubuntu.

dlm (4.0.4-3) unstable; urgency=medium

  * [526167a] Add corosync dependency to dlm-controld (Closes: #814519)
  * [3c98ecb] Update Standards-Version to 3.9.7 (no changes needed)

dlm (4.0.4-2) unstable; urgency=medium

  * [a10e0c9] New patch Build-reproducibly-don-t-compile-in-the-build-time.patch
  * [dda5591] Replace obsolete libsystemd-daemon-dev B-D with libsystemd-dev
    (Closes: #813376)
  * [12b55a9] Switch to secure VCS URIs as Lintian suggests
  * [562bd20] New patch Enable-bindnow-for-libdlmcontrol.patch

dlm (4.0.4-1) unstable; urgency=medium

  * [0c99a79] Imported Upstream version 4.0.4
  * [619a537] Avoid useless libxml2 dependency of dlm-controld
  * [203aa46] debian/watch: look for tar.xz instead of tar.gz
  * [0ce96d5] Delete upstreamed patches, update the remaining one
  * [6a30ac3] Upstream udev dir is under /usr/lib since 102d3c2
  * [d655c87] Taking over dlm_{controld,tool} requires Breaks+Replaces cman
    (Closes: #812419)
  * [a7b3406] Hardening seems to work now, enable it

dlm (4.0.2-1) unstable; urgency=medium

  [ Ferenc Wágner ]
  * [eb5910d] Switch to the new DLM upstream from redhat-cluster and redo
    packaging
  * [1bdc449] Add symbols file for libdlmcontrol3
  * [ce903ed] Force building with Corosync 2 libraries
  * [f0cc3b2] Build and ship the dlm_stonith helper
  * [03ccd41] New patch Make-systemd-stop-dlm-on-corosync-restart.patch
  * [3127527] New patch If-an-error-occurs-unlink-the-lock-file-and-exit-
    wit.patch
  * [05e959e] New patch Don-t-SIGKILL-dlm_controld.patch
  * [61adabd] Ensure configfs is loaded before sys-kernel-config.mount needs it

  [ Christoph Berg ]
  * Rely on dh for -dbgsym packages instead of providing our own.
  * Add watch file.

 -- James Page <email address hidden> Tue, 08 Mar 2016 10:31:02 +0000

Changed in dlm (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers