package libdleyna-core-1.0-5 (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/libdleyna-core-1.0.so.5.0.0', which is also in package libdleyna-core-1.0-3:amd64 0.6.0-1

Bug #1862714 reported by Alex Murray on 2020-02-11
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
dleyna-core (Ubuntu)
Undecided
Unassigned

Bug Description

On doing a daily apt update && apt dist-upgrade on focal apt hit this error. Whilst apt suggest to fix using `apt install -f` this does not resolve it:

$ sudo apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libbrlapi0.6 libdleyna-core-1.0-3 libxen-4.9 libxenstore3.0
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  libdleyna-core-1.0-5
The following packages will be upgraded:
  dleyna-server
1 to upgrade, 1 to newly install, 0 to remove and 0 not to upgrade.
Need to get 67.4 kB of archives.
After this operation, 53.2 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 https://mirror.aarnet.edu.au/ubuntu focal/universe amd64 libdleyna-core-1.0-5 amd64 0.6.0-3 [13.3 kB]
Get:2 https://mirror.aarnet.edu.au/ubuntu focal/universe amd64 dleyna-server amd64 0.6.0-1build1 [54.2 kB]
Fetched 67.4 kB in 0s (169 kB/s)
Selecting previously unselected package libdleyna-core-1.0-5:amd64.
(Reading database ... 233097 files and directories currently installed.)
Preparing to unpack .../libdleyna-core-1.0-5_0.6.0-3_amd64.deb ...
Unpacking libdleyna-core-1.0-5:amd64 (0.6.0-3) ...
dpkg: error processing archive /var/cache/apt/archives/libdleyna-core-1.0-5_0.6.
0-3_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libdleyna-core-1.0.so.5.0.0', wh
ich is also in package libdleyna-core-1.0-3:amd64 0.6.0-1
Preparing to unpack .../dleyna-server_0.6.0-1build1_amd64.deb ...
Unpacking dleyna-server (0.6.0-1build1) over (0.6.0-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libdleyna-core-1.0-5_0.6.0-3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libbrlapi0.6 libdleyna-core-1.0-3 libxen-4.9 libxenstore3.0
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libdleyna-core-1.0-5
The following NEW packages will be installed:
  libdleyna-core-1.0-5
0 to upgrade, 1 to newly install, 0 to remove and 0 not to upgrade.
1 not fully installed or removed.
Need to get 0 B/13.3 kB of archives.
After this operation, 53.2 kB of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 233097 files and directories currently installed.)
Preparing to unpack .../libdleyna-core-1.0-5_0.6.0-3_amd64.deb ...
Unpacking libdleyna-core-1.0-5:amd64 (0.6.0-3) ...
dpkg: error processing archive /var/cache/apt/archives/libdleyna-core-1.0-5_0.6.0-3_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libdleyna-core-1.0.so.5.0.0', which is also in package libdleyna-core-1.0-3:amd64 0.6.0-1
Errors were encountered while processing:
 /var/cache/apt/archives/libdleyna-core-1.0-5_0.6.0-3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ sudo apt remove --purge libdleyna-core-1.0-3
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 dleyna-server : Depends: libdleyna-core-1.0-5 (>= 0.6.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: libdleyna-core-1.0-5 (not installed)
ProcVersionSignature: Ubuntu 5.4.0-12.15-generic 5.4.8
Uname: Linux 5.4.0-12-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu16
AptOrdering:
 libdleyna-core-1.0-5:amd64: Install
 dleyna-server:amd64: Install
 NULL: ConfigurePending
Architecture: amd64
Date: Tue Feb 11 13:03:53 2020
DpkgTerminalLog:
 Preparing to unpack .../libdleyna-core-1.0-5_0.6.0-3_amd64.deb ...
 Unpacking libdleyna-core-1.0-5:amd64 (0.6.0-3) ...
 dpkg: error processing archive /var/cache/apt/archives/libdleyna-core-1.0-5_0.6.0-3_amd64.deb (--unpack):
  trying to overwrite '/usr/lib/x86_64-linux-gnu/libdleyna-core-1.0.so.5.0.0', which is also in package libdleyna-core-1.0-3:amd64 0.6.0-1
ErrorMessage: trying to overwrite '/usr/lib/x86_64-linux-gnu/libdleyna-core-1.0.so.5.0.0', which is also in package libdleyna-core-1.0-3:amd64 0.6.0-1
InstallationDate: Installed on 2019-11-18 (84 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
Python3Details: /usr/bin/python3.7, Python 3.7.6, python3-minimal, 3.7.5-1ubuntu1
PythonDetails: N/A
RelatedPackageVersions:
 dpkg 1.19.7ubuntu2
 apt 1.9.9
SourcePackage: dleyna-core
Title: package libdleyna-core-1.0-5 (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/x86_64-linux-gnu/libdleyna-core-1.0.so.5.0.0', which is also in package libdleyna-core-1.0-3:amd64 0.6.0-1
UpgradeStatus: Upgraded to focal on 2020-01-22 (19 days ago)

Alex Murray (alexmurray) wrote :
description: updated
Alex Murray (alexmurray) wrote :

Fixed it for now by doing:

sudo apt purge dleyna-server libdleyna-core-1.0-3 libdleyna-core-1.0-5
sudo apt install dleyna-server

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dleyna-core (Ubuntu):
status: New → Confirmed
xenoxz (simonsoelberg) wrote :

Same bug experienced here.
Fix described above solved the problem.

Jamie Strandboge (jdstrand) wrote :

Fyi, I worked around it with:

$ sudo dpkg --purge --force-depends libdleyna-core-1.0-3
$ sudo apt-get -f install

Luis Joaquim (luispjoaquim) wrote :

#5 worked for me

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dleyna-core - 0.6.0-4

---------------
dleyna-core (0.6.0-4) unstable; urgency=medium

  * QA upload.
  * Breaks+Replaces: libdleyna-core-1.0-3 (>= 0.6.0)
    (Closes: #951204) (LP: #1862714, #1862757, #1862782)
  * Set Rules-Requires-Root: no.
  * Bump Standards-Version to 4.5.0.

 -- Andreas Beckmann <email address hidden> Fri, 13 Mar 2020 00:32:08 +0100

Changed in dleyna-core (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers