Packages requiring dkms at Pandaboard (omap 4) will also pull linux-headers-generic because current dkms dependencies

Bug #960770 reported by Ricardo Salveti
50
This bug affects 5 people
Affects Status Importance Assigned to Milestone
dkms (Ubuntu)
Medium
Adam Conrad
Precise
Undecided
Timo Aaltonen
Quantal
Undecided
Adam Conrad
linux-meta (Ubuntu)
Undecided
Andy Whitcroft
Precise
Undecided
Andy Whitcroft
Quantal
Undecided
Unassigned
linux-meta-ac100 (Ubuntu)
Undecided
Adam Conrad
Quantal
Undecided
Adam Conrad
linux-meta-armadaxp (Ubuntu)
Undecided
Andy Whitcroft
Quantal
Undecided
Adam Conrad
linux-meta-lowlatency (Ubuntu)
Undecided
Andy Whitcroft
Quantal
Undecided
Adam Conrad
linux-meta-nexus7 (Ubuntu)
Undecided
Adam Conrad
Quantal
Undecided
Unassigned
linux-meta-ti-omap4 (Ubuntu)
Undecided
Adam Conrad
Precise
Undecided
Andy Whitcroft
Quantal
Undecided
Adam Conrad

Bug Description

[SRU Justification]
DKMS is pulling in incorrect headers on some images/installs, plus this fix backports the removal of the 'linux-image' dep that was pulling in linux-image on various media, despite precise.2 wanting linux-image-lts-quantal.

This should be fixed by dropping the dkms dependency on headers, and making linux-flavour depend on the correct headers, as it does in Q and R.

[Test Case for DKMS]
Testcase is twofold:
1) verify that the binary packages no longer have deps on any linux-headers or linux-image packages.
2) verify that the latest precise daily builds no longer incorrectly carry 3.2.0 kernels on x86

[Test case for linux-meta-*]
Make sure linux-$(flavour) now depends on linux-image-flavour *and* linux-headers-flavour, rather than just linux-image.

[Regression potential]
Low, this dependency was pretty much always broken, and it was merely a fluke that it was handled correctly elsewhere and mostly a non-issue on x86 installs.

[Original Report]
The PowerVR SGX kernel module package for Pandaboard depends on linux-headers-omap4 (headers package for the Omap 4 based kernel) and DKMS, but when installing the package DKMS will also pull linux-headers-generic, forcing the module build to happen with both kernel headers package, besides wasting quite a few extra megabytes.

PPA with the current PVR SGX driver: https://launchpad.net/~rsalveti/+archive/pvr-sgx/

Changed in dkms (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Revision history for this message
Ricardo Salveti (rsalveti) wrote :

Actually I'm not yet sure if the fix should be applied at dkms by making it depend on linux-headers-omap4, or if the linux-headers-3.2.0-1409-omap4 kernel package should also provide linux-headers.

Currently the OMAP 4 kernel is providing linux-ti-omap4-headers and linux-ti-omap4-headers-2.6, but for me it'd also make sense to provide linux-headers, as this is the main kernel headers package used by the system (at Pandaboard).

Changed in dkms (Ubuntu):
status: Confirmed → New
Revision history for this message
Ricardo Salveti (rsalveti) wrote :

Paolo, do you think it'd make sense to change the kernel headers package to also provide linux-headers?

Revision history for this message
Ricardo Salveti (rsalveti) wrote :

Marking dkms related bug as invalid as Paolo is fixing this at the omap4 kernel itself.

Changed in dkms (Ubuntu):
status: New → Invalid
Changed in linux-ti-omap4 (Ubuntu):
importance: Undecided → Medium
Paolo Pisati (p-pisati)
Changed in dkms (Ubuntu):
status: Invalid → New
Changed in linux-ti-omap4 (Ubuntu):
status: New → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dkms (Ubuntu):
status: New → Confirmed
Revision history for this message
Ricardo Salveti (rsalveti) wrote :

We had a discussion about where would be the proper fix for this issue at https://lists.ubuntu.com/archives/kernel-team/2012-March/019502.html, and the conclusion was basically to remove the linux-headers from dkms recommends list:

Recommends: fakeroot,
 menu | sudo,
 linux-headers-generic-pae | linux-headers-686-pae | linux-headers-amd64 | linux-headers-generic | linux-headers,
 linux-image

The dkms driver should by default depend on the kernel already, so there's indeed no need to have them as recommends.

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/960770

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.2.0.3-1.1ubuntu2

---------------
dkms (2.2.0.3-1.1ubuntu2) raring; urgency=low

  * Don't Recommend any linux-headers packages, our installers
    all install headers matching your kernel anyway, and this
    dependency causes more problems than it solves (LP: #960770)
 -- Adam Conrad <email address hidden> Wed, 31 Oct 2012 11:28:52 +0000

Changed in dkms (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Marty Vona (vona) wrote :

As of 12/11/12, this seems to still be happening with a fresh install of precise.

1) flash ubuntu-12.04-preinstalled-desktop-armhf+omap4.img
2) boot pandaboard, run os configuration
3) sudo apt-get dist-upgrade
4) sudo apt-add-repository ppa:tiomap-dev/release
5) sudo apt-get install ubuntu-omap4-extras
6) boom, pvr-omap4-dkms fails to build

In addition, after this

(a) the dpkg database behaves strangely for a while, seems to be locked when I didn't expect anything to be using it; may be becuase the gui "your system has had an error" bugreporter thing kicks in and takes a *long* time to do its thing

(b) booting the new kernel is very unstable, on one attempt it was hanging reliably at boot with something like"kernel BUG linux-ti-omap4-3.4.0 page_alloc.c". On one try (it takes about 2h for each attempted install) I tried removing linux-headers-3.2.0-*-omap as Ricardo suggested in bug 1033091 and then reinstalling pvr-omap4-dkms; then I got it to boot further but system was still unstable, kernel crashing with other mm looking error messages. I just found http://askubuntu.com/questions/201981/pandaboard-crash-on-startup-or-freeze-after-minutes which basically suggests mem=1G@0x80000000 and u-boot-linaro-omap4-panda, maybe will try that.

Timo Aaltonen (tjaalton)
Changed in linux-ti-omap4 (Ubuntu Precise):
status: New → Invalid
Changed in dkms (Ubuntu Precise):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → In Progress
Revision history for this message
Adam Conrad (adconrad) wrote : Please test proposed package

Hello Ricardo, or anyone else affected,

Accepted dkms into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/dkms/2.2.0.3-1ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in dkms (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad)
no longer affects: linux-ti-omap4 (Ubuntu)
no longer affects: linux-ti-omap4 (Ubuntu Precise)
Adam Conrad (adconrad)
Changed in linux-meta-nexus7 (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
status: New → Fix Released
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Precise):
status: New → Confirmed
Changed in linux (Ubuntu):
status: New → Confirmed
Brad Figg (brad-figg)
affects: linux-meta (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Adam Conrad (adconrad) wrote :

Note that due a launchpad bug, some of the packages above don't have precise tasks, but this is indeed where all the fixes are landing. quantal and raring were already fixed a while ago.

affects: linux (Ubuntu) → linux-meta (Ubuntu)
Changed in linux-meta (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Confirmed → Fix Released
Changed in linux-meta (Ubuntu Precise):
assignee: nobody → Andy Whitcroft (apw)
status: Confirmed → Fix Committed
Changed in linux-meta-armadaxp (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: New → Fix Committed
Changed in linux-meta-lowlatency (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: New → Fix Committed
Changed in linux-meta-ti-omap4 (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
status: New → Fix Released
Changed in linux-meta-ti-omap4 (Ubuntu Precise):
assignee: nobody → Andy Whitcroft (apw)
status: New → Fix Committed
Changed in dkms (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
Adam Conrad (adconrad)
Changed in linux-meta-ac100 (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
status: New → In Progress
Revision history for this message
Colin Watson (cjwatson) wrote :

Hello Ricardo, or anyone else affected,

Accepted linux-meta-ac100 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/linux-meta-ac100/3.0.27.1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Colin Watson (cjwatson) wrote :

Hello Ricardo, or anyone else affected,

Accepted linux-meta-ac100 into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/linux-meta-ac100/3.1.10.6.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Colin Watson (cjwatson)
Changed in linux-meta-ac100 (Ubuntu Quantal):
assignee: nobody → Adam Conrad (adconrad)
status: New → Fix Committed
Adam Conrad (adconrad)
Changed in linux-meta-nexus7 (Ubuntu Quantal):
status: New → Invalid
Changed in linux-meta-armadaxp (Ubuntu Quantal):
assignee: nobody → Adam Conrad (adconrad)
status: New → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Ricardo, or anyone else affected,

Accepted linux-meta-lowlatency into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/linux-meta-lowlatency/3.2.0.36.25 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Adam Conrad (adconrad) wrote :

Verified all the linux-meta headers changes in precise:
linux-ac100_3.0.27.1.2_armel.deb:
 Depends: linux-image-ac100 (= 3.0.27.1.2), linux-headers-ac100 (= 3.0.27.1.2)
linux-ac100_3.0.27.1.2_armhf.deb:
 Depends: linux-image-ac100 (= 3.0.27.1.2), linux-headers-ac100 (= 3.0.27.1.2)
linux-armadaxp_3.2.0.1613.19_armhf.deb:
 Depends: linux-image-armadaxp (= 3.2.0.1613.19), linux-headers-armadaxp (= 3.2.0.1613.19)
linux-generic_3.2.0.36.43_amd64.deb:
 Depends: linux-image-generic (= 3.2.0.36.43), linux-headers-generic (= 3.2.0.36.43)
linux-generic_3.2.0.36.43_i386.deb:
 Depends: linux-image-generic (= 3.2.0.36.43), linux-headers-generic (= 3.2.0.36.43)
linux-generic-pae_3.2.0.36.43_i386.deb:
 Depends: linux-image-generic-pae (= 3.2.0.36.43), linux-headers-generic-pae (= 3.2.0.36.43)
linux-highbank_3.2.0.36.43_armhf.deb:
 Depends: linux-image-highbank (= 3.2.0.36.43), linux-headers-highbank (= 3.2.0.36.43)
linux-hwe-generic_3.2.0.36.43_amd64.deb:
 Depends: linux-image-hwe-generic, linux-headers-generic
linux-hwe-generic_3.2.0.36.43_i386.deb:
 Depends: linux-image-hwe-generic, linux-headers-generic-pae
linux-lowlatency_3.2.0.36.25_amd64.deb:
 Depends: linux-image-lowlatency (= 3.2.0.36.25), linux-headers-lowlatency (= 3.2.0.36.25)
linux-lowlatency_3.2.0.36.25_i386.deb:
 Depends: linux-image-lowlatency (= 3.2.0.36.25), linux-headers-lowlatency (= 3.2.0.36.25)
linux-lowlatency-pae_3.2.0.36.25_i386.deb:
 Depends: linux-image-lowlatency-pae (= 3.2.0.36.25), linux-headers-lowlatency-pae (= 3.2.0.36.25)
linux-omap_3.2.0.36.43_armel.deb:
 Depends: linux-image-omap (= 3.2.0.36.43), linux-headers-omap (= 3.2.0.36.43)
linux-omap_3.2.0.36.43_armhf.deb:
 Depends: linux-image-omap (= 3.2.0.36.43), linux-headers-omap (= 3.2.0.36.43)
linux-omap4_3.2.0.1424.25_armel.deb:
 Depends: linux-image-omap4 (= 3.2.0.1424.25), linux-headers-omap4 (= 3.2.0.1424.25)
linux-omap4_3.2.0.1424.25_armhf.deb:
 Depends: linux-image-omap4 (= 3.2.0.1424.25), linux-headers-omap4 (= 3.2.0.1424.25)
linux-powerpc_3.2.0.36.43_powerpc.deb:
 Depends: linux-powerpc-smp (= 3.2.0.36.43)
linux-powerpc64-smp_3.2.0.36.43_powerpc.deb:
 Depends: linux-image-powerpc64-smp (= 3.2.0.36.43), linux-headers-powerpc64-smp (= 3.2.0.36.43)
linux-powerpc-smp_3.2.0.36.43_powerpc.deb:
 Depends: linux-image-powerpc-smp (= 3.2.0.36.43), linux-headers-powerpc-smp (= 3.2.0.36.43)
linux-server_3.2.0.36.43_amd64.deb:
 Depends: linux-image-server (= 3.2.0.36.43), linux-headers-server (= 3.2.0.36.43)
linux-server_3.2.0.36.43_i386.deb:
 Depends: linux-generic-pae
linux-virtual_3.2.0.36.43_amd64.deb:
 Depends: linux-image-virtual (= 3.2.0.36.43), linux-headers-virtual (= 3.2.0.36.43)
linux-virtual_3.2.0.36.43_i386.deb:
 Depends: linux-image-virtual (= 3.2.0.36.43), linux-headers-virtual (= 3.2.0.36.43)

Adam Conrad (adconrad)
Changed in linux-meta (Ubuntu Quantal):
status: New → Fix Released
Changed in linux-meta-ti-omap4 (Ubuntu Quantal):
assignee: nobody → Adam Conrad (adconrad)
status: New → Fix Released
Adam Conrad (adconrad)
Changed in linux-meta-lowlatency (Ubuntu Quantal):
assignee: nobody → Adam Conrad (adconrad)
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta-ac100 - 3.0.27.1.2

---------------
linux-meta-ac100 (3.0.27.1.2) precise; urgency=low

  * Change sections to devel/kernel to match the archive (LP: #1074787)
  * Update linux-ac100 to depend on linux-headers-ac100 (LP: #960770)
 -- Adam Conrad <email address hidden> Tue, 15 Jan 2013 00:22:38 -0700

Changed in linux-meta-ac100 (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta-armadaxp - 3.2.0.1613.19

---------------
linux-meta-armadaxp (3.2.0.1613.19) precise; urgency=low

  * Add linux-headers-<flavour> to linux-<flavour> to retain headers
    for dkms et al. (LP: #960770)
 -- Andy Whitcroft <email address hidden> Mon, 14 Jan 2013 21:05:49 +0000

Changed in linux-meta-armadaxp (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta-ti-omap4 - 3.2.0.1424.25

---------------
linux-meta-ti-omap4 (3.2.0.1424.25) precise-proposed; urgency=low

  * Add linux-headers-<flavour> to linux-<flavour> to retain headers
    for dkms et al. (LP: #960770)

linux-meta-ti-omap4 (3.2.0.1424.24) precise-proposed; urgency=low

  * linux-ti-omap4 ABI 3.2.0-1424
 -- Andy Whitcroft <email address hidden> Mon, 14 Jan 2013 20:21:08 +0000

Changed in linux-meta-ti-omap4 (Ubuntu Precise):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta - 3.2.0.36.43

---------------
linux-meta (3.2.0.36.43) precise-proposed; urgency=low

  * Add linux-headers-<flavour> to linux-<flavour> to retain headers
    for dkms et al. (LP: #960770)

linux-meta (3.2.0.36.42) precise-proposed; urgency=low

  [ Brad Figg ]

  * Bump ABI

linux-meta (3.2.0.35.41) precise-proposed; urgency=low

  [ Brad Figg ]

  * Bump ABI
 -- Andy Whitcroft <email address hidden> Mon, 14 Jan 2013 19:45:34 +0000

Changed in linux-meta (Ubuntu Precise):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta-ac100 - 3.1.10.6.2

---------------
linux-meta-ac100 (3.1.10.6.2) quantal; urgency=low

  * Change sections to devel/kernel to match the archive (LP: #1074787)
  * Update linux-ac100 to depend on linux-headers-ac100 (LP: #960770)
 -- Adam Conrad <email address hidden> Thu, 20 Dec 2012 21:30:36 -0700

Changed in linux-meta-ac100 (Ubuntu Quantal):
status: Fix Committed → Fix Released
Adam Conrad (adconrad)
Changed in linux-meta-lowlatency (Ubuntu Quantal):
status: In Progress → Fix Committed
Adam Conrad (adconrad)
Changed in dkms (Ubuntu Quantal):
assignee: nobody → Adam Conrad (adconrad)
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta-lowlatency - 3.2.0.36.26

---------------
linux-meta-lowlatency (3.2.0.36.26) precise; urgency=low

  * Change sections to devel/kernel to match the archive (LP: #1074787)
 -- Adam Conrad <email address hidden> Thu, 17 Jan 2013 14:09:04 -0700

Changed in linux-meta-lowlatency (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-meta-lowlatency - 3.5.0.22.21

---------------
linux-meta-lowlatency (3.5.0.22.21) quantal; urgency=low

  * Change sections to devel/kernel to match the archive (LP: #1074787)
  * Update linux-flavor to depend on linux-headers-flavor (LP: #960770)
 -- Adam Conrad <email address hidden> Thu, 17 Jan 2013 14:03:09 -0700

Changed in linux-meta-lowlatency (Ubuntu Quantal):
status: Fix Committed → Fix Released
Revision history for this message
Adam Conrad (adconrad) wrote :

Verified that, in both quantal and precise, dkms no longer recommends linux-headers or linux-image, and thus doesn't independently pull them in.

Changed in dkms (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-done
removed: verification-needed
Revision history for this message
Chris Halse Rogers (raof) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.2.0.3-1ubuntu3.1

---------------
dkms (2.2.0.3-1ubuntu3.1) precise-proposed; urgency=low

  * Don't Recommend any linux-headers packages, our installers
    all install headers matching your kernel anyway, and this
    dependency causes more problems than it solves (LP: #960770)
 -- Timo Aaltonen <email address hidden> Thu, 10 Jan 2013 13:11:20 +0200

Changed in dkms (Ubuntu Precise):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.2.0.3-1.1ubuntu1.1

---------------
dkms (2.2.0.3-1.1ubuntu1.1) quantal; urgency=low

  * Don't Recommend any linux-headers packages, our installers
    all install headers matching your kernel anyway, and this
    dependency causes more problems than it solves (LP: #960770)
 -- Adam Conrad <email address hidden> Thu, 17 Jan 2013 16:27:13 -0700

Changed in dkms (Ubuntu Quantal):
status: Fix Committed → Fix Released
Revision history for this message
V字龍(Vdragon) (vdragon) wrote :

Hi,
the fix of this bug caused another bug here
  Bug #1174010 “[packaging]virtualbox-guest-dkms(or dkms) should d...” : Bugs : “virtualbox” package : Ubuntu
  https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1174010
please check out.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers