apport hook should identify duplicates

Bug #766160 reported by Felix Geyer on 2011-04-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dkms (Ubuntu)
Medium
Brian Murray

Bug Description

Binary package hint: dkms

The apport hook should detect duplicate build failures by setting the DuplicateSignature variable:
http://www.piware.de/2011/03/new-apport-feature-custom-bug-duplicate-identification/

To do that dkms needs to run the build with LC_ALL=C and strip the date from the build log.

Related branches

tags: added: apport-hook
Changed in dkms (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Mario Limonciello (superm1) wrote :

I'm not crazy about running the build with LC_ALL=C in case there is a problem and the person wants to investigate in their native language. Are there a lot of cases that DKMS bugs aren't getting duplicated correctly for individual packages? Would just stripping the build date help here?

Brian Murray (brian-murray) wrote :

I've modified the apport package hook to create a duplicate signature using the DKMS build log and stripping out the date line. Additionally, when looking at some apport-package bug reports a noticed a couple like bug 829815 and bug 799297 where the module failed to build due to a segmentation fault. It seems to me that these reports aren't really useful as apport-package reports and would be better filed a different way, subsequently I've blocked them in the dkms package hook.

Changed in dkms (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.2.0.2-1ubuntu1

---------------
dkms (2.2.0.2-1ubuntu1) oneiric; urgency=low

  [ Brian Murray]
  * Add a duplicate signature to the apport hook, so that reports caused by
    a common failure can more easily be identified as duplicates.
    LP: #766160.
 -- Steve Langasek <email address hidden> Thu, 01 Sep 2011 10:37:41 -0700

Changed in dkms (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers