ability to install dkms without version checking and retire it when kernel fixed issue

Bug #1838921 reported by Alex Tu on 2019-08-05
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Alex Tu
dkms (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

refer to https://github.com/dell/dkms/pull/98

[Impact]
to have a way for this case
"user need to force install the dkms, but also would like to retire that dkms once kernel fixes the issue."
 - upstream patch : https://github.com/dell/dkms/pull/98

[Test case]
1. install the dkms package which already patched
2. install a DKMS which has file content "{dkms name}_version-override" under /usr/share/dkms/modules_to_force_install/
   - the installation should ignore module version checking.

3. update that installed DKMS to a new one which added OBSOLETE_BY in dkms.conf
   - on the kernel which version lower than OBSOLETE_BY, the dkms should be installed.
   - on the kernel which version higher than OBSOLETE_BY, the dkms should NOT be installed.

[Regression potential]
medium as it touched the version sanity. This change already there in upstream.

Alex Tu (alextu) on 2019-08-05
Changed in oem-priority:
assignee: nobody → Alex Tu (alextu)
importance: Undecided → High
Alex Tu (alextu) wrote :

a test result here for reference:
in my system there're 2 kernels 4.15.0-1030 and 4.15.0-1045

1. installed dkms from [1], which included the proposed patch.
2. install dkms from [2], which set OBSOLETE_BY="4.15.0-1033" , and set 'FORCE' already.

from the attached message during installation,
 - for kernel 4.15.0-1030: line 4604 checked srcversion, but still install dkms because of 'FORCE' be set
 - for kernel 4.15.0-1045: line 9419 checked obsolete value, then stop install dkms.

[1]:https://code.launchpad.net/~alextu/+recipe/2.3-3ubuntu9.5-closes89
[2]:https://code.launchpad.net/~alextu/+recipe/2.3-3ubuntu9.5-closes89-dkms

Timo Aaltonen (tjaalton) wrote :

can you just attach debdiffs for dkms?

for instance the git repo for eoan is for oem-backlight-dell-dell-uart-backlight-lp1811346-4.15-dkms...

Alex Tu (alextu) wrote :

per talked on IRC, to avoid confusing I renamed the branch for DKMS package, and bump the package version as well. And also confirmed with the sponsor that git repository is enough, so I list them below. Please ping me if any other need for SRU, I'll response ASAP.

# based on bionic:
https://code.launchpad.net/~alextu/+git/dkms-2.3-lp1838245/+ref/bionic-dkms-2.3-closes89

# based on disco:
https://code.launchpad.net/~alextu/+git/dkms-2.3-lp1838245/+ref/disco-dkms-2.6.1-closes89

# based on eoan:
https://code.launchpad.net/~alextu/+git/dkms-2.3-lp1838245/+ref/eoan-dkms-2.7.1-closes89

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.7.1-2ubuntu2

---------------
dkms (2.7.1-2ubuntu2) eoan; urgency=medium

  * dkms: cherry-pick from upstream a35d981 for issue #89
    0019-fix-OBSOLETE_BY-be-blocked-by-force-Closes-89.patch (LP: #1838921)

 -- Timo Aaltonen <email address hidden> Mon, 02 Sep 2019 17:28:28 +0300

Changed in dkms (Ubuntu):
status: New → Fix Released

Hello Alex, or anyone else affected,

Accepted dkms into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/dkms/2.6.1-4ubuntu2.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in dkms (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed verification-needed-disco
Changed in dkms (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello Alex, or anyone else affected,

Accepted dkms into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/dkms/2.3-3ubuntu9.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

All autopkgtests for the newly accepted dkms (2.6.1-4ubuntu2.3) for disco have finished running.
The following regressions have been reported in tests triggered by the package:

dahdi-linux/unknown (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/disco/update_excuses.html#dkms

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Hi Łukasz,

from the regression of autopkgtests in #10, it seems the connection of test environment is not stable so it got "connection timed out".

Could you please re-trigger the autopkgtest again?

All autopkgtests for the newly accepted dkms (2.3-3ubuntu9.6) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

nvidia-graphics-drivers-430/430.26-0ubuntu0.18.04.2 (amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#dkms

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Not really understand that why the regression happen in #12 but not in #10.
And I also check installing nvidia-dkms-430 with proposed dkms and it looks works well.

installation:
- https://paste.ubuntu.com/p/4wtRyswGvK/

dpkg -l | grep "nvidia\|dkms":
- http://paste.ubuntu.com/p/NMHNr9cWx8/

So, I believe both #10 and #12 is miss alarm.

Alex Tu (alextu) wrote :

marked this verification as failed, because we get better solution to reach the target by https://github.com/dell/dkms/pull/98

I'll change this bug title and content to match the new patch.

tags: added: verification-failed-bionic verification-failed-disco
removed: verification-needed-bionic verification-needed-disco
summary: - priority of OBSOLETE_BY should higher than "force"
+ ability to install dkms without version checking and retire it when
+ kernel fixed issue
description: updated
Alex Tu (alextu) wrote :

the patch for eoan is ready , please refer to https://code.launchpad.net/~alextu/+git/dkms/+ref/2.7.1-rc

there're 2 patches:

b3c98e6
bump version

7c72a48
cherry-pick feature for force version override feature.
new file: 0019-add-force-version-override-and-dkms-_version-overrid.patch
deleted: 0019-fix-OBSOLETE_BY-be-blocked-by-force-Closes-89.patch
modified: series

Timo Aaltonen (tjaalton) wrote :

reopening for eoan, the new version is uploaded

Changed in dkms (Ubuntu):
status: Fix Released → In Progress
Alex Tu (alextu) on 2019-10-07
Changed in oem-priority:
importance: High → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.7.1-4ubuntu2

---------------
dkms (2.7.1-4ubuntu2) eoan; urgency=medium

  * revert 0019-fix-OBSOLETE_BY-be-blocked-by-force-Closes-89.patch
  * cherry-pick from upstream 9bbef17 for issue #89 #42
    - 0019-add-force-version-override-and-dkms-_version-overrid.patch
    (LP: #1838921)

 -- Alex Tu <email address hidden> Thu, 03 Oct 2019 17:38:12 +0800

Changed in dkms (Ubuntu):
status: In Progress → Fix Released
Alex Tu (alextu) wrote :

the patch for disco SRU is ready on https://code.launchpad.net/~alextu/+git/dkms/+ref/ubuntu/disco-devel

there're 3 patches:

96f8e8d bump version

7cfafe3 add --force-version-override and {dkms}_version-override option

8945992 revert 0019-fix-OBSOLETE_BY-be-blocked-by-force-Closes-89.patch

Alex Tu (alextu) wrote :

the patch for bionic SRU is ready on https://code.launchpad.net/~alextu/+git/dkms/+ref/ubuntu/bionic-devel

there're 3 patches:

61c339f bump version

2f8363a add --force-version-override and {dkms}_version-override option

d2c914f revert 0019-fix-OBSOLETE_BY-be-blocked-by-force-Closes-89.patch

All autopkgtests for the newly accepted dkms (2.3-3ubuntu9.6) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

nvidia-graphics-drivers-430/430.26-0ubuntu0.18.04.2 (amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#dkms

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Alex Tu (alextu) wrote :

I verifed dkms 2.3-3ubuntu9.7 (uploaded by #20) on bionic from the proposed archive.
both force, obselect_by, and override_version works as expected.

Alex Tu (alextu) wrote :

btw, the auto dpkgtrest in #21 is a miss-alarm, installing nvidia-driver-430 with propose archive enabled is a known issue that tseliot is taking care of it.

https://paste.ubuntu.com/p/XKnwjVNdRf/

http://i.imgur.com/ozMINW8.png

Alex Tu (alextu) wrote :

I verifed dkms 2.6.1-4ubuntu2.4 (uploaded by #19) on bionic from the proposed archive.
both force, obsoleted_by, and override_version works as expected.

Alex Tu (alextu) wrote :
tags: added: verification-done-bionic verification-done-disco
removed: verification-failed-bionic verification-failed-disco
Timo Aaltonen (tjaalton) on 2019-10-21
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.6.1-4ubuntu2.4

---------------
dkms (2.6.1-4ubuntu2.4) disco; urgency=medium

  * revert 0019-fix-OBSOLETE_BY-be-blocked-by-force-Closes-89.patch
  * cherry-pick from upstream 9bbef17 for issue #89 #42
    - 0019-add-force-version-override-and-dkms-_version-overrid.patch

 -- Alex Tu <email address hidden> Mon, 14 Oct 2019 18:38:32 +0800

Changed in dkms (Ubuntu Disco):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.3-3ubuntu9.7

---------------
dkms (2.3-3ubuntu9.7) bionic; urgency=medium

  * revert 0019-fix-OBSOLETE_BY-be-blocked-by-force-Closes-89.patch
  * cherry-pick from upstream 9bbef17 for issue #89 #42
    - 0019-add-force-version-override-and-dkms-_version-overrid.patch

 -- Alex Tu <email address hidden> Mon, 14 Oct 2019 17:50:50 +0800

Changed in dkms (Ubuntu Bionic):
status: Fix Committed → Fix Released
Rex Tsai (chihchun) on 2019-10-31
Changed in oem-priority:
status: New → Fix Released
To post a comment you must log in.