sed: -e expression #1, char 6: unknown command: `m'

Bug #1358373 reported by Nicholas Skaggs on 2014-08-18
112
This bug affects 22 people
Affects Status Importance Assigned to Milestone
dkms (Debian)
Fix Released
Unknown
dkms (Ubuntu)
Medium
Unassigned
Trusty
Medium
Chris J Arges
Utopic
Medium
Chris J Arges

Bug Description

Initial dkms setup triggers a sed error, sed: -e expression #1, char 6: unknown command: `m'. This error does not appear to affect the setup and it completes. See the log below:

----------

sudo apt-get install virtualbox-dkms
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  virtualbox-dkms
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/556 kB of archives.
After this operation, 4,494 kB of additional disk space will be used.
Selecting previously unselected package virtualbox-dkms.
(Reading database ... 321942 files and directories currently installed.)
Preparing to unpack .../virtualbox-dkms_4.3.14-dfsg-1_all.deb ...
Unpacking virtualbox-dkms (4.3.14-dfsg-1) ...
Setting up virtualbox-dkms (4.3.14-dfsg-1) ...
Loading new virtualbox-4.3.14 DKMS files...
First Installation: checking all kernels...
Building for 3.16.0-7-generic and 3.16.0-9-generic
Building initial module for 3.16.0-7-generic
Done.

vboxdrv:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.16.0-7-generic/updates/dkms/

vboxnetadp.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.16.0-7-generic/updates/dkms/

vboxnetflt.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.16.0-7-generic/updates/dkms/

vboxpci.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.16.0-7-generic/updates/dkms/

sed: -e expression #1, char 6: unknown command: `m'
depmod....

DKMS: install completed.
Building initial module for 3.16.0-9-generic
Done.

vboxdrv:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.16.0-9-generic/updates/dkms/

vboxnetadp.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.16.0-9-generic/updates/dkms/

vboxnetflt.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.16.0-9-generic/updates/dkms/

vboxpci.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.16.0-9-generic/updates/dkms/

sed: -e expression #1, char 6: unknown command: `m'
depmod....

DKMS: install completed.
 * Stopping VirtualBox kernel modules [ OK ]
 * Starting VirtualBox kernel modules [ OK ]

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: virtualbox-dkms 4.3.14-dfsg-1
ProcVersionSignature: Ubuntu 3.16.0-7.12-generic 3.16.0
Uname: Linux 3.16.0-7-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.14.6-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Aug 18 11:51:26 2014
InstallationDate: Installed on 2013-12-19 (241 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131218)
PackageArchitecture: all
SourcePackage: virtualbox
SystemImageInfo: Error: [Errno 2] No such file or directory: 'system-image-cli'
UpgradeStatus: Upgraded to utopic on 2014-05-09 (100 days ago)

Nicholas Skaggs (nskaggs) wrote :
Vlad Orlov (monsta) on 2014-08-29
affects: virtualbox (Ubuntu) → dkms (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dkms (Ubuntu):
status: New → Confirmed
Changed in dkms (Debian):
status: Unknown → New
dino99 (9d9) wrote :

Get that error each time dkms is used: installing virtualbox or/and nvidia-340

tags: added: i386
Changed in dkms (Debian):
status: New → Fix Released
dino99 (9d9) wrote :

As the Debian package is now fixed, can we have it landing into the Ubuntu archive before the coming Utopic final release?

Changed in dkms (Ubuntu):
importance: Undecided → Medium
dino99 (9d9) wrote :

Has been fixed in Vivid, and might be backported in Utopic

Michael (mi9hael) wrote :

Please backport

Bruno Borges (bruno-borges) wrote :

This is an urgent bug to be backported to 14.10.

Can't work on VirtualBox at all, without this fixed.

Dylan Justice (dsjstc) wrote :

Absolutely urgent priority, I do a significant fraction of my work in Virtualbox, and I can no longer install any version of it on Utopic.

Dylan Justice (dsjstc) wrote :

I was able to get my failed Virtualbox-4.3.20 to complete its install by downloading and manually installing dkms from Vivid. Your results may vary.

Chris Kankiewicz (phlak) wrote :

I am also experiencing this issue with Virtualbox in Utopic. Would really like to see the fix backported.

Chris J Arges (arges) wrote :

Uploaded fixes for Utopic/Trusty. Once they are accepted into -proposed please test them to see if they fix the issue.
Thanks!

Changed in dkms (Ubuntu Trusty):
status: New → In Progress
Changed in dkms (Ubuntu Utopic):
status: New → In Progress
Changed in dkms (Ubuntu Trusty):
importance: Undecided → Medium
Changed in dkms (Ubuntu Utopic):
importance: Undecided → Medium
Changed in dkms (Ubuntu Trusty):
assignee: nobody → Chris J Arges (arges)
Changed in dkms (Ubuntu Utopic):
assignee: nobody → Chris J Arges (arges)

Hello Nicholas, or anyone else affected,

Accepted dkms into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/dkms/2.2.0.3-1.1ubuntu5.14.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in dkms (Ubuntu Utopic):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in dkms (Ubuntu Trusty):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Nicholas, or anyone else affected,

Accepted dkms into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/dkms/2.2.0.3-1.1ubuntu5.14.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Chris Kankiewicz (phlak) wrote :

Installed dkms 2.2.0.3-1.1ubuntu5.14.10 from utopic-proposed, ran 'sudo service vboxdrv setup' successfully.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.2.0.3-1.1ubuntu5.14.04

---------------
dkms (2.2.0.3-1.1ubuntu5.14.04) trusty; urgency=medium

  * fixed_sed_without_options_issue.patch: Backport of patch to fix sed issues.
    (LP: #1358373)
 -- Chris J Arges <email address hidden> Mon, 01 Dec 2014 16:53:16 -0600

Changed in dkms (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for dkms has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dkms - 2.2.0.3-1.1ubuntu5.14.10

---------------
dkms (2.2.0.3-1.1ubuntu5.14.10) utopic; urgency=medium

  * fixed_sed_without_options_issue.patch: Backport of patch to fix sed issues.
    (LP: #1358373)
 -- Chris J Arges <email address hidden> Mon, 01 Dec 2014 16:53:16 -0600

Changed in dkms (Ubuntu Utopic):
status: Fix Committed → Fix Released
Adam Conrad (adconrad) on 2014-12-09
Changed in dkms (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.