Ubuntu

Sync djvulibre 3.5.24-7 (main) from Debian unstable (main)

Reported by Fabrice Coutadeur on 2011-06-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
djvulibre (Ubuntu)
Wishlist
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/djvulibre
 status new
 importance wishlist
 subscribe ubuntu-sponsors
 done

Please sync djvulibre 3.5.24-7 (main) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
- - .la file is not shipped anymore, so it does not need fix
- - the mov instruction in libdjvu/GThreads.cpp is not there anymore
This package will also fix LP: #765937 (FTBFS in oneiric)
soname is not bumped, so no transition is required

Changelog entries since current oneiric version 3.5.23-3ubuntu2:

djvulibre (3.5.24-7) unstable; urgency=low

  * upstream fix to page extraction bug (closes: #629941)

 -- Barak A. Pearlmutter <email address hidden> Thu, 09 Jun 2011 23:06:30 +0100

djvulibre (3.5.24-6) unstable; urgency=low

  * upstream GCC 4.6 fixes
  * upstream MMX fix addresses 32-bit MMX issue (closes: #629235)

 -- Barak A. Pearlmutter <email address hidden> Sun, 05 Jun 2011 08:08:01 +0100

djvulibre (3.5.24-5) unstable; urgency=low

  * fix kbsd pthreads linkage more gently

 -- Barak A. Pearlmutter <email address hidden> Thu, 02 Jun 2011 12:32:53 +0100

djvulibre (3.5.24-4) unstable; urgency=low

  * merge upstream kbsd pthreads linkage mod (closes: #628800)

 -- Barak A. Pearlmutter <email address hidden> Wed, 01 Jun 2011 15:21:23 +0100

djvulibre (3.5.24-3) unstable; urgency=low

  * merge upstream change with promiscuous inclusions (closes: #625073)

 -- Barak A. Pearlmutter <email address hidden> Thu, 05 May 2011 08:04:13 +0100

djvulibre (3.5.24-2) unstable; urgency=low

  * do not include .la files per new policy (closes: #621306)

 -- Barak A. Pearlmutter <email address hidden> Wed, 20 Apr 2011 15:34:38 +0100

djvulibre (3.5.24-1) unstable; urgency=low

  * New upstream version

 -- Barak A. Pearlmutter <email address hidden> Mon, 07 Mar 2011 10:17:06 +0000

djvulibre (3.5.23-6) unstable; urgency=low

  * tiny patch to libdjvu/miniexp.cpp from Jacob Wilk (closes: #613549)

 -- Barak A. Pearlmutter <email address hidden> Wed, 02 Mar 2011 08:47:43 +0000

djvulibre (3.5.23-5) unstable; urgency=low

  * changes to debian/rules
    - honor DEB_BUILD_OPTIONS=noopt (closes: #613521) and debug
    - remove unused/inappropriate/old variables
    - let upstream ./configure choose optimisation flags; remove all special
      cases for particular broken versions of GCC on particular architectures
    - use dh_auto_make instead of invoking $(MAKE) directly
    - no need for "chmod +x ..." since git maintains that bit
    - remove "INSTALL_PROGRAM = $(INSTALL) --strip", as dh handles it
  * djvulibre-bin depends: same version of libdjvulibre21 (closes: #613530)

 -- Barak A. Pearlmutter <email address hidden> Wed, 16 Feb 2011 13:37:56 +0000

djvulibre (3.5.23-4) unstable; urgency=low

  * bump to debhelper 8
  * flush djview3, generate djview4 transition package (closes: #604347)
  * flush djvulibre-plugin, to be generated by djview4
  * dh --parallel
  * include phrase "dummy" in package descriptions to silence lintian
  * dpkg source format 3.0 (quilt)
  * upstream has switched to git (debian/README.Debian, debian/copyright)

 -- Barak A. Pearlmutter <email address hidden> Sat, 12 Feb 2011 13:26:14 +0000

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk4ALzQACgkQCV8mz8CxYckpiACfdEwfrXI08YWdChtlKZ2BWa1K
7/0An2Qp3gGY+ouW3BO73IdbBjphs2eT
=yBxJ
-----END PGP SIGNATURE-----

Changed in djvulibre (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) wrote :

[Updating] djvulibre (3.5.23-3ubuntu2 [Ubuntu] < 3.5.24-7 [Debian])
 * Trying to add djvulibre...
2011-06-22 11:09:17 INFO - <djvulibre_3.5.24-7.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2011-06-22 11:09:17 INFO - <djvulibre_3.5.24-7.dsc: downloading from http://ftp.debian.org/debian/>
2011-06-22 11:09:17 INFO - <djvulibre_3.5.24.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
I: djvulibre [main] -> libdjvulibre-dev_3.5.23-3ubuntu2 [main].
I: djvulibre [main] -> libdjvulibre21_3.5.23-3ubuntu2 [main].
I: djvulibre [main] -> libdjvulibre-text_3.5.23-3ubuntu2 [main].
I: djvulibre [main] -> djvulibre-dbg_3.5.23-3ubuntu2 [main].
I: djvulibre [main] -> djvulibre-desktop_3.5.23-3ubuntu2 [universe].
I: djvulibre [main] -> djview_3.5.23-3ubuntu2 [universe].
I: djvulibre [main] -> djview3_3.5.23-3ubuntu2 [universe].
I: djvulibre [main] -> djvuserve_3.5.23-3ubuntu2 [universe].
I: djvulibre [main] -> djvulibre-bin_3.5.23-3ubuntu2 [universe].

Changed in djvulibre (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers