c44(1) man page outputs splurious `.SM' macro invocation

Bug #255695 reported by Ralph Corderoy on 2008-08-07
6
Affects Status Importance Assigned to Milestone
djvulibre
Unknown
Unknown
djvulibre (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: djvulibre-bin

Ubuntu 8.04, djvulibre-bin 3.5.20-2.

c44(1) includes an invocation of the macro SM (small capitals) in its
output.

    $ man c44 | g -1 PPM
       can be either a portable gray-map ( PGM ) or a portable pix-map (.SM
       PPM ). Input images compressed with JPEG are also accepted. It is how‐
       ever suggested to only use high quality JPEG files ( low compression
    $

This is due to a faulty method of making the open parenthesis before
`PPM' have no intervening white-space.

    $ zc /usr/share/man/man1/c44.1.gz | g -1 PPM
    ) or a portable pix-map (\
    .SM PPM
    ).
    $

The attached patch fixes this and various other problems with the page's
formatting, including removing extra blank lines, starting paragraphs
the proper way, removing empty paragraphs from before a section header,
removing spaces from inside other parenthesis, stopping `e.g.' and
`i.e.' from looking like the end of a sentance, and removing full stops
after exclamation marks.

Kurt Litsch (kurt.litsch) wrote :

debdiff created from following the "Fixing Bugs 1" session from Developer Week.

Changed in djvulibre:
status: New → Confirmed
Daniel Holbach (dholbach) wrote :

Thanks Kurt.

Can you remove the additional
+ *
in your debian/changelog entry?

Also we're in Alpha5 Freeze right now, so it can't be uploaded.

It'd be nice if you could also forward the change to upstream (http://sourceforge.net/tracker/?group_id=32953&atid=406583) and/or Debian (https://wiki.ubuntu.com/Debian/Bugs).

Apart from that, the patch looks good. :-)

Kurt Litsch (kurt.litsch) wrote :

New debdiff to reflect Daniel's suggestion...I removed the old one to avoid any confusion. :)

Daniel Holbach (dholbach) wrote :

Thanks a lot for forwarding it, hopefully we can drop our local change due to that soon again. Also thanks for crediting Ralph with the fix in the changelog.

I'll check this out again once Alpha5 Freeze is over.

Thanks to both of you!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package djvulibre - 3.5.20-7ubuntu2

---------------
djvulibre (3.5.20-7ubuntu2) intrepid; urgency=low

  * tools/c44.1: applied patch from Ralph Corderoy to fix the manpage
    markup. (LP: #255695)

 -- Kurt Litsch <email address hidden> Wed, 03 Sep 2008 04:02:10 -0500

Changed in djvulibre:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.