Convert triggers to noawait

Bug #1780996 reported by Julian Andres Klode on 2018-07-10
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
appstream (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Julian Andres Klode
Bionic
Undecided
Unassigned
bumblebee (Ubuntu)
Undecided
Brian Murray
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
clutter-imcontext (Ubuntu)
Undecided
Julian Andres Klode
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
django-countries (Ubuntu)
Undecided
Brian Murray
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
dochelp (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Julian Andres Klode
Bionic
Undecided
Unassigned
dovecot (Ubuntu)
Undecided
Mathieu Trudel-Lapierre
Xenial
Undecided
Mathieu Trudel-Lapierre
Bionic
Undecided
Unassigned
fusiondirectory (Ubuntu)
Undecided
Mathieu Trudel-Lapierre
Xenial
Undecided
Mathieu Trudel-Lapierre
Bionic
Undecided
Unassigned
gdk-pixbuf (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Julian Andres Klode
Bionic
Undecided
Unassigned
glib2.0 (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Julian Andres Klode
Bionic
Undecided
Unassigned
gosa (Ubuntu)
Undecided
Łukasz Zemczak
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
guile-2.0 (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
hicolor-icon-theme (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Julian Andres Klode
Bionic
Undecided
Unassigned
libomxil-bellagio (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
libreoffice (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
ltsp (Ubuntu)
Undecided
Brian Murray
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
mate-icon-theme (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Julian Andres Klode
Bionic
Undecided
Unassigned
maxima (Ubuntu)
Undecided
Brian Murray
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
neurodebian (Ubuntu)
Undecided
Brian Murray
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
nevow (Ubuntu)
Undecided
Brian Murray
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
octave (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Brian Murray
Bionic
Undecided
Unassigned
packagekit (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Julian Andres Klode
Bionic
Undecided
Unassigned
pike7.8 (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
pike8.0 (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
postgresql-common (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Julian Andres Klode
Bionic
Undecided
Unassigned
qgis (Ubuntu)
Undecided
Brian Murray
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
reconf-inetd (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
shared-mime-info (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Julian Andres Klode
Bionic
Undecided
Unassigned
sphinx (Ubuntu)
Undecided
Unassigned
Xenial
Medium
Brian Murray
Bionic
Undecided
Unassigned
syslog-ng-incubator (Ubuntu)
Undecided
Brian Murray
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
tex-common (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Brian Murray
Bionic
Undecided
Unassigned
wokkel (Ubuntu)
Undecided
Brian Murray
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
xpdf (Ubuntu)
Undecided
Unassigned
Xenial
Medium
Brian Murray
Bionic
Undecided
Unassigned
yorick (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Brian Murray
Bionic
Undecided
Unassigned

Bug Description

This is a bug collecting all remaining packages that need to be converted to noawait in xenial or bionic.

[Impact]
"await" triggers are run before a package is configured. If B activates A, then A's trigger code in the postinst must be run before A can be configured.

Triggers do not specify a ordering dependency however, so apt can very well have A in a state where it is not configurable, and installing B then fails. This is a limitation of triggers: They are not exposed in Packages files, so we don't see them.

What this means is that packages with await triggers either need to have all triggering packages depend on them (e.g. B Depends A), or they need to be moved to noawait.

This bug is about moving triggers to be noawait, by changing "activate" to "activate-noawait" and/or "interest" to "interest-noawait". If it turns out the trigger should be "await", we should explictly use the "interest-await" and "activate-await" variants in cosmic too.

[Test case]
There is no test case.

[Regression potential]
Packages triggering other packages are now configured even without the package being triggered being fully configured (they will be in the triggers-pending state).

In most cases, this is not a problem. However, packages should be usable when configured, so for example, a package installing a gsettings schema would need to depend on the appropriate gsettings stuff and keep triggering it via await, as it would crash otherwise despite being configured.

Changed in appstream (Ubuntu):
status: New → Fix Released
Changed in appstream (Ubuntu Xenial):
status: New → Triaged
Changed in appstream (Ubuntu Bionic):
status: New → Fix Released
Changed in libreoffice (Ubuntu Xenial):
status: New → Triaged
Changed in libreoffice (Ubuntu Bionic):
status: New → Fix Released
Changed in libreoffice (Ubuntu):
status: New → Fix Released
Julian Andres Klode (juliank) wrote :

Missing in this bug:

kubuntu-settings
ubuntu-gnome-defaults/xenial
ubuntu-mate-artwork/xenial

these are tracked in bug 1750465.

description: updated
Changed in xpdf (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
Changed in xpdf (Ubuntu):
status: New → Fix Released
Changed in xpdf (Ubuntu Bionic):
status: New → Fix Released
Changed in appstream (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
Changed in appstream (Ubuntu Xenial):
status: Triaged → In Progress
Changed in glib2.0 (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
Changed in glib2.0 (Ubuntu Bionic):
status: New → Fix Released
Changed in glib2.0 (Ubuntu):
status: New → Fix Released
Changed in glib2.0 (Ubuntu Xenial):
status: New → In Progress
Changed in hicolor-icon-theme (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
status: New → Fix Released
Changed in hicolor-icon-theme (Ubuntu Bionic):
status: New → Fix Released
Changed in hicolor-icon-theme (Ubuntu Xenial):
status: New → In Progress
Brian Murray (brian-murray) wrote :
Changed in xpdf (Ubuntu Xenial):
assignee: nobody → Brian Murray (brian-murray)
importance: Undecided → Medium
status: New → In Progress
Changed in xpdf (Ubuntu):
assignee: Brian Murray (brian-murray) → nobody
Changed in mate-icon-theme (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
status: New → Fix Released
Changed in mate-icon-theme (Ubuntu Bionic):
status: New → Fix Released
Changed in mate-icon-theme (Ubuntu Xenial):
status: New → In Progress
Dmitry Shachnev (mitya57) wrote :

Sphinx in cosmic no longer uses triggers. Sphinx in bionic uses interest-noawait.

Changed in sphinx (Ubuntu):
status: New → Fix Released
Changed in sphinx (Ubuntu Bionic):
status: New → Fix Released
Changed in sphinx (Ubuntu Xenial):
assignee: nobody → Brian Murray (brian-murray)
importance: Undecided → Medium
status: New → In Progress
Changed in tex-common (Ubuntu Xenial):
assignee: nobody → Brian Murray (brian-murray)
Changed in tex-common (Ubuntu):
status: New → Fix Released
Changed in tex-common (Ubuntu Bionic):
status: New → Fix Released
Changed in tex-common (Ubuntu Xenial):
status: New → In Progress
Brian Murray (brian-murray) wrote :

Here's the yorick upstream change:

https://salsa.debian.org/science-team/yorick/commit/2266af43e759aee5c5f4afdf085c1bb23105412a

The important bit was just the trigger file.

Changed in yorick (Ubuntu Xenial):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress
Changed in yorick (Ubuntu):
status: New → Fix Released
Changed in gdk-pixbuf (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
status: New → Fix Released
Changed in gdk-pixbuf (Ubuntu Bionic):
status: New → Fix Released
Changed in gdk-pixbuf (Ubuntu Xenial):
status: New → In Progress
Changed in shared-mime-info (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
status: New → Fix Released
Changed in shared-mime-info (Ubuntu Bionic):
status: New → Fix Released
Changed in shared-mime-info (Ubuntu Xenial):
status: New → In Progress
Julian Andres Klode (juliank) wrote :

Turns out goopg was not affected, it does not exist in xenial.

no longer affects: goopg (Ubuntu)
no longer affects: goopg (Ubuntu Bionic)
no longer affects: goopg (Ubuntu Xenial)
Changed in packagekit (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
status: New → Fix Released
Changed in packagekit (Ubuntu Bionic):
status: New → Fix Released
Changed in packagekit (Ubuntu Xenial):
status: New → In Progress
Changed in appstream (Ubuntu Xenial):
assignee: nobody → Julian Andres Klode (juliank)
Changed in appstream (Ubuntu):
assignee: Julian Andres Klode (juliank) → nobody
Changed in gdk-pixbuf (Ubuntu Xenial):
assignee: nobody → Julian Andres Klode (juliank)
Changed in gdk-pixbuf (Ubuntu):
assignee: Julian Andres Klode (juliank) → nobody
Changed in glib2.0 (Ubuntu):
assignee: Julian Andres Klode (juliank) → nobody
Changed in glib2.0 (Ubuntu Xenial):
assignee: nobody → Julian Andres Klode (juliank)
Changed in hicolor-icon-theme (Ubuntu Xenial):
assignee: nobody → Julian Andres Klode (juliank)
Changed in hicolor-icon-theme (Ubuntu):
assignee: Julian Andres Klode (juliank) → nobody
Changed in mate-icon-theme (Ubuntu Xenial):
assignee: nobody → Julian Andres Klode (juliank)
Changed in mate-icon-theme (Ubuntu):
assignee: Julian Andres Klode (juliank) → nobody
Changed in packagekit (Ubuntu Xenial):
assignee: nobody → Julian Andres Klode (juliank)
Changed in packagekit (Ubuntu):
assignee: Julian Andres Klode (juliank) → nobody
Changed in shared-mime-info (Ubuntu Xenial):
assignee: nobody → Julian Andres Klode (juliank)
Changed in shared-mime-info (Ubuntu):
assignee: Julian Andres Klode (juliank) → nobody
tags: added: id-5b1169fb7c4ba277874d3879
Changed in octave (Ubuntu Xenial):
assignee: nobody → Brian Murray (brian-murray)
Changed in octave (Ubuntu):
status: New → Fix Released
Changed in octave (Ubuntu Bionic):
status: New → Fix Released
Changed in octave (Ubuntu Xenial):
status: New → In Progress
Changed in postgresql-common (Ubuntu Xenial):
assignee: nobody → Julian Andres Klode (juliank)
status: New → Triaged
Changed in postgresql-common (Ubuntu Bionic):
status: New → Fix Released
Changed in postgresql-common (Ubuntu):
status: New → Fix Released
Changed in postgresql-common (Ubuntu Xenial):
status: Triaged → In Progress
Changed in clutter-imcontext (Ubuntu):
status: New → Triaged
Changed in clutter-imcontext (Ubuntu Bionic):
status: New → Triaged
Changed in clutter-imcontext (Ubuntu Xenial):
status: New → Triaged
Changed in clutter-imcontext (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
Changed in gosa (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
status: New → In Progress
Julian Andres Klode (juliank) wrote :

clutter-imcontext declares an interest on /usr/lib/clutter-imcontext/immodules, but no package ships files in there, so not fixing that in a stable release. Not sure about devel.

Changed in clutter-imcontext (Ubuntu Xenial):
status: Triaged → Won't Fix
Changed in clutter-imcontext (Ubuntu Bionic):
status: Triaged → Won't Fix
Changed in yorick (Ubuntu Bionic):
status: New → Fix Released
Changed in libreoffice (Ubuntu Xenial):
assignee: nobody → Julian Andres Klode (juliank)
assignee: Julian Andres Klode (juliank) → nobody
Changed in dochelp (Ubuntu Xenial):
assignee: nobody → Julian Andres Klode (juliank)
status: New → Triaged
Changed in dochelp (Ubuntu):
status: New → Fix Released
Changed in dochelp (Ubuntu Bionic):
status: New → Fix Released
Changed in dochelp (Ubuntu Xenial):
status: Triaged → In Progress
Changed in dovecot (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
status: New → In Progress
Changed in bumblebee (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
Changed in bumblebee (Ubuntu):
status: New → In Progress
Changed in maxima (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress
Changed in neurodebian (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress
Changed in nevow (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress

dovecot for cosmic and bionic already changed to noawait triggers by Debian maintainer.

Changed in dovecot (Ubuntu):
status: In Progress → Fix Released
Changed in dovecot (Ubuntu Bionic):
status: New → Fix Released
Changed in dovecot (Ubuntu Xenial):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
status: New → In Progress
Changed in qgis (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress
Changed in wokkel (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress
Changed in syslog-ng-incubator (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress
Brian Murray (brian-murray) wrote :

wokkel needed fixing in both Ubuntu 16.04 and Ubuntu 18.04 although I can't add tasks for those releases.

Changed in ltsp (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress
Changed in django-countries (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress
Changed in appstream (Ubuntu):
status: Fix Released → In Progress
status: In Progress → Fix Released
Changed in wokkel (Ubuntu Xenial):
status: New → In Progress
Changed in wokkel (Ubuntu Bionic):
status: New → In Progress
Changed in wokkel (Ubuntu):
status: In Progress → Fix Released
Changed in bumblebee (Ubuntu Xenial):
status: New → In Progress
Changed in django-countries (Ubuntu Xenial):
status: New → In Progress
Changed in maxima (Ubuntu Xenial):
status: New → In Progress
Changed in neurodebian (Ubuntu Xenial):
status: New → In Progress
Changed in nevow (Ubuntu Xenial):
status: New → In Progress
Changed in qgis (Ubuntu Xenial):
status: New → In Progress
Changed in syslog-ng-incubator (Ubuntu Xenial):
status: New → In Progress
Changed in bumblebee (Ubuntu):
status: In Progress → Fix Released
Changed in django-countries (Ubuntu):
status: In Progress → Fix Released
Changed in maxima (Ubuntu):
status: In Progress → Fix Released
Changed in neurodebian (Ubuntu):
status: In Progress → Fix Released
Changed in nevow (Ubuntu):
status: In Progress → Fix Released
Changed in qgis (Ubuntu):
status: In Progress → Fix Released
Changed in glib2.0 (Ubuntu Xenial):
status: In Progress → Fix Committed
Changed in syslog-ng-incubator (Ubuntu):
status: In Progress → Fix Released
Changed in bumblebee (Ubuntu Bionic):
status: New → Fix Released
Changed in django-countries (Ubuntu Bionic):
status: New → Fix Released
Changed in maxima (Ubuntu Bionic):
status: New → Fix Released
Changed in neurodebian (Ubuntu Bionic):
status: New → Fix Released
Changed in nevow (Ubuntu Bionic):
status: New → Fix Released
Changed in qgis (Ubuntu Bionic):
status: New → Fix Released
Changed in syslog-ng-incubator (Ubuntu Bionic):
status: New → Fix Released
Changed in ltsp (Ubuntu):
status: In Progress → Fix Released
Changed in ltsp (Ubuntu Bionic):
status: New → Fix Released
Changed in ltsp (Ubuntu Xenial):
status: New → In Progress

Hello Julian, or anyone else affected,

Accepted glib2.0 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/glib2.0/2.48.2-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted hicolor-icon-theme into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/hicolor-icon-theme/0.15-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in hicolor-icon-theme (Ubuntu Xenial):
status: In Progress → Fix Committed
Changed in fusiondirectory (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
status: New → In Progress
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted xpdf into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xpdf/3.04-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xpdf (Ubuntu Xenial):
status: In Progress → Fix Committed
Angel Abad (angelabad) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fusiondirectory - 1.0.19-1ubuntu1

---------------
fusiondirectory (1.0.19-1ubuntu1) cosmic; urgency=medium

  * debian/fusiondirectory.triggers: Be specific about using interest-noawait
    for the triggers -- there's no need to block in awaiting the triggers for
    locale, plugins updates. (LP: #1780996)

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 12 Jul 2018 10:57:06 -0400

Changed in fusiondirectory (Ubuntu):
status: In Progress → Fix Released
Changed in fusiondirectory (Ubuntu Xenial):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
status: New → In Progress
Changed in fusiondirectory (Ubuntu Bionic):
status: New → In Progress
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted mate-icon-theme into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mate-icon-theme/1.12.0-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mate-icon-theme (Ubuntu Xenial):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted sphinx into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/sphinx/1.3.6-2ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in sphinx (Ubuntu Xenial):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted tex-common into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/tex-common/6.04ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in tex-common (Ubuntu Xenial):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted yorick into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/yorick/2.2.04+dfsg1-5ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in yorick (Ubuntu Xenial):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted gdk-pixbuf into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gdk-pixbuf/2.32.2-1ubuntu1.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gdk-pixbuf (Ubuntu Xenial):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted shared-mime-info into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/shared-mime-info/1.5-2ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in shared-mime-info (Ubuntu Xenial):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted packagekit into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/packagekit/0.8.17-4ubuntu6~gcc5.4ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in packagekit (Ubuntu Xenial):
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers