ubuntu-distro-info --devel fails (distro-info data out of date)

Bug #1309591 reported by Scott Moser on 2014-04-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bikeshed (Ubuntu)
Medium
Dustin Kirkland 
distro-info (Ubuntu)
Undecided
Unassigned

Bug Description

$ ubuntu-distro-info --devel; echo $?
ubuntu-distro-info: Distribution data outdated.
Please check for an update for distro-info-data. See /usr/share/doc/distro-info-data/README.Debian for details.
1

Not really distro-info's fault that no one has released the Unseen Unicorn just yet, but it seems maybe possible that 'trusty' is a better result than failure here.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: distro-info 0.12
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Apr 18 11:18:27 2014
Dependencies:
 distro-info-data 0.18
 gcc-4.9-base 4.9-20140406-0ubuntu1
 libc6 2.19-0ubuntu6
 libgcc1 1:4.9-20140406-0ubuntu1
 multiarch-support 2.19-0ubuntu6
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-04-17 (1 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140415)
SourcePackage: distro-info
UpgradeStatus: No upgrade log present (probably fresh install)

Scott Moser (smoser) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in distro-info (Ubuntu):
status: New → Confirmed
Dustin Kirkland  (kirkland) wrote :

I hit this bug too. It's breaking the cloud-sandbox script in bikeshed.

Changed in bikeshed (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Dustin Kirkland  (kirkland)
Changed in bikeshed (Ubuntu):
status: In Progress → Fix Committed
Iain Lane (laney) wrote :

I think we should just fall back to reporting stable in this case.

Here's a patch that does this for the command-line tool. I've not done it for the libraries, but can do if we want that too.

tags: added: patch
Benjamin Drung (bdrung) wrote :

I am against falling back to reporting the stable release if the distribution data is outdated, because it is just a guess and this guess could be wrong.

Application that use distro-info should decide what to do in case of outdated distribution data. cloud-sandbox should fall back to use stable (and then to use the latest supported one):

release="$(ubuntu-distro-info --devel || ubuntu-distro-info --stable || ubuntu-distro-info --supported | tail -n 1) daily"

Iain Lane (laney) wrote :

Fine. I think it's stupid that every application has to do this itself. This could be documented behaviour. But there you go.

Benjamin Drung (bdrung) wrote :

Would it be a good idea to add a new --latest option that will roughly be equivilent to "distro-info --devel || distro-info --stable || distro-info --supported | tail -n 1"? Then the application developers can decide what they want and use either --latest or --devel.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bikeshed - 1.45-0ubuntu1

---------------
bikeshed (1.45-0ubuntu1) utopic; urgency=medium

  * cloud-sandbox:
    - safer use of ubuntu-distro-info, from Scott Moser
  * vigpg, wifi-status.1:
 -- Dustin Kirkland <email address hidden> Wed, 23 Apr 2014 18:17:19 -0500

Changed in bikeshed (Ubuntu):
status: Fix Committed → Fix Released
Benjamin Drung (bdrung) wrote :

--latest option implemented in distro-info 0.13.

Changed in distro-info (Ubuntu):
status: Confirmed → Fix Committed
Benjamin Drung (bdrung) wrote :

I reopen the bug against bikeshed. Please use "ubuntu-disto-info --latest" instead of "distro-info --devel || distro-info --all | tail -n 1"

Changed in bikeshed (Ubuntu):
status: Fix Released → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package distro-info - 0.13

---------------
distro-info (0.13) unstable; urgency=medium

  [ Benjamin Drung ]
  * ubuntu-distro-info: Add --latest option. Use this option instead of --devel
    if you want to fallback to --stable for outdated data. (LP: #1309591)
  * distro_info_test/test_help.py: Close file descriptors at the end.

  [ Dimitri John Ledkov ]
  * Add --series lookup.

 -- Benjamin Drung <email address hidden> Sat, 10 May 2014 20:55:33 +0200

Changed in distro-info (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments