Import issue with namespace packages in pkg_resources

Bug #938786 reported by Cas on 2012-02-22
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
distribute (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

This bug was introduced by the distribute (0.6.16-1) update and breaks python namespace packages.

The fix to this was released in distribute 0.6.18 and the trivial patch is here: https://bitbucket.org/tarek/distribute/changeset/191f38f47256

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: python-pkg-resources 0.6.16-1
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
Uname: Linux 3.0.0-16-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Wed Feb 22 12:31:54 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
SourcePackage: distribute
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Cas (calumlind) wrote :
Micah Gersten (micahg) on 2012-02-23
Changed in distribute (Ubuntu):
status: New → Invalid
Revision history for this message
Bobby R. Ward (bobbyrward) wrote :

debdiff including the fix from upstream

Based this off of the version from here (https://bugs.launchpad.net/ubuntu/+source/distribute/+bug/910965). I'm not sure how that's supposed to work.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in distribute (Ubuntu Oneiric):
status: New → Confirmed
Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

Thanks!

ACK on the debdiff. I simply added a bug number reference to the changelog, and changed the pocket to oneiric-proposed.

Uploaded to -proposed to await processing by the SRU team.

Revision history for this message
Sebastien Bacher (seb128) wrote :

unsubscribing sponsors

Changed in distribute (Ubuntu Oneiric):
status: Confirmed → Fix Committed
importance: Undecided → High
Changed in distribute (Ubuntu):
status: Invalid → Fix Released
Revision history for this message
Jonathan Riddell (jr) wrote :

waiting on approval from ubuntu-sru

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Cas, or anyone else affected,

Accepted distribute into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote : Verification still needed

The fix for the this bug has been awaiting testing feedback in the -proposed repository for oneiric for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now the package will be removed from the -proposed repository.

Revision history for this message
Cas (calumlind) wrote :

Sorry I no longer use Oneiric so I cannot verify, all I can say is that I know that the fix worked when I tested it originally.

tags: added: removal-candidate
Revision history for this message
Brian Murray (brian-murray) wrote :

The version of distribute in oneiric-proposed has been removed as this bug report was not verified in a timely fashion.

Changed in distribute (Ubuntu Oneiric):
status: Fix Committed → Triaged
tags: removed: verification-needed
tags: removed: removal-candidate
Revision history for this message
Cas (calumlind) wrote :

You are kidding?

Revision history for this message
Scott Kitterman (kitterman) wrote :

No. It's been sitting there for 9 months with no one testing to see if the bug was fixed. Quite reasonable.

Revision history for this message
Cas (calumlind) wrote :

The process clearly is not working when distribute has a patch applied in the first instance which turns out was bad and then the fix to correct that patch requires verification but 9 months later seemingly no-one other than myself can do that.

I also was honest about being unable to test on Oneiric however the diff and the fix I pointed to originally are identical (4 lines of python with an indentation issue) so I feel I should have just helped the process along and said it worked fine.

Revision history for this message
Matthias Klose (doko) wrote : Re: [Bug 938786] Re: Import issue with namespace packages in pkg_resources

Am 01.12.2012 01:32, schrieb Cas:
> I also was honest about being unable to test on Oneiric however the diff
> and the fix I pointed to originally are identical (4 lines of python
> with an indentation issue) so I feel I should have just helped the
> process along and said it worked fine.

the process works fine. And I don't think you are telling the truth not being
able to test this. You should be able to set up an oneiric chroot, or an oneiric
virtual machine to test this. Yes, it does cost time, including for yourself.
Fine if you don't want to spend this time, but then please don't blame others
doing the same as you.

If you do have questions regarding the chroot approach, please see
https://wiki.ubuntu.com/DebootstrapChroot

Revision history for this message
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in distribute (Ubuntu Oneiric):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers