Xenial --> Bionic = distcc fails to start

Bug #1797361 reported by Ken Sharp
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
distcc (Debian)
Fix Released
Unknown
distcc (Ubuntu)
Undecided
Unassigned

Bug Description

When upgrading from Xenial to Bionic there is a failure to check for deprecated options, and hence distcc fails to load at boot.

Oct 11 07:56:47 distcc[1595]: * Starting Distributed Compiler Daemon: distccd
Oct 11 07:56:48 distcc[1595]: * /etc/init.d/distcc: start failed with error code 101
Oct 11 07:56:48 distcc[1595]: ...fail!
Oct 11 07:56:48 distccd[1714]: ERROR: --zeroconf: unknown option
Oct 11 07:56:48 systemd[1]: distcc.service: Control process exited, code=exited status=101

distcc --help no longer shows a zeroconf option.

From /etc/init.d/distcc:

if [ "$ZEROCONF" = "true" ] || [ "$ZEROCONF" = "YES" ]; then
        DAEMON_ARGS="$DAEMON_ARGS --zeroconf"
fi

$ZEROCONF is apparently pulled in from /etc/default/distcc which is edited by the end user, but if it is a deprecated option then it should be silently ignored.

The patch will be simple, but I don't know the process for submitting it to Ubuntu/Debian.

Already reported to Debian.
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=880986

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: distcc 3.1-6.3
ProcVersionSignature: Ubuntu 4.15.0-36.39-generic 4.15.18
Uname: Linux 4.15.0-36-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
Date: Thu Oct 11 12:04:18 2018
InstallationDate: Installed on 2016-08-13 (789 days ago)
InstallationMedia: Ubuntu-Server 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
SourcePackage: distcc
UpgradeStatus: Upgraded to bionic on 2018-09-28 (12 days ago)
modified.conffile..etc.logrotate.d.distcc: [modified]
mtime.conffile..etc.logrotate.d.distcc: 2018-05-17T23:02:33.460945

Revision history for this message
Ken Sharp (kennybobs) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in distcc (Ubuntu):
status: New → Confirmed
Changed in distcc (Debian):
status: Unknown → New
Changed in distcc (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.