Ubuntu

displayconfig-gtk crashed with AttributeError in isXorgConfigChanged()

Reported by Graubart on 2007-12-03
270
Affects Status Importance Assigned to Milestone
displayconfig-gtk (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: displayconfig-gtk

All Fields in displayconfig GTK are empty. klick on Cancel or okay, and it crash.

ProblemType: Crash
Architecture: amd64
Date: Mon Dec 3 23:18:23 2007
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/displayconfig-gtk
InterpreterPath: /usr/bin/python2.5
Package: displayconfig-gtk 0.3.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/displayconfig-gtk
ProcCwd: /home/emil
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/displayconfig-gtk']
SourcePackage: displayconfig-gtk
Title: displayconfig-gtk crashed with AttributeError in isXorgConfigChanged()
Uname: Linux ubuntu 2.6.22-14-generic #1 SMP Sun Oct 14 21:45:15 GMT 2007 x86_64 GNU/Linux
UserGroups:

Graubart (emilseyfried) wrote :
Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

The attached patch should stop the crashing, feel free to test and give feedback.

Thanks,
 Michael

Changed in displayconfig-gtk:
importance: Undecided → Medium
milestone: none → ubuntu-8.04-beta
status: New → In Progress
Savvas Radevic (medigeek) wrote :

Will this proposal fix the fact that my screens and graphics appears totally empty?
http://bugs.launchpad.net/bugs/195342
http://launchpadlibrarian.net/12179056/empty-displayconfig-gtk.png

or should I put it under a separate bug report?

Savvas Radevic (medigeek) wrote :

never mind, found another bug report :)

Dave Thiede (davidrthiede) wrote :

I applied the patch and the app still crashes. The bug report I filed was marked as a duplicate of this one even though the triggering environment would appear to be the empty screens and graphics pick boxes. 198948

Dave Thiede (davidrthiede) wrote :

Posted the previous too quickly. This bug does also includes the blank entry fields problem. sigh. while the above patch certainly will work better in that it checks its arguments better it still doesn't address why the graphics devices and screens are not being populated. In my case, it might be the vmware devices that are not being detected or enumerated.

Chris Smith (cs278) wrote :

I am seeing the both problems, the crash, and the non populated form on physical hardware.

Same here no resolution options or hardware

Is anyone else still experiencing this? The issue has been resolved on my Hardy install.

I am still experincing this. When I open the program, there fields
are empty and the mouse pointer shows the loading animation.

On Mon, Mar 10, 2008 at 3:48 PM, Andrew Starr-Bochicchio
<email address hidden> wrote:
> Is anyone else still experiencing this? The issue has been resolved on
> my Hardy install.
>
>
>
> --
> displayconfig-gtk crashed with AttributeError in isXorgConfigChanged()
> https://bugs.launchpad.net/bugs/173762
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Daniele Dellafiore
http://blog.ildella.net/

Dave Thiede (davidrthiede) wrote :

it is sort of fixed. my expectations would be that the fields would be populated by a fixed package but as of last Wednesday's patches it hadn't. even rebooting didn't cause the fields to fill in. I then installed nightly iso build from wednesday (5 march 2008). this time the fields were filled in and I was able to select screen resolutions and monitors. much improved. I wouldn't say that the configuration tool is solid though. that is probably for another bug posting.

Bryce Harrington (bryce) wrote :

The reason the fields are blank is because displayconfig-gtk populates them by reading from xorg.conf. In modern Xorg such as shipped with Hardy, most of this stuff is now automatically detected and is no longer needed in xorg.conf. Due to these changes, displayconfig-gtk has become obsolete, and we're deprecating it in favor of an updated Screen Resolution tool which has xrandr 1.2 support. For a more detailed explanation please see bug 144641.

Changed in displayconfig-gtk:
status: In Progress → Fix Released
Bryce Harrington (bryce) wrote :

An in depth background is also available in the comments of bug 147721.

To post a comment you must log in.