wrong detection of graphics card

Bug #30300 reported by Stephan Ruegamer on 2006-02-02
This bug report is a duplicate of:  Bug #35473: Intel Mobile 915 wrong detection. Edit Remove
10
Affects Status Importance Assigned to Milestone
discover1-data (Ubuntu)
Medium
Unassigned

Bug Description

during default install of latest daily and via dist-upgrade from breezy, the xorg graphics card detection is not working correctly anymore.

Instead of detecting the i810 card (well, it's an i915 in this portege r200 sponsored laptop) it detects only the VESA mode driver.

The resolution is still correct, but it's the wrong driver.

Joacim Haglund (joaha) wrote :

I also have an i915 in a centrino notebook and got the vesa driver with dapper flight 3. (Resolution is always wrong since neither vesa nor i810 support 1280x768 without 'i915resolution', but that's another issue).

/Joacim.

William Grant (wgrant) wrote :

My Dell Inspiron 630m's i915 graphics is also not correctly detected in Dapper Flight 3/4. Reconfiguring Xorg and forcing use of the i810 driver makes everything work fine.

There is _certainly_ a problem with the detection of the i915, and maybe other later Intel chips. I believe that this bug's status should be Confirmed, and should be easily fixed before Dapper.

Changed in xorg:
status: Unconfirmed → Confirmed

This is related to https://launchpad.net/malone/bugs/28262, possibly the same bug.

Simo Hellsten (simohell) wrote :

Flight 4 failed to detect 915GM, but for me manually changing vesa to i810 fails, giving black screen only.

Xinerama setting with both laptop and external monitor works patially.

Paul Sladen (sladen) wrote :

Hello \sh, this should be fixed now, some IDs were missing

Changed in discover1-data:
status: Confirmed → Fix Released
Joacim Haglund (joaha) wrote :

Tested Dapper Flight 6 i386 iso and my i915 was configured to use the i810 driver direct on install. This failed with flight 3 and flight 5 for me. Thanks for the fix.
--
glxinfo | grep -i render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) 915GM 20050225

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers