dir2ogg crashed with ID3NoHeaderError in __load_header()

Bug #229179 reported by Christian Victor on 2008-05-11
10
Affects Status Importance Assigned to Milestone
dir2ogg
Undecided
Unassigned
dir2ogg (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Julian Andres Klode

Bug Description

Binary package hint: dir2ogg

i coded my mp3 files to ogg.. and then ...

ProblemType: Crash
Architecture: i386
Date: Sun May 11 09:13:28 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/dir2ogg
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: dir2ogg 0.11.4-1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/dir2ogg -r --delete-input -v --convert-all -t /music/
ProcEnviron:
 SHELL=/bin/bash
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
 LANGUAGE=de_DE:de:en_GB:en
PythonArgs: ['/usr/bin/dir2ogg', '-r', '--delete-input', '-v', '--convert-all', '-t', '/music/']
SourcePackage: dir2ogg
Title: dir2ogg crashed with ID3NoHeaderError in __load_header()
Uname: Linux 2.6.24-17-generic i686
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin plugdev sambashare scanner tape users vboxusers

---
If a single file contains no headers, the conversion of all other files fails. This is extremely bad if a user converts 10,000 files.
TEST CASE:
 $ oggdec -o - /usr/share/example-content/ubuntu Sax.ogg | lame > test.mp3; dir2ogg test.mp3

PATCH (Update 0.11.5-1):
 http://bazaar.launchpad.net/~juliank/dir2ogg/main/revision/60

Julian Andres Klode (juliank) wrote :

Does this file have any ID3 tags?

No.

But that is not the point. If one tries to convert thousands of mp3-files to
ogg, then it is very disturbing, if the process ends just because of missing
tags. the program should override this, i think.

result: mp3-file without tags before conversion, ogg-file without comments after
conversion

Julian Andres Klode (juliank) wrote :

The bug has been fixed in the bugfix release 0.11.5, which has been uploaded to Debian as 0.11.5-1 and will be synced into Ubuntu soon.

Changed in dir2ogg:
status: New → Fix Released
Julian Andres Klode (juliank) wrote :

Needs to be synced

Changed in dir2ogg:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dir2ogg - 0.11.5-1

---------------
dir2ogg (0.11.5-1) unstable; urgency=low

  * New bugfix release: Fix support for files with no headers (LP: #229179)

 -- Ubuntu Archive Auto-Sync <email address hidden> Fri, 16 May 2008 09:47:37 +0100

Changed in dir2ogg:
status: Confirmed → Fix Released
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers