digikam doesn't create thumbnails of video files

Bug #890059 reported by Reece
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
digikam (Ubuntu)
Fix Released
Low
Harald Sitter
Quantal
Won't Fix
Low
Harald Sitter
Raring
Fix Released
Low
Harald Sitter

Bug Description

Environment: 11.10, daily updates, running GNOME/unity

digikam creates thumbnails for images, but not for video. stderr shows:
digikam(2506)/digikam (core) Digikam::ThumbnailCreator::createThumbnail: Cannot create thumbnail for "/home/reece/Pictures/2011/06/05/mvi_2649.mov"
digikam(2506)/digikam (core) Digikam::ThumbnailCreator::createThumbnail: Cannot create thumbnail for "/home/reece/Pictures/2011/06/05/mvi_2649.mov"
digikam(2506)/digikam (core) Digikam::ThumbnailCreator::load: Thumbnail is null for "/home/reece/Pictures/2011/06/05/mvi_2649.mov"
digikam(2506)/digikam (core) Digikam::ThumbnailCreator::load: Thumbnail is null for "/home/reece/Pictures/2011/06/05/mvi_2649.mov"

(Yes, messages are doubled.) There's no indication about the cause of the failure.

Revision history for this message
Calvin Leung (78luphr0rnk2nuqimstywepozxn9kl19tqh0tx66b5dki1xxsh5mkz9gl21a5rl-launchpad-a811i2i3ytqlsztthjth0svbccw8inm65tmkqp9sarr553jq53in4xm1m8wn3o4) wrote :

I got the same message with 2.4.1 Digikam I believe the move thumbnail used to work in previous release

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in digikam (Ubuntu):
status: New → Confirmed
Revision history for this message
p1ngu1n (vincent-barberet) wrote :

Got same issue with digikam 2.4.1 / KDE 4.7.3

Note:
- mplayerthumbs is installed
- changing the engine from phonon to mplayer in mplayerthumbsconfig does not solve issue
- konqueror and dolphin still generates thumbnails when required.

Revision history for this message
idef1x (sjoerdkrol) wrote :

Also the case for digikam 2.4.1 / KDE 4.7.4

dolphin does show the thumbs..

Revision history for this message
p1ngu1n (vincent-barberet) wrote :

Further debugging information, with kdebug enabled:

digikam(2721)/digikam (core) Digikam::ThumbnailSchemaUpdater::startUpdates: Have a thumbnail database structure version "2"
digikam(2721)/digikam (core) Digikam::ThumbnailLoadThread::initializeThumbnailDatabase: Thumbnail db ready for use

==> This changes storage method from ThumbnailCreator::FreeDesktopStandard to ThumbnailCreator::ThumbnailDatabase

[...]

digikam(2721)/KEXIV2 KExiv2Iface::KExiv2::KExiv2Priv::printExiv2ExceptionError: Cannot load metadata using Exiv2 (Error # 11 : /media/video/VIDEO_VINCENT/Noel_2011/01039.MTS : Le fichier contient des données de type inconnu
digikam(2721)/KDCRAW KDcrawIface::KDcraw::loadEmbeddedPreview: Failed to load embedded RAW preview
digikam(2721)/digikam (core) Digikam::DImg::load: "/media/video/VIDEO_VINCENT/Noel_2011/01039.MTS" : QIMAGE file identified
digikam(2721)/digikam (core) Digikam::QImageLoader::load: Can not load " "/media/video/VIDEO_VINCENT/Noel_2011/01039.MTS" " using DImg::QImageLoader!
digikam(2721)/digikam (core) Digikam::isJpegImage: mimetype = ""
digikam(2721)/digikam (core) Digikam::ThumbnailCreator::createThumbnail: Cannot create thumbnail for "/media/video/VIDEO_VINCENT/Noel_2011/01039.MTS"
digikam(2721)/digikam (core) Digikam::ThumbnailCreator::load: Thumbnail is null for "/media/video/VIDEO_VINCENT/Noel_2011/01039.MTS"

Revision history for this message
p1ngu1n (vincent-barberet) wrote :

Hello,

FYI, issue still present with Digikam 2.5.0 and KDE 4.8

regards

Revision history for this message
melenzb (woodhouser) wrote :

A serious bug and no apparent activity to fix it? speaking on 06 may 2012 and confirming that the bug is still present on an up to date ubuntu 12.04 64 bit system

Revision history for this message
Calvin Leung (78luphr0rnk2nuqimstywepozxn9kl19tqh0tx66b5dki1xxsh5mkz9gl21a5rl-launchpad-a811i2i3ytqlsztthjth0svbccw8inm65tmkqp9sarr553jq53in4xm1m8wn3o4) wrote :

The video thumbnail seem to work in 2.6 PPA build

Revision history for this message
Achim Bohnet (allee) wrote :

Kubuntu 12.10 quantal with KDE 4.9.2 and digikam 2.8

* After I installed kffmpegthumbnailer video thumbs worked in dolphin and digikam.

* mplayerthumbs pkg does not exist anymore

* ffmpegthumbnailer is not used by KDE video thumb creation process. Did not work for me.

So replace digikams debian/control

Recomends: mplayerthumbs

with

Recomends: kffmpegthumbnailer

@UNITY Users: as I've no unity enviroment can someone verify that this fixes the bug with digikam in unity

Achim

Revision history for this message
hvdwolf (hvdwolf) wrote :

Hi Achim,

I am on Unity (12.04) and I would very much like to try it but how/where do I replace digikams debian/control settings?

I did install kffmpegthumbnailer, I restarted digikam and tried to rebuild the miniatures for some albums but that didn't work for my mp4s.

Please explain

Revision history for this message
Achim Bohnet (allee) wrote :

1) a correction: ffmpegthumbs does work too! Verified precise + kde sc 4.9.2 backport + digikam 2.6
    as this pkg in part of kdemultimedia I assume it's the better choice. Last kffmpegthumbnailer release was Jan 2010

2) @hvdwolf: mp4 is AFAIU a restricted format. So make sure you have the libavcodec-extra* pkg installed. If it's allowed in your
   country install kubuntu-restricted-extras

   Try to install ffmpegthumbnailer pkg and test if you can create a thumbnail:

      ffmpegthumbnailer -i /path/to/your/file.mp4 -o test.png
      kde-open test.png

Revision history for this message
hvdwolf (hvdwolf) wrote :

Thanks for your reply.

I installed ffmpegthumbs, ffmpegthumbnailer, kubuntu-restricted-extras.
I already had all libav*-extra installed as I use h.264 mp4 video as well in kdenlive and openshot.

I removed kffmpegthumbnailer again.

I can create thumbnails as per your explained command. However, kde-open opens the png in a webbrowser due to the bug described in <http://mail.kde.org/pipermail/unassigned-bugs/2012-January/022812.html>.

Still, digikam still doesn't display the thumbnails for the movie, neither after a regenerate of the thumbnails for that album(s).

Again, please explain what you mean with "So replace digikams debian/control .... etc".
Where do I replace what? Is there some (configuration) setting? Or do you address the digikam packager here for dependencies?

Revision history for this message
Achim Bohnet (allee) wrote :

@hvdwolf:
The 'So replace digikams debian/control ...' is for the guys doing the .deb packing,
not for users. For you it translates into install (k)ffmpegthumbs pkg. What you've done already.

If you replace kde-open with your favorite image viewer and generated thumbnail
of an mp4, that has no icon in digikam, is okay, then I have no glue what goin' wrong in your case :-(

Revision history for this message
hvdwolf (hvdwolf) wrote :

@Achim: Did you configure anything in digikam or it's config files to get ffmpegthumbs (or ffmpegthumbnailer or kffmpegthumbnailer for that matter) working for digikam. I assume the "ThumbnailCreator" process needs some input to know which thumbnailer to choose.

Changed in digikam (Ubuntu Quantal):
status: New → Triaged
Changed in digikam (Ubuntu Raring):
status: Confirmed → Triaged
Changed in digikam (Ubuntu Quantal):
importance: Undecided → Low
Changed in digikam (Ubuntu Raring):
importance: Undecided → Low
Changed in digikam (Ubuntu Quantal):
assignee: nobody → Harald Sitter (apachelogger)
Changed in digikam (Ubuntu Raring):
assignee: nobody → Harald Sitter (apachelogger)
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package digikam - 4:3.0.0~beta3-0ubuntu1

---------------
digikam (4:3.0.0~beta3-0ubuntu1) raring; urgency=low

  * New upstream release
    - Add build-deps : libhupnp-dev, libqtgstreamer-dev, libmagickcore-dev
  * Merge from debian, remaining changes:
    - Make sure libqt4-opengl-dev, libgl1-mesa-dev and libglu1-mesa-dev only
      install on i386,amd64 and powerpc
    - Depend on libtiff-dev instead of libtiff4-dev
    - Drop digikam breaks/replaces kipi-plugins-common since we're past the
      LTS release now
    - digikam to recommend mplayerthumbs | ffmpegthumbs. We currently only
      have latter in the archives, even though former is also supposed to
      be part of kdemultimedia. (LP: #890059)
    - kipi-plugins to recommend www-browser rather than konqueror directly
      since 2.8 no direct usage of konqueror is present in the flickr
      plugin anymore (LP: #1011211)
    - Keep kubuntu_mysqld_executable_name.diff
    - Don't install libkipi translations
    - Keep deps on libcv-dev, libcvaux-dev
    - Keep split packaging of libraries
    - Replace icons from KDE 3 time in debian/xpm.d/*.xpm with the new
      versions (LP: #658047)
  * Update debian/not-installed
 -- Rohan Garg <email address hidden> Mon, 26 Nov 2012 18:24:20 +0000

Changed in digikam (Ubuntu Raring):
status: Fix Committed → Fix Released
Revision history for this message
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in digikam (Ubuntu Quantal):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers