digikam cannot connect to PTP cameras

Bug #865032 reported by Thomas Lesinski
224
This bug affects 42 people
Affects Status Importance Assigned to Milestone
digikam (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I'm using Digikam with a Nikon D80 and a Nikon Coolpix S3100. with both cameras set up for PTP transfer mode, selecting Import > Camera > xyz (auto-detected), nothing happens. If I run digikam from Konsole, i get an error message there:

digikam(19641)/digikam (core): Failed to detect camera with GPhoto2 from Solid information

Initially, gphoto2 wasn't installed as a dependency of digikam (probably should be ?). After installing it: same error.

Everything seems to work with mass storage mode, though.

Thanks for you attention to this detail...

T.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: digikam 2:2.1.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Sun Oct 2 20:46:20 2011
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: digikam
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Thomas Lesinski (lesintho) wrote :
Revision history for this message
Thomas Lesinski (lesintho) wrote :

I forgot:

* Mass storage works on the D80, the S3100 doesn't have this mode... Help :^)

* Gphoto2 does detect the cameras, as does the system in general (device widget, etc.)

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in digikam (Ubuntu):
status: New → Confirmed
Revision history for this message
Joeman1 (jgiles) wrote :
Download full text (3.6 KiB)

I am having this problem too with my Sony Mavica MVC-CD300.

-----------------------------------------------------------------------------------------------------------------------------
digikam(2125)/digikam (core): Failed to detect camera with GPhoto2 from Solid information
digikam(2125)/digikam (core): Failed to detect camera with GPhoto2 from Solid information
digikam(2125)/digikam (core): Failed to detect camera with GPhoto2 from Solid information
-----------------------------------------------------------------------------------------------------------------------------

gphoto2 is able to see the camera and pull data from it:

-----------------------------------------------------------------------------------------------------------------------------
gphoto2 --list-folders
There is 1 folder in folder '/'.
 - store_00010001
There are 0 folders in folder '/store_00010001'.
-----------------------------------------------------------------------------------------------------------------------------

I am also able to mount the device with Dolphin and pull the images from the device.

gPhoto2 says it fully supports the device:

-----------------------------------------------------------------------------------------------------------------------------
gphoto2 --list-cameras |grep CD300
        "Sony MVC-CD300 (PTP mode)"
-----------------------------------------------------------------------------------------------------------------------------

I am using PTP Mode as well.
-----------------------------------------------------------------------------------------------------------------------------
cat /etc/debian_version
wheezy/sid

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"

uname -a
Linux linuxbox 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

dpkg -l |grep digikam
ii digikam 2:2.1.1-0ubuntu1 digital photo management application for KDE
ii digikam-data 2:2.1.1-0ubuntu1 digikam architecture-independent data
ii libkface-data 1.0~digikam2.1.1-0ubuntu1 Data files for libkface
ii libkface1 1.0~digikam2.1.1-0ubuntu1 LibFace wrapper for Qt/C++
ii libkgeomap-data 1.0~digikam2.1.1-0ubuntu1 Data files for libkgeomap
ii libkgeomap1 1.0~digikam2.1.1-0ubuntu1 World-map wrapper to browse and arrange photos over a map
ii libkvkontakte-data 1.0~digikam2.1.1-0ubuntu1 Data files for libkvkontakte
ii libkvkontakte1 1.0~digikam2.1.1-0ubuntu1 vkontakte.ru library

dpkg -l |grep gphoto
ii gphoto2 2.4.11-1ubuntu1 The gphoto2 digital camera command-line client
ii libgphoto2-2 2.4.11-3 gphoto2 digital camera ...

Read more...

Revision history for this message
Bohdan (bohdan-linda) wrote :

Confirming the problem with Nikon D90

Revision history for this message
Bohdan (bohdan-linda) wrote :

Gentoo had similar problem, digikam was compiled withou libgphoto2 support. ldd /usr/bin/digikam does not list any compiled in libgphoto2 library

Revision history for this message
Bohdan (bohdan-linda) wrote :

Self compiled digikam
~/compile/digikam-sc/build/core/digikam$ ldd digikam | grep gph
        libgphoto2_port.so.0 => /usr/lib/libgphoto2_port.so.0 (0x00007f43c19c3000)
        libgphoto2.so.2 => /usr/lib/libgphoto2.so.2 (0x00007f43c1743000)
Stock digikam
$ ldd /usr/bin/digikam | grep gph
$

Revision history for this message
Bohdan (bohdan-linda) wrote :

From source package of dikigam:

# FIXME: gphoto2 support disabled because it causes a DSO build failure
override_dh_auto_configure:
        dh_auto_configure -- -DWITH_Gphoto2=FALSE

if changed to true and recompiled, digikam will segfault after trying to import from camera

Revision history for this message
Stéphane (stephane-treboux) wrote :

Same bug on Ubuntu since oeneric (11.10).

Qt: 4.7.4
KDE Development Platform: 4.7.1 (4.7.1)
digiKam: 2.1.1

PTP cameras cause the following error message:
digikam(9245)/digikam (core): Failed to detect camera with GPhoto2 from Solid information

Revision history for this message
Jari Laamanen (yartsa) wrote :

I confirm that this is also in Kubuntu 11.10

Qt: 4.7.4
KDE Development Platform: 4.7.2 (4.7.2)
digiKam: 2.1.1

Error:
digikam(31333)/digikam (core): Failed to detect camera with GPhoto2 from Solid information

$ ldd /usr/bin/digikam | grep gph
shows nothing

$ gphoto2 --auto-detect
Model Port
----------------------------------------------------------
Canon Digital IXUS iZ (PTP mode) usb:002,011

Revision history for this message
Bohdan (bohdan-linda) wrote :

additional finding. Seems that adding support with libgphoto2 triggers this problem:

https://bugs.kde.org/show_bug.cgi?id=268267

I have compiled digikam 2.3.0 from GIT with libgphoto support and encountered above mentioned problem. The bugreport suggest that there is visibility problem with usb_init() in libdc1394 library, which happens on my system:

    24132: binding file /usr/lib/libgphoto2_port/0.8.0/usb.so [0] to /usr/lib/libdc1394.so.22 [0]: normal symbol `usb_init'
    24132: binding file /usr/lib/libgphoto2_port/0.8.0/usb.so [0] to /usr/lib/libdc1394.so.22 [0]: normal symbol `usb_init'

catching bindings before crash suggests that 11.10 does not have the following patch applied:

http://sourceforge.net/tracker/?func=detail&atid=308157&aid=3361405&group_id=8157

Revision history for this message
Jürgen (j-w-ott) wrote :

Same Problem with Fuji Finepix S2500HD camera lists 3 folders
Fuji Finepix.. and USB PTP..
Both folders show the same content
It should only be one folder in my opinion

summary: - digikam cannot connect to Nikon cameras through PTP
+ digikam cannot connect to PTP cameras
Revision history for this message
Igor Petrovski (i-petrovski) wrote :

Have the same problem with CANON EOS 400D

Revision history for this message
themroc (rauchweihe) wrote :

Same Problem here with Fuji FinePix F30 on Kubutu Oneiric 11.10 amd64.

Import window does not open, if choose "Import with DigiKam" in device manager or manual clicking on the import button in DigiKam.

Revision history for this message
Edward Viesel (zwheeler) wrote :

Same problem with Canon PowerShot A720 IS in PTP mode after upgrading to Kubutu Oneiric 11.10 amd64 via KPackageKit.

Importing photos used to work completely automatically.

Running digikam from Konsole now leads to the following error message:

digikam(2029)/digikam (core): Failed to detect camera with GPhoto2 from Solid information.

Gwenview imports photos automatically.

I can also access the photos in Dolphin.

There is no autodetect button in the Settings/Cameras menu of digikam, by the way. According to the digikam manual there should be one.

Revision history for this message
themroc (rauchweihe) wrote :

@zwheeler: Note, for me (Fuji FinePix F30 -> PTP Camera too) the camera is listed (autodetect USB ...), but an import is not possible.

Gwenview can import from PTP cameras, but after importing all picture files have wrong rights! Only reading and deleting is allowed. Same wrong rights after copy & paste with Dolphin or an other file manager.
This is a serious problem for normal users, because normal user don't realize the wrong rights after import.

So, it is no longer possible for normal users to manage photos with kubuntu 11.10 oneiric.

Therefore I think this is a very important bug and it should be fixed as soon as possible.

Revision history for this message
Bohdan (bohdan-linda) wrote :

meanwhile, till someone notices this, this guy seems to fix this in his ppa. If you have enough trust, you can try:

https://launchpad.net/~philip5/+archive/extra

as a bonus you get digikam 2.2.0 . It works for me

Revision history for this message
Sod75 (launchpad-net-vernaillen) wrote :

they apparently left libgphoto2 support INTENTIONALLY to be able to ship digikam 2.1.1

https://bugs.kde.org/show_bug.cgi?id=284604#c2
see here(from the same guy that build the above ppa)

ugh, this is bad. favoring a shiny new addon over basic functionality is not the way forward.

Revision history for this message
themroc (rauchweihe) wrote :

https://launchpad.net/~philip5/+archive/extra

works for me too,

thanks @Bohdan

Revision history for this message
Edward Viesel (zwheeler) wrote :

Thanks, themroc, the problems with Gwenview and Dolphin have been well noted. I only used both to check if the camera and the photos are recognised.

I had a look at the bug report quoted by Sod75 (#18). Really bad, just leaving out libgphoto2 support. I've got a notebook with Kubuntu 11.04 still on it. I'll use that for the time being. I can always transfer a fully finished folder (album) with photos via USB stick or network.

Revision history for this message
Bohdan (bohdan-linda) wrote :

What is even worse, the source of this bug was well known long before launch of 11.10

https://bugs.launchpad.net/ubuntu/+source/libdc1394-22/+bug/835687

Revision history for this message
b3nmore (b3nmore) wrote :

Another workaround to get pictures from your PTP camera to your hdd: gtkam is nice little gui to libgphoto2, the library digikam refuses to work together with. That means, one can use it with every camera model digikam used to work with.

Revision history for this message
Biji (biji) wrote :

installing from
https://launchpad.net/~philip5/+archive/extra

give many dependency errors :(

Changed in digikam (Ubuntu):
status: Confirmed → Fix Released
description: updated
Revision history for this message
Kjetil Kjernsmo (kjetil) wrote :

Any idea if/when this fix will appear in an updated Oneiric package?

Revision history for this message
GarthPS (garthps) wrote :

yeah any idea ?

Revision history for this message
Marko Grönroos (magi) wrote :

Yes, any idea if this could be fixed in Oneiric? Doesn't seem to be fixed yet.

I confirm the issue with Canon G12.

Revision history for this message
Bill Metzenthen (billm-melbpc) wrote :

This bug has been here for months now. It is a big backward step for digikam. Can someone say why the fix hasn't appeared in an update, and when/if it might appear?

Revision history for this message
Bohdan (bohdan-linda) wrote :

add ppa mentioned above. I bet it will be properly fixed by 12.4 soonest

Revision history for this message
dusoft (dusoft-staznosti) wrote :

it works after adding ppa above and doing full update / upgrade process. however, this bug is Major and thus grave to many camera users, therefore it should have been fixed long ago, specially as digikam was working wonderfully before.

Revision history for this message
dusoft (dusoft-staznosti) wrote :

reporter, please change the importance to major!

Revision history for this message
Michel (michellammertink) wrote :

This issue also affects me. Digikam is useless for me without a fix. Using cannon ixus 55.

Thanks.

Revision history for this message
Marco De Simone (marco-desimone) wrote :

This bug affects me, I have digikam version 2:2.1.1-0ubuntu1 with a canon powershot sx220

Revision history for this message
Superman ha Muerto (superman-ha-muerto) wrote :

There is an alternative for those who use digikam as photo management software.

sudo apt-get install gphoto2

gphoto2 is a command line software to download images from the camera using command line.

To download all your pictures, just open a terminal window and type:

gphoto2 --get-all-files

It will download all files into the current directory.

To delete all the files in the camera:

gphoto2 --delete-all-files

and that's it. Then you can use digikam to process the images.

Revision history for this message
Superman ha Muerto (superman-ha-muerto) wrote :

Sorry, I made a mistake. To delete all the files in the camera:

gphoto2 -R --delete-all-files

And that's it (this time yes).

Revision history for this message
Stéphane (stephane-treboux) wrote :

The issue is not solved in Digikam 2.1.1 ( Ubuntu 11.10) but its status was changed to "resolved" by Erich Wurstbauer (erich-wurstbauer).

Does anyone knows if the problem is solved with Digikam 2.5.0 (coming in Ubuntu 12.04)?
Is a fix planned for Digikam 2.1?

Revision history for this message
ronny (ronny-standtke) wrote :

Unfortunately, I have to join in here. I just "upgraded" to Kubuntu-11.10 and Digikam no longer works with my PowerShot A2000. Great! It's stuff like this that makes me more and more nervous about upgrading any Ubuntu system at all. And I even thought that I waited long enough before upgrading this time... :-(

Revision history for this message
ErwanH (hamon-erwan) wrote :

Just updated to 12.04 Precise. This bug is gone with Digikam 2.5.0.

Revision history for this message
Jürgen (j-w-ott) wrote :

Bug is back in raring ringtail

Revision history for this message
themroc (rauchweihe) wrote :

I cannot confirm this.

For me (Fuji FinePix F30 -> PTP Camera too) the camera is listed (autodetect USB ...) and an import is possible.

Revision history for this message
Paul Donohue (s-launchpad-paulsd-com) wrote :

The raring issue appears to be https://bugs.kde.org/show_bug.cgi?id=311393 (fixed upstream).

Revision history for this message
Stéphane (stephane-treboux) wrote :

It seems that there is a regression in Kubuntu 16.10.
digikam 4:4.14.0-4ubuntu6 is built without libgphoto2 support.
"ldd /usr/bin/digikam | grep gph" gives no result.
gtkam works fine as a workaround.

Revision history for this message
FranJPR (fjperezor) wrote :

I confirm the regression in Kubuntu 16.10 and digikam 4:14.0. With former versions digikam autodetected my canon EOS and I could import pictures without any problem. After the upgrade digikam recognizes the camera but importing pictures is not working at all. I am able to copy files directly from dolphin though (however importing options from digikam are gone).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.