FFe: digkam 2.0.0

Bug #834190 reported by Philip Muškovac on 2011-08-25
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
digikam (Ubuntu)
Undecided
Rohan Garg

Bug Description

This needs either the opencv MIR (bug 324523) approved first or digikam demoted to universe.

http://digikam.org/drupal/node/616

Digikam 2.0.0 adds many new features, taken from NEWS:
General : XMP metadata sidecar support.
General : Reverse geo-coding support.
General : Face detection and recognition support.
General : Tag keyboard shortcuts support.
General : Color Labels support to improve photograph workfow.
General : Pick Labels support to improve photograph selection.
General : Color Theme engine is now ported to KDE color theme manager.
General : MySQl support improvements. Dependency is now optional.
General : Added JPEGTurbo library support.
General : Update internal LibPGF to 6.11.24 with OpenMP support.
AlbumGUI : Re-designed Filters view on right sidebar to perform icon-view items filtering.
AlbumGUI : Add options to group/ungroup items from icon-view.
AlbumGUI : Add options to show file format over icon-view items.
ImageEditor : Image versionning support.
ImageEditor : Foveon sensor based camera.
ImageEditor : New advanced RAW decoding settings backported from RawTherapee project.
AdvancedRename : New datetime option "UnixTimeStamp" (requires Qt 4.7 or higher)

see full news for the fixed bugs:
https://projects.kde.org/projects/extragear/graphics/digikam/repository/revisions/master/entry/project/NEWS.2.0.0

this also fixes the geolocation support that has been broken in 1.9.0 in the archive after the upload of KDE 4.7

ISSUES: gphoto2 support is disabled since it causes the build to fail with a DSO error.

This release also ships a new release of kipi-plugins:
GPSSync : Complete rewrite of GUI, including reverse-geocoding feature.
YandexFotki : New tool to export collection to Yandex web service (http://fotki.yandex.ru).
MediaWiki : New tool to export collection to MediaWiki based web service (http://www.mediawiki.org).
RajceExport : New tool to export collection to Rajce web service (http://www.rajce.idnes.cz).
MetadataEdit : Factoring Exif/Iptc/Xmp editor to a common dialog.

which fixes a bunch of bugs too:
https://projects.kde.org/projects/extragear/graphics/kipi-plugins/repository/revisions/master/entry/project/NEWS.2.0.0

Related branches

Philip Muškovac (yofel) on 2011-08-25
Changed in digikam (Ubuntu):
status: New → Incomplete
Philip Muškovac (yofel) on 2011-08-27
description: updated
Philip Muškovac (yofel) wrote :

PPA build log from oneiric amd64

Philip Muškovac (yofel) wrote :

Installation log:
Selecting previously deselected package libkface1.
(Reading database ... 439495 files and directories currently installed.)
Unpacking libkface1 (from .../libkface1_2%3a2.0.0-0ubuntu1~ppa5_amd64.deb) ...
Selecting previously deselected package libkgeomap1.
Unpacking libkgeomap1 (from .../libkgeomap1_2%3a2.0.0-0ubuntu1~ppa5_amd64.deb) ...
Selecting previously deselected package digikam-data.
Unpacking digikam-data (from .../digikam-data_2%3a2.0.0-0ubuntu1~ppa5_all.deb) ...
Selecting previously deselected package digikam.
Unpacking digikam (from .../digikam_2%3a2.0.0-0ubuntu1~ppa5_amd64.deb) ...
Selecting previously deselected package kipi-plugins-common.
Unpacking kipi-plugins-common (from .../kipi-plugins-common_2%3a2.0.0-0ubuntu1~ppa5_all.deb) ...
Selecting previously deselected package kipi-plugins.
Unpacking kipi-plugins (from .../kipi-plugins_2%3a2.0.0-0ubuntu1~ppa5_amd64.deb) ...
Selecting previously deselected package libkmediawiki1.
Unpacking libkmediawiki1 (from .../libkmediawiki1_2%3a2.0.0-0ubuntu1~ppa5_amd64.deb) ...
Selecting previously deselected package showfoto.
Unpacking showfoto (from .../showfoto_2%3a2.0.0-0ubuntu1~ppa5_amd64.deb) ...
Selecting previously deselected package digikam-dbg.
Unpacking digikam-dbg (from .../digikam-dbg_2%3a2.0.0-0ubuntu1~ppa5_amd64.deb) ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for hicolor-icon-theme ...
Setting up libkface1 (2:2.0.0-0ubuntu1~ppa5) ...
Setting up libkgeomap1 (2:2.0.0-0ubuntu1~ppa5) ...
Setting up digikam-data (2:2.0.0-0ubuntu1~ppa5) ...
Setting up digikam (2:2.0.0-0ubuntu1~ppa5) ...
Setting up kipi-plugins-common (2:2.0.0-0ubuntu1~ppa5) ...
Setting up kipi-plugins (2:2.0.0-0ubuntu1~ppa5) ...
Setting up libkmediawiki1 (2:2.0.0-0ubuntu1~ppa5) ...
Setting up showfoto (2:2.0.0-0ubuntu1~ppa5) ...
Setting up digikam-dbg (2:2.0.0-0ubuntu1~ppa5) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

Changed in digikam (Ubuntu):
status: Incomplete → New
Changed in digikam (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

How about digikam 2.1.0 while you're at it?

Rohan Garg (rohangarg) wrote :

Currently packaging digikam 2.1.1

Changed in digikam (Ubuntu):
assignee: nobody → Rohan Garg (rohangarg)
Achim Bohnet (allee) wrote :

FWIW: Philipp Matthias Hahn did yesterday include his pkging work for 2.0 2.1 and 2.1.1 in Debian Bug#628019.

Rohan Garg (rohangarg) wrote :

Also note, Digikam has been demoted to Universe status now, it can now build with all required deps

Martin Pitt (pitti) wrote :

Are all these new features relative to the current 1.9.0, or to the previous stable? I'm not familiar with the versioning here, whether 1.9 is a beta for 2.0 (then we should ceratinly update), or a stable release in its own right.

Sandra Karuving (lumks) wrote :

1.9 was the last stable of the 1.9 branch and is \"not maintained anymore\" (http://www.digikam.org/drupal/about/releaseplan) it is from march(!) 2011. so the most of us will forced to use some ppa in an future release of ubuntu to get the latest version (atm digikam 2.1.1).

Complaining won't get it done any faster.

elguavas (elguavas.) wrote :

> Complaining

this is not complaining but quite pertinent information: "...the 1.9 branch and is \"not maintained anymore\" ..."

> won't get it done any faster.

so, it is getting done? Martin was asking about 2.0 above, since then there have been a couple of point point releases and a full point release, so upstream is now at 2.1.1.

i agree it would be a big shame for 11.10 to ship with an outdated digikam.

anyway, keep up the good work packaging types,
cheers,
stephen.

Scott Kitterman (kitterman) wrote :

OK. We knew already.

I expect we'll have it in in the next few days.

Achim Bohnet (allee) wrote :

2.2.1 digikam pkgs for testing are available for oneiric in:

   ppa:kubuntu-ppa/experimental

please report success and/or failure.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package digikam - 2:2.1.1-0ubuntu1

---------------
digikam (2:2.1.1-0ubuntu1) oneiric; urgency=low

  [ Rohan Garg ]
  * New upstream release (LP: #834190)
    - debian/control
      + Build with libqtwebkit-dev
   - debian/kipi-plugins-common
      + Install libkvkontakte required by kipi-plugins
   - debian/digikam
      + Install panoramagui

  [ Philip Muškovac ]
  * New upstream release
    - debian/control:
      + Add libcv-dev, libcvaux-dev, libhighgui-dev, libboost-graph1.46-dev,
        libksane-dev, libxml2-dev, libxslt-dev, libqt4-opengl-dev, libqjson-dev,
        libgpod-dev and libqca2-dev to build-deps
      + Add packages for kipi-plugins, libmediawiki, libkface, libkgeomap and
        libkvkontakte
    - debian/rules:
      + Don't build with gphoto2 since it doesn't build with it.
    - Add kubuntu_fix_test_linking.diff to fix linking of the dngconverter test
    - update install files
    - update kubuntu_01_mysqld_executable_name.diff for new cmake layout
      and rename to kubuntu_mysqld_executable_name.diff
  * Fix typo in digikam-data description (LP: #804894)
  * Fix Vcs links

  [ Felix Geyer ]
  * Move library data files to the new packages libkface-data, libkgeomap-data
    and libkvkontakte-data.
  * Override version of the embedded library packages to 1.0~digikam<version>.
  * Exclude the library packages from digikam-dbg to prevent file conflicts in
    the future.
  * Call dh_install with --list-missing.
 -- Felix Geyer <email address hidden> Fri, 23 Sep 2011 18:18:55 +0200

Changed in digikam (Ubuntu):
status: Confirmed → Fix Released
Sandra Karuving (lumks) wrote :

Thank you for this :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers