FFe for digikam 1.0.0-beta5 (merge with debian)

Bug #445232 reported by Luka Renko
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
digikam (Ubuntu)
Fix Released
Wishlist
Unassigned

Bug Description

Binary package hint: digikam

I would like to request FFe for latest version of digikam 1.0.0 beta release (beta5).

The release schedule of digikam 1.0.0 is a bit unfortunate for Karmic: http://www.digikam.org/drupal/about/releaseplan
Beta5 is the last release of digikam 1.0.0 that we can have in time for Karmic, going back with older 0.10.0 release (first KDE4 release of the application) is also not a good option, therefore we will stay with beta release for Karmic. The plan is to provide future beta6, RC and final releases via backports to Karmic users.

Current beta version in Karmic is two releases behind (beta3) and should be updated to latest in order to improve our collaboration with upstream (reporting bugs...).

I have merged prepared the beta5 package by merging Ubuntu changes to Debian/unstable packages. Test packages are available in my PPA:
https://launchpad.net/~lure/+archive/ppa/+packages

Merged changes are committed to bzr branch:
https://code.launchpad.net/~kubuntu-members/digikam/ubuntu

Related branches

Luka Renko (lure)
Changed in digikam (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Jonathan Riddell (jr) wrote :

ACK from me after we get some folks to test it

Revision history for this message
Luka Renko (lure) wrote :

I did basic testing of PPA packages and could not find any obvious regression.

For upload, please use orig.tar.gz from debian:
http://ftp.de.debian.org/debian/pool/main/d/digikam/digikam_1.0.0~beta5.orig.tar.gz

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package digikam - 2:1.0.0~beta5-1ubuntu1

---------------
digikam (2:1.0.0~beta5-1ubuntu1) karmic; urgency=low

  * New upstream release (LP: #445232)
  * Merge with Debian, remaining changes:
    - Export .pot name and copy to plugins in debian/rules
    - Remove liblqr-1-0-dev from build-deps, not in main

digikam (2:1.0.0~beta5-1) unstable; urgency=low

  * New upstream release
  * Remove 01_dont_use_tests_directory.diff - fixed upstream
  * Add libx11-dev build dependency to fix a ftbfs
  * Update Standards Version to 3.8.3 (no changes needed)

digikam (2:1.0.0~beta4-2) unstable; urgency=low

  [ José Manuel Santamaría Lema ]

  * Add 01_dont_use_tests_directory.diff patch:
    - avoid including the "tests" directory (Closes: #544677, #545436)

digikam (2:1.0.0~beta4-1) unstable; urgency=low

  * New upstream release
  * top level tests/ required

 -- Luka Renko <email address hidden> Wed, 07 Oct 2009 07:11:34 +0200

Changed in digikam (Ubuntu):
status: New → Fix Released
Lyn (lynylynyl)
description: updated
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers