[karmic] Digikam does not display anything in the main pane

Bug #377560 reported by Michael Marley on 2009-05-17
52
This bug affects 7 people
Affects Status Importance Assigned to Milestone
digikam (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: digikam

I just installed Digikam on my Karmic test box, and nothing at all displays in the main (right) window pane. In Jaunty, all of the images would be displayed there. All other functions of Digikam (like slideshows) seem to work, though.

PCC (p-c-chan) wrote :

I have a similar issue on karmic. Digikam claimed it could not load the kio's but they were actually there.

digikam(24012): couldn't create slave: "Unable to create io-slave:
klauncher said: Error loading 'kio_digikamdates'.
"
digikam(24012): couldn't create slave: "Unable to create io-slave:
klauncher said: Error loading 'kio_digikamalbums'.

It happened only when I was going through kdm. If I didn't run kdm, i.e. xinit and then digikam (or xinit, startkde and then digikam), digikam had no issue in displaying the albums.

 It looks like kdm may have caused an issue on klauncher/digikam, probably a path, an environment.

I've not figured out what is wrong yet.

Michael Marley (mamarley) wrote :

Apparently, Digikam just needs to be rebuilt against the KDE 4.3 libraries, and possibly other Karmic-specific things. I did a test build with my pbuilder, and it seems to be working fine. I am uploading it to my PPA now, so maybe you could give it a shot once it finishes uploading and building.

The Ubuntu machine is at work. I'll try it out monday. I am running Debian unstable at home. Digikam works with respect to the kio issue on the Debian.

I hit quit a bit of issues in kde4 on both machines. Kde3 has been solid for a long time.

Thanks,
P. C.

> Date: Sat, 23 May 2009 12:10:18 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 377560] Re: [karmic] Digikam does not display anything in the main pane
>
> Apparently, Digikam just needs to be rebuilt against the KDE 4.3
> libraries, and possibly other Karmic-specific things. I did a test
> build with my pbuilder, and it seems to be working fine. I am uploading
> it to my PPA now, so maybe you could give it a shot once it finishes
> uploading and building.
>
> --
> [karmic] Digikam does not display anything in the main pane
> https://bugs.launchpad.net/bugs/377560
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “digikam” source package in Ubuntu: New
>
> Bug description:
> Binary package hint: digikam
>
> I just installed Digikam on my Karmic test box, and nothing at all displays in the main (right) window pane. In Jaunty, all of the images would be displayed there. All other functions of Digikam (like slideshows) seem to work, though.

_________________________________________________________________
Internet explorer 8 lets you browse the web faster.
http://go.microsoft.com/?linkid=9655582

PCC (p-c-chan) wrote :

_________________________________________________________________
Create a cool, new character for your Windows Live™ Messenger.
http://go.microsoft.com/?linkid=9656621

PCC (p-c-chan) wrote :

Micheal,

Sorry to send you a blank, the hotmail user agent bug hit again.

When should I be downloading the new digikam?

Regards,
P. C.

> Date: Sat, 23 May 2009 12:10:18 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 377560] Re: [karmic] Digikam does not display anything in the main pane
>
> Apparently, Digikam just needs to be rebuilt against the KDE 4.3
> libraries, and possibly other Karmic-specific things. I did a test
> build with my pbuilder, and it seems to be working fine. I am uploading
> it to my PPA now, so maybe you could give it a shot once it finishes
> uploading and building.
>
> --
> [karmic] Digikam does not display anything in the main pane
> https://bugs.launchpad.net/bugs/377560
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “digikam” source package in Ubuntu: New
>
> Bug description:
> Binary package hint: digikam
>
> I just installed Digikam on my Karmic test box, and nothing at all displays in the main (right) window pane. In Jaunty, all of the images would be displayed there. All other functions of Digikam (like slideshows) seem to work, though.

_________________________________________________________________
Create a cool, new character for your Windows Live™ Messenger.
http://go.microsoft.com/?linkid=9656621

Michael Marley (mamarley) wrote :

It is in my PPA. https://edge.launchpad.net/~thefirstm/+archive/karmic-testing You can either add the PPA to your sources, or just download the package and install it manually.

PCC (p-c-chan) wrote :

_________________________________________________________________
Internet explorer 8 lets you browse the web faster.
http://go.microsoft.com/?linkid=9655582

Shura (shura01) wrote :

Hi,

Same problem here (nothing is displayed in the main panel).
KDE 4.3 b1 and Kubuntu 9.04.

Michael Marley (mamarley) wrote :

Have you tried the package from my PPA yet?

Shura (shura01) wrote :

The digikam package in your PPA is only for Karmic, isn't it ?
It will be ok if i download the .deb and install it on my Jaunty ?

Michael Marley (mamarley) wrote :

It should work fine, since you are running KDE 4.3. Just make sure that you manually install the one package, because some of the other packages I have there might break your system.

Shura (shura01) wrote :

I've just tried and it doesn't work.
It miss some newer versions of the following libs :
libgphoto2-2 (>= 2.4.3) (Jaunty version is 2.4.2)
libgphoto2-port0 (>= 2.4.3) (Jaunty version is 2.4.2)
libqt4-phonon (>= 4.5.1) (Not installed (not useful ?) in Jaunty)

Michael Marley (mamarley) wrote :

Oops. I wasn't thinking about dependencies. You shouldn't try to install the packages from Karmic, because the QT package would probably break your system. My recommendation would be to contact one of the maintainers of the KDE 4.3 PPA and ask him/her to upload the digikam package, referencing this bug.

Changed in digikam (Ubuntu):
status: New → Confirmed
PCC (p-c-chan) wrote :

Yes I have and it works.

Did you get a blank message again?

> Date: Mon, 25 May 2009 17:02:19 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 377560] Re: [karmic] Digikam does not display anything in the main pane
>
> Have you tried the package from my PPA yet?
>
> --
> [karmic] Digikam does not display anything in the main pane
> https://bugs.launchpad.net/bugs/377560
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “digikam” source package in Ubuntu: New
>
> Bug description:
> Binary package hint: digikam
>
> I just installed Digikam on my Karmic test box, and nothing at all displays in the main (right) window pane. In Jaunty, all of the images would be displayed there. All other functions of Digikam (like slideshows) seem to work, though.

_________________________________________________________________
Internet explorer 8 lets you browse the web faster.
http://go.microsoft.com/?linkid=9655582

Sorry I lost my change to general.useragent.vendor setting on firefox restart again, probably when there was another useragent switch extension enabled.

It is very annoying when hotmail keeps doing strange things when vendor string was set to ubuntu.

Before we could not write anything into the mail content, now it would blank out the entire content on save or send. MS has made it less obvious and more evil since.

> Date: Mon, 25 May 2009 18:28:54 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: RE: [Bug 377560] Re: [karmic] Digikam does not display anything in the main pane
>
>
> Yes I have and it works.
>
> Did you get a blank message again?
>
> > Date: Mon, 25 May 2009 17:02:19 +0000
> > From: <email address hidden>
> > To: <email address hidden>
> > Subject: [Bug 377560] Re: [karmic] Digikam does not display anything in the main pane
> >
> > Have you tried the package from my PPA yet?
> >
> > --
> > [karmic] Digikam does not display anything in the main pane
> > https://bugs.launchpad.net/bugs/377560
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
> > Status in “digikam” source package in Ubuntu: New
> >
> > Bug description:
> > Binary package hint: digikam
> >
> > I just installed Digikam on my Karmic test box, and nothing at all displays in the main (right) window pane. In Jaunty, all of the images would be displayed there. All other functions of Digikam (like slideshows) seem to work, though.
>
> _________________________________________________________________
> Internet explorer 8 lets you browse the web faster.
> http://go.microsoft.com/?linkid=9655582
>
> --
> [karmic] Digikam does not display anything in the main pane
> https://bugs.launchpad.net/bugs/377560
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “digikam” source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: digikam
>
> I just installed Digikam on my Karmic test box, and nothing at all displays in the main (right) window pane. In Jaunty, all of the images would be displayed there. All other functions of Digikam (like slideshows) seem to work, though.

_________________________________________________________________
Windows Live helps you keep up with all your friends, in one place.
http://go.microsoft.com/?linkid=9660826

Adam Reeve (adreeve) wrote :

Same issue here. I get this in my .xsession-errors:

kdeinit4: preparing to launch
Could not open library '/usr/lib/kde4/kio_digikamalbums.so'.
Cannot load library /usr/lib/kde4/kio_digikamalbums.so: (/usr/lib/libdigikamcore.so.1: undefined symbol: _ZN6Marble12MarbleWidget16addPlaceMarkDataERK7QStringS3_)
digikam(3955): couldn't create slave: "Unable to create io-slave:
klauncher said: Error loading 'kio_digikamalbums'.

I did file this at bugs.kde.org (https://bugs.kde.org/show_bug.cgi?id=195079) but was told this is a Kubuntu issue with libmarblewidget.

Michael Marley (mamarley) wrote :

This appears to be fixed by the latest build.

Changed in digikam (Ubuntu):
status: Confirmed → Fix Released
Adam Reeve (adreeve) wrote :

Yes after the updates today this is now fixed.

Shura (shura01) wrote :

The problem is still present in Kubuntu 9.04 (KDE 4.3 Beta2). Any solution ?
Thanks.

Michael Marley (mamarley) wrote :

The fix, right now, is only for Karmic. You need to send an email to someone on the kubuntu-ppa team and ask them to upload DigiKam. I am sure they will.

Shura (shura01) wrote :

Ok, I'll do that. Thank you.

Shura (shura01) wrote :

Fix for Jaunty released in kubuntu-experimental ppa (beware it contains KDE 4.3 beta too).
A big Thanks to alessandro ;)

Michael Marley (mamarley) wrote :

The bug doesn't occur, though, unless you have KDE 4.3.

Shura (shura01) wrote :

What do you mean ? I had the problem before KDE 4.3, and also after 4.3, And now it is fixed.

Dmitriy Volk (dmitriy-volk) wrote :

Shura, where exactly does it appear in kubuntu-experimental?

I am experiencing the same bug as described before, running Kubuntu 9.04 + KDE 4.3 rc1

Shura (shura01) wrote :

The fix was here : https://launchpad.net/~kubuntu-ppa/+archive/experimental
Now there is the 1.0.0 beta1 version, but it fixes the bug too I guess.

T. Middleton (timtoo) wrote :

beta1 works, but it has other significant bugs. So be careful.

Due to crashes and weirdness, I've had to switch to gwenview for doing photo file management, until some glorious day i have time to build myself beta3 since no one seems to be updating any ppa's since beta1.

I still use beta1 for tagging, editing, importing and viewing though.

Michael Marley (mamarley) wrote :

I have beta3 in my PPA.

tlu (thomas-ludwig-gmx) wrote :

I can confirm that beta1 works for me although I haven't tested it thoroughly for other bugs.

tlu (thomas-ludwig-gmx) wrote :

I can confirm that beta1 works for me with KDE 4.3 final although I haven't tested it thoroughly for other bugs.

I just updated my desktop which is Debian to 4.3, the 2.1 beta3 digikam there stops working the same way. I put beta1 from Ubuntu onto the Debian, it actually worked. It shows all the pictures and videos. It looks like we are not out of the woods yet.

> Date: Wed, 5 Aug 2009 13:50:33 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 377560] Re: [karmic] Digikam does not display anything in the main pane
>
> I can confirm that beta1 works for me with KDE 4.3 final although I
> haven't tested it thoroughly for other bugs.
>
> --
> [karmic] Digikam does not display anything in the main pane
> https://bugs.launchpad.net/bugs/377560
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “digikam” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: digikam
>
> I just installed Digikam on my Karmic test box, and nothing at all displays in the main (right) window pane. In Jaunty, all of the images would be displayed there. All other functions of Digikam (like slideshows) seem to work, though.

_________________________________________________________________
More storage. Better anti-spam and antivirus protection. Hotmail makes it simple.
http://go.microsoft.com/?linkid=9671357

I got another update yesterday still beta3, 2:1.0.0~beta3-1+b1. This one works.

> Date: Thu, 6 Aug 2009 05:21:00 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: RE: [Bug 377560] Re: [karmic] Digikam does not display anything in the main pane
>
>
> I just updated my desktop which is Debian to 4.3, the 2.1 beta3 digikam there stops working the same way. I put beta1 from Ubuntu onto the Debian, it actually worked. It shows all the pictures and videos. It looks like we are not out of the woods yet.
>
> > Date: Wed, 5 Aug 2009 13:50:33 +0000
> > From: <email address hidden>
> > To: <email address hidden>
> > Subject: [Bug 377560] Re: [karmic] Digikam does not display anything in the main pane
> >
> > I can confirm that beta1 works for me with KDE 4.3 final although I
> > haven't tested it thoroughly for other bugs.
> >
> > --
> > [karmic] Digikam does not display anything in the main pane
> > https://bugs.launchpad.net/bugs/377560
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
> > Status in “digikam” package in Ubuntu: Fix Released
> >
> > Bug description:
> > Binary package hint: digikam
> >
> > I just installed Digikam on my Karmic test box, and nothing at all displays in the main (right) window pane. In Jaunty, all of the images would be displayed there. All other functions of Digikam (like slideshows) seem to work, though.
>
> _________________________________________________________________
> More storage. Better anti-spam and antivirus protection. Hotmail makes it simple.
> http://go.microsoft.com/?linkid=9671357
>
> --
> [karmic] Digikam does not display anything in the main pane
> https://bugs.launchpad.net/bugs/377560
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “digikam” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: digikam
>
> I just installed Digikam on my Karmic test box, and nothing at all displays in the main (right) window pane. In Jaunty, all of the images would be displayed there. All other functions of Digikam (like slideshows) seem to work, though.

_________________________________________________________________
Stay on top of things, check email from other accounts!
http://go.microsoft.com/?linkid=9671355

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.