MediaWiki option not available in Export menu when plugin activated.

Bug #1322965 reported by Brylie Christopher Oxley
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
digiKam
Fix Released
High
kipi-plugins
Undecided
Unassigned
digikam (Ubuntu)
Undecided
Unassigned

Bug Description

I am not able to locate the MediaWiki option in the Export menu. I have double checked that the plugin is activated in my digiKam settings.

This has been an issue since Ubuntu 12.04, and continues on Kubuntu 14.04.

Revision history for this message
In , Brylie Christopher Oxley (brylie) wrote :

Created attachment 86324
Screenshot showing Export menu; no MediaWiki option.

I am not able to locate the MediaWiki option in the Export menu. I have double checked that the plugin is activated in my digiKam settings. How can I troubleshoot?

Revision history for this message
In , Brylie Christopher Oxley (brylie) wrote :

Created attachment 86325
Screenshot showing the Kipi Plugins section of digiKam settings; MediaWiki is checked.

Revision history for this message
In , Brylie Christopher Oxley (brylie) wrote :

I installed kdegraphics 4.13, disabled and reenabled the plugin, and the it still doesn't appear in the export menu.

Revision history for this message
Brylie Christopher Oxley (brylie) wrote :
Revision history for this message
Brylie Christopher Oxley (brylie) wrote :

Adding screenshot of digiKam export menu.

Revision history for this message
Harald Sitter (apachelogger) wrote :

It appears that for some reason kipi-plugins doesn't actually detect a shlibs dep to libmediawiki1.

affects: kipi-plugins (Ubuntu) → digikam (Ubuntu)
Changed in kipi-plugins:
status: New → Invalid
Changed in digikam:
importance: Unknown → High
status: Unknown → New
Revision history for this message
In , Caulier-gilles-9 (caulier-gilles-9) wrote :

Brylie,

Using last stable digiKam 4.2.0, the problem is not reproducible here.

Can you try agaian with a more recent release of digiKam.

Thanks in advance

Gilles Caulier

Changed in digikam:
status: New → Invalid
Revision history for this message
Brylie Christopher Oxley (brylie) wrote :

I just installed digiKam 4.2.0 on Edubuntu 14.10. The plugin is enabled in preferences, but still does not show up in the export menu.

Revision history for this message
In , Brylie Christopher Oxley (brylie) wrote :

What distribution were you using when you tried to reproduce? How had you installed digiKam 4.2.0?

Revision history for this message
In , Brylie Christopher Oxley (brylie) wrote :

Giles,
I am still unable to see the MediaWiki export under Kipi plugins. I am now using Ubuntu 16.04 (KDE Neon edition). I have installed:

- Digikam 5.2.0
- kipi-plugins
- libmediawiki1

Revision history for this message
In , Brylie Christopher Oxley (brylie) wrote :

Sorry,
Gilles*

Revision history for this message
In , Caulier-gilles-9 (caulier-gilles-9) wrote :

Can you reproduce the problem use last digiKam Linux AppImage bundle ?

https://drive.google.com/open?id=0BzeiVr-byqt5Y0tIRWVWelRJenM

Typically I cannot here. Mediawiki tool still here.

Gilles Caulier

Revision history for this message
In , Caulier-gilles-9 (caulier-gilles-9) wrote :

Problem fixed in 6.0.0 where all tools are now in digiKam core

Changed in digikam:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.